Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

VMWare-Tools productLocker-Ordner beschädigt?

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon cotec » 11.04.2017, 16:18

Hallo,

ich habe festgestellt, dass ich bei einem (6.0 Patch 2) meiner drei ESX-Hosts (6.0 Patch 3) kein VMWare-Tools Update mehr durchführen kann:
Bild

nun habe ich mich dran erinnert, dass die ISO Images zum mounten des CD-Laufwerks ja unter /vmimages liegen, also wollte ich nachschauen was mit dem ISO los ist.
mittels
Bild
okay, ist ein symbolischer Link, gehen wir also in den Ordner /productlocker und suchen da weiter
und da stellte ich dann das hier fest:
locker.JPG


Der USB-Stick im Server (auf dem ESXi installiert ist) ist geschätzt 4 Jahre alt. Meiner Meinung hat der USB Stick (auf dem ESXi installiert ist) das zeitliche gesegnet bzw. wird das zeitliche segnen. Oder wie würdet ihr das sehen? Auf meinen anderen 2 ESXi-Hosts existiert der Buchstabensalat jedenfalls nicht.
Neustarten des Hosts ist (derzeit) ohne Probleme möglich, aber wie gesagt - weder eine VMWare Tools installation lässt sich mit diesem realisieren, noch kann ich mittels neuerem ESXi-ISO eine Update-Installation durchführen.

Einziger Weg den ich derzeit sehe:
Config-Backup -> Neuinstallation (ggf. auf neuem Stick) mit gleicher ESXi-Buildnummer -> Config-Recover und anschließend nochmal versuchen das ESXI-Update und anschließend die VMWare-Tools zu installieren.

Oder habt ihr eine andere Idee, wie ich den ESXi hier noch "retten" könnte?

Gruß
cotec
Dateianhänge
locker3.JPG
locker2.JPG

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon ~thc » 11.04.2017, 20:50

Config-Backup -> Neuinstallation (ggf. auf neuem Stick) mit gleicher ESXi-Buildnummer -> Config-Recover und anschließend nochmal versuchen das ESXI-Update und anschließend die VMWare-Tools zu installieren.

Im Prinzip ja, aber bitte bedenken, dass auch "/bootbank" und "/altbootbank" nicht mehr funktionieren. Die Konfiguration des ESXi wird normalerweise dort abgelegt. Sollte das Config-Backup darauf verzichten können, ist es machbar.

Alternativ kann man mit ein paar Kommandos auf der Shell die Konfiguration auslesen.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon rprengel » 12.04.2017, 07:28

~thc hat geschrieben:
Config-Backup -> Neuinstallation (ggf. auf neuem Stick) mit gleicher ESXi-Buildnummer -> Config-Recover und anschließend nochmal versuchen das ESXI-Update und anschließend die VMWare-Tools zu installieren.

Im Prinzip ja, aber bitte bedenken, dass auch "/bootbank" und "/altbootbank" nicht mehr funktionieren. Die Konfiguration des ESXi wird normalerweise dort abgelegt. Sollte das Config-Backup darauf verzichten können, ist es machbar.

Alternativ kann man mit ein paar Kommandos auf der Shell die Konfiguration auslesen.



Ich habe miitlerweile alle USB Sticks durch einfache Notebook-Sata-Platten ersetzt. Die Kosten nicht die Welt und sind um Längen zuverlässiger.
Kostet mich zwar einen Sata-Anschluss aber in meinen Geräte sind dann noch immer 5 verfügbar.

Gruss

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon cotec » 12.04.2017, 08:47

~thc hat geschrieben:Im Prinzip ja, aber bitte bedenken, dass auch "/bootbank" und "/altbootbank" nicht mehr funktionieren. Die Konfiguration des ESXi wird normalerweise dort abgelegt. Sollte das Config-Backup darauf verzichten können, ist es machbar.

Alternativ kann man mit ein paar Kommandos auf der Shell die Konfiguration auslesen.


ich hab zum exportieren jetzt den befehl hier direkt an der konsole genutzt:

To backup the configuration data for an ESXi host, run this command:
vim-cmd hostsvc/firmware/backup_config
Quelle: https://kb.vmware.com/selfservice/micro ... Id=2042141


die anderen beiden von dir genannten Ordner sehen gut aus:
alt.JPG

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon ~thc » 12.04.2017, 09:17

O.K. - dann ist nur die "locker"-Partition (und nicht der gesamte Stick) offensichtlich beschädigt.

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon cotec » 12.04.2017, 10:23

mal ganz dumm gefragt...
kann ich dann nicht einfach versuchen den Ordner zu leeren und von einem funktionierendem Host die drei Ordner reinkopieren? :?

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon ~thc » 12.04.2017, 11:10

Prinzipiell ja - wenn nur das Dateisystem verwurstet wurde, der Stick an dieser Stelle (Partition) nicht physisch defekt ist und du eine Quelle mit exakt dem gleichen Stand hast.

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon mbreidenbach » 12.04.2017, 14:11

Den productLocker Ordner kann man übrigens umleiten und so gezielt bestimmte VMware Tools Versionen verteilen.

https://blogs.vmware.com/vsphere/2015/1 ... -read.html

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

Re: VMWare-Tools productLocker-Ordner beschädigt?

Beitragvon cotec » 18.04.2017, 11:23

nur zur Info.

Hab die Konfig sichern können, anschließend das identische ISO erneut installiert, temporär eine neue IP-vergeben, Backup wieder eingespielt, neugestartet und alles i.O.

Thread kann geschlossen werden, Vielen Dank für die Unterstützung. :)


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast