Die Foren-SW läuft schon geraume Zeit ohne erkennbare Probleme. Sollte etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

[solved] Upload von großen ISOs bricht immer ab

Virtualisierungsmanagement, Servermanagement.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

[solved] Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 06.05.2020, 11:29

Hallo zusammen,

ich habe heute die ehrenvolle Aufgabe bekommen mir das Problem mit den Uploads der großen Dateien anzuschauen.
Wir haben eine Vmware 6.7 und ein vCenter Version 6 Standard.
Unser Problem ist, dass es bei einem Upload eines Windows Server ISOs nach 38% einen Fehler gibt.

Der Vorgang ist fehlgeschlagen
Der Vorgang ist aus einem unbekannten Grund fehlgeschlagen. Dieses Problem tritt in der Regel aufgrund von Zertifikaten auf, die der Browser nicht als vertrauenswürdig erkennt. Wenn Sie selbstsignierte oder benutzerdefinierte Zertifikate verwenden, öffnen Sie die folgende URL in einer neuen Registerkarte im Browser und akzeptieren Sie das Zertifikat. Wiederholen Sie anschließend den Vorgang.

https://dnsname-eines-esx-hosts.domäbe.local

Wenn das Problem dadurch nicht behoben werden kann, stehen im folgenden KB-Artikel weitere mögliche Lösungen bereit: http://kb.vmware.com/kb/2147256

Nein das Problem wurde dadurch nicht behoben oder ich habe was falsch gemacht bei der Importierung der Zertifikate.
Ich habe die Zertifikate aus dem Download der vCenterseite in den vertrauenswürdigen Stammzertifizierungen installiert und war hoch erfreut die neue gparted live CD hochladen zu können. die hatte 338MB. Das Problem ist gelöst ... Pustekuchen! Windows ISO Upload wird mit dem oben genannten Fehler beendet und in dem Datastore liegen 358MB Windows Server ISO. Die Quelle ist schon ein wenig größer.
Könnt ihr mir bei dem Problem unter die Arme greifen?

Gruß Thomas

King of the Hill
Beiträge: 12867
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Upload von großen ISOs bricht immer ab

Beitragvon Dayworker » 06.05.2020, 11:43

Deine Angaben sind etwas mißverständlich. Das vCenter sollte immer die höchste oder zumindest die gleiche Versionsnummer wie die höchste eingesetze ESXi-Version tragen.

Genug Platz im DS setze ich mal voraus. Mit welchem Browser versuchst du den Upload? Mal testweise den Upload per SSH probiert?

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Upload von großen ISOs bricht immer ab

Beitragvon irix » 06.05.2020, 13:18

Aeh.... wenn deine Dateien teilweise hochgeladen worden sind dann kann es kein Problem mit den Zertifikaten sein weil das schlaegt bei 0% zu.

Des weiteren ist es mit den Zertifikaten folgender massen. Ja du bist mit dem vCenter verbunden.... das vCenter sucht sich aber nun im Hintergrund einen ESXi aus und der ist die Quelle der Zertifikatswarnung. Du must quasi alle ESXi Hosts Zertifikaten mal importiert haben.

Wir haben die ISOs auf einem NFS + CIFS welches eine Linux VM bereit stellt. So koennen wir/Kunden das bequem vom Windows aus hinschieben.

Gruss
Joerg

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 07.05.2020, 06:43

Hallo ihr zwei,

danke für die Infos.
Wie importiere ich die ganzen Zertifikate von den einzelnen Hosts am besten?
Kann es sein , dass es früher mal funktioniert hat? In einer anderen Version von ESX 6.0 6.5 oder so?
Meine Kollegen behaupten das es erst sein einiger Zeit nicht mehr geht. Genauer wäre mir lieber aber da kommt nicht so viel.

Gruß

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 07.05.2020, 07:32

Mir ist eben noch was aufgefallen.
Wenn ich mich direkt auf einen Host verbinde und dort den Upload versuche komme ich auch nicht weiter.
Auf dem Datastore sind lauf Anzeige 42GB frei und ich versuche 5,9GB hochzuladen.
Der Fortschrittsbalken geht los. Prozente werden hochgezählt 1,3,7,... bei 41 kommt es zum ersten Stopp. Dann dreht der Lüfter von meinem Recher hoch und scheint echt beschäftigt zu sein.
Nach ein paar Minuten 42% und nach noch einiger Zeit 43%. Das dauert gefühlt ewig bis was weiter geht. Ich habe dann neben dem Fortschrittsbalken auf Aktualisieren geklickt und dann war plötzlich fertig und hat die ISO hochgeladen. Allerdings war die gerade mal 127MB groß :-(
Habt ihr eine Idee was ich da noch versuchen kann?

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Upload von großen ISOs bricht immer ab

Beitragvon irix » 07.05.2020, 08:04

Hat dein Browser oder eine Software welche zwischen dir und dem vCenter sitzt Probleme mit der 2GB Grenze?

Nimm pscp oder Winpscp und lade es direkt auf nen ESXi hoch.

Gruss
Joerg

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 07.05.2020, 08:37

Hallo Jörg,

ich weiß es ehrich gesagt nicht ob es da eine Grenze gibt. Ich habe eben mit chrome das Windows Image hoch geladen. Es hat ewig gedauert und stand bestimmt ne Stunde bei 43% dann ging es plötzlich mit 76% weiter und zählte hoch bis 100%. Fertig.
Das Ergebnis:
Datei in Datenspeicher hochladen san_lun100_ISOs root 07.05.2020 07:25:38 07.05.2020 07:25:38 Erfolgreich abgeschlossen 07.05.2020 08:28:56
Steht unten in der Aktuelle Aufgaben Anzeige.
So gehe ich zum Datatsore und schaue rein ... leer. Am Kopf kratz.
Ich habe dann auch über das vCenter iin den Datastore geschaut und da ist die Datei nicht drin.
Wie kommt denn sowas?

King of the Hill
Beiträge: 12867
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Upload von großen ISOs bricht immer ab

Beitragvon Dayworker » 07.05.2020, 12:00

Schau mal direkt per SSH nach, wieviel Platz du wirklich in einem bestimmten Datastore frei hast. Die Anzeige von 42GB frei könnte auch der summierte freie Platz sein, kann ich mangels vCenter und dessen Anzeige nicht besser beschreiben. Mit Thin-VMDKs könnte der freie Platz auch schon belegt sein, was gerne in Kürze stehende/abstürzende VMs bedeutet.
Ohne genauer Kenntnis der Lage würde ich da erstmal nix weiter hochladen.

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 08.05.2020, 08:54

Hallo Dayworker,

ist es dieser Befehl? und bei Size der verfügbare Speicher?

Führen Sie den Befehl esxcli storage core device list aus, um eine Liste der LUNs zu generieren, die zurzeit mit dem ESXi-Host verbunden sind.

Es wird eine Ausgabe ähnlich der folgenden angezeigt:

mpx.vmhba0:C0:T0:L0
Display Name: Local VMware Disk (mpx.vmhba2:C0:T0:L0)
Has Settable Display Name: false
Size: 286070
Device Type: Direct-Access
Multipath Plugin: NMP
Devfs Path: /vmfs/devices/disks/ mpx.vmhba2:C0:T0:L0


Gruß

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Upload von großen ISOs bricht immer ab

Beitragvon irix » 08.05.2020, 08:56

Code: Alles auswählen

df -h


Aber bei No Space left on Device wuerde ich eine anderen Fehlermeldung erwarten bzw. dann haettest du auch ganz andere Probleme :D

Gruss
Joerg

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 08.05.2020, 09:43

Ich kann es mir auch nicht vorstellen, dass der Datastore voll ist.
Wir haben einen eigenen nur für die ISOs und was anderes liegt auch nicht dadrauf.
Aber danke für das Kommando. Ich schaue es mir später noch an.
Parallel erstellen wir mal ein Ticket bei VMware. mal schauen was die sagen.
Dann poste ich das hier herein. :-)

Gruß

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Upload von großen ISOs bricht immer ab

Beitragvon irix » 08.05.2020, 10:33

Was passiert wenn du den HostClient verwendest in dem du mal direkt auf den ESXi und nicht vCenter/WebClient verwendest?

Gruss
Joerg

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 08.05.2020, 10:56

Hallo Jörg,

wenn ich mich direkt an eindem der ESXe mit root anmelde dann kann ich den Upload zwar durchführen aber es klappt am Ende nicht.Ich habe eben mit Chrome ein Windows Image hoch geladen. Es hat ewig gedauert und stand bestimmt ne Stunde bei 43% dann ging es plötzlich mit 76% weiter und zählte hoch bis 100%. Fertig.
Das Ergebnis:
Datei in Datenspeicher hochladen san_lun100_ISOs root 07.05.2020 07:25:38 07.05.2020 07:25:38 Erfolgreich abgeschlossen 07.05.2020 08:28:56
Steht unten in der Aktuelle Aufgaben Anzeige.

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Upload von großen ISOs bricht immer ab

Beitragvon irix » 08.05.2020, 10:59

Was passiert bei kleineren Dateien?

Im Moment hoert es sich eher an als ob was dazwischen funkt und weniger der ESXi das Problem ist.

- VirenScanner/Security Suite
- Proxy
- Firewall mit Contentfilter

Gruss
Joerg

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 08.05.2020, 11:29

Okay ich versuche mir mal ein paar Dateien zu basteln.
1GB 2 GB und so weiter.
380MB haben ohne Probleme funktioniert

Ich geb Bescheid :-)

Gruß

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 08.05.2020, 12:14

Bisher interessantes Verhalten. Ich habe mir zwei Fenster zum vCenter aufgemacht. Links Opera rechts Chrome

Im linken Opera Fenster verfolge ich per Aktualisieren die Datei die hochgeladen wird und schaue ob sich die Dateigröße verändert.
Im rechten Chrome Fenster lade ich die Dateien per vCenter hoch und schaue mir die Fortschrittsbalken an.

Ich lade die Dateien einzeln hoch. Ich habe die Dateien mit fsutil erstellt.
-Die erste Datei 1GB.iso flutschte durch alles easy.
-Die zweite Datei 2GB.iso ging etwas langsamer und braucht dennoch recht fix im Chrome die 100% im Fortschrittsbalken. Im Opera wares es gerade mal 480MB übertragen.
Die dritte Datei 3GB.iso dauerte wieder etwas länger wie 2GB.iso und meldete wiederholt bei 69% Der Vorgang ist fehlgeschlagen.
Dann die über die Anmeldung beim ESX selbst. Der Upload lief erst bei 71% dann eine Pause ca 2 Minuten und wir sind bei 74%.
Über die Aktualisierung im Opera habe den Upload der 3GB.iso mitverfolgt und bei jeder Aktualisierung ergab es einen anderen Wert.
Mal waren es 399MB dann 11MB dann war sie gar nicht da dann wieder 66MB dann 155MB also kreuz und quer. Der Fortschrittsbalken bei Chrome unverändert bei 74%. Ich habe einfach mal nichts mehr gemacht und abgewartet. Weißt u warum das so anstrengend für den Computer ist? Der Lüfter dreht sich wie verrückt wenn der Upload läuft.
Ich schaue gerade in den Taskmanager. Über das Netzwerk überträgt der Chrome tatsächlich fleissig Daten. Der Sophos Web Intelligence hat fast 2GB Arbeitsspeicherauslastung. Ich denk ich schalte den mal ab und teste es dann noch mal. Vielleicht stört der ja auch den Upload.
Dazu schreibe ich dann wieder ein Update

Member
Beiträge: 86
Registriert: 15.11.2011, 11:09

Re: Upload von großen ISOs bricht immer ab

Beitragvon Neopolis » 08.05.2020, 13:04

Halo Jörg,

es scheint das Problem gelöst zu sein.
Alle 5 Dateien 1-5GB Größe sind hochgeladen.
Der Virenscanner ist wohl der Übeltäter.
Unser Sophos Mensch hat jetzt die ESX Server als Ausnahme definiert und etwas im Client umgestellt.

Jetzt sind alle ISOs hochgeladen.

Danke euch!!!

Schönes Wochenende

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Upload von großen ISOs bricht immer ab

Beitragvon irix » 08.05.2020, 17:24

Dann male ich mir mal ein Fleisbienchen in das Heft.

Gruss
Joerg


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste