Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Upgrade schlägt fehl, Conflicting VIB

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 89
Registriert: 12.06.2007, 14:04

Upgrade schlägt fehl, Conflicting VIB

Beitragvon pcpanik » 17.05.2018, 11:27

Hallo, ich habe auf einem Fujitsu TX1330M1 Server das Fujitsu customized Image 6.0.0 6921384 und möchte ein Upgrade auf ein entsprechendes Fujitsu Image 6.5 U1 durchführen.

Ich habe mir das Paket auf dem lokalen Datastore abgelegt und rufe es mit esxcli software profile update --depot=/vmfs/volumes/DATASTORE/DIRECTORY/VMware-ESXi-6.5.0-4564106-Fujitsu-v400-1-offline_bundle.zip -p Fujitsu-VMvisor-Installer-6.5-4564106-v400-1auf.

Ich erhalte aber die Fehglermeldung:

[DependencyError]
VIB VMware_bootbank_ehci-ehci-hcd_1.0-4vmw.600.3.69.5572656 requires com.vmware.usb-9.2.3.0, but the requirement cannot be satisfied within the ImageProfile.
Please refer to the log file for more details.



Wenn ich das 6.5er Image von einem USB Stick zur Installation starte erghalte ich folgerndes:

The upgrade contains the following set of conflicting VIBs:VMware ehci-ehci-hcd 1.0-4vmw.600.3.69.5572656 2017-05-17 23:28:23.000. Remove the conflicting VIBs or use Image Builder to create a custom ISO.”


Mit esxcli software vib list | grep ehci habe ich folgende Ausgabe:

ehci-ehci-hcd 1.0-4vmw.600.3.69.5572656 VMware VMwareCertified 2018-02-01

Ich vermute mal dahinter verbirgt sich der USB 2.0 Controller.

Ich könnte wohl mit esxcli software vib remove -n ehci-ehci-hcd das Paket entfernen, richtig?

Nun sind für mich zuvor aber Fragen offen: Wie stelle ich fest ob dieses Paket gebraucht wird?
Sofern ich dieses Paket brauche, was muss ich tun um dennoch erfolgreich auf 6.5 zu akutalisieren?

Vielleicht weiß ja jemand von Euch was zu tun ist. Bin für Hilfe wie immer sehr Dankbar.


P.S.: es gibt in der UI ja unter "Hilfe" einen Punkt "Aktualisieren". Wie muss dort die Syntax lauten um vom Datastore zu aktualiseren? Gebe ich den Pfad zum zip an erhalte ich jedenfalls eine Fehlermeldung. :-P

Experte
Beiträge: 1302
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Re: Upgrade schlägt fehl, Conflicting VIB

Beitragvon Supi » 17.05.2018, 12:33

Auf welchem Medium ist denn der ESXi installiert? USB Stick?
Schon mal über eine CD probiert wenn möglich?

Grundsätzlich bist du schon auf dem richtigen Weg:
https://www.stephenwagner.com/2016/12/0 ... -0-to-6-5/

Einzig vorher immer schön einen Backup der Config und der VMs ziehen.

Alternative siehe hier Variante 2:
https://www.marco-burmeister.de/helferl ... i_6_5.html

Member
Beiträge: 89
Registriert: 12.06.2007, 14:04

Re: Upgrade schlägt fehl, Conflicting VIB

Beitragvon pcpanik » 17.05.2018, 12:53

Hallo Stefan, Danke dass Du Dir die Zeit genommen hast.

Ich versuchte es vor Ort vom USB Stick. Weil ich auf den Fehler gestoßen bin dann halt aus der Ferne mittels ZIP auf dem Datastore.

Frage ist halt, ob ich das ehci VIB entfernen kann und danach noch in der Lage bin das Update einzuspielen.

Experte
Beiträge: 1352
Registriert: 04.10.2011, 14:06

Re: Upgrade schlägt fehl, Conflicting VIB

Beitragvon JustMe » 17.05.2018, 13:27

Gibt es irgendeinen nachvollziehbaren Grund, warum Du tatsaechlich ein DOWNGRADE von Build 6921384 auf 4564106 durchfuehren moechtest?

v400 ist NICHT 6.5u1, sondern 6.5 OHNE u1, und dann auch noch das allererste Image.

Aktueller 6.5u1-Stand von FTS ist 412.1.7967591. Damit sollte auch das Upgrade funktionieren. Die Tipps zum Upgrade im ReadMe von FTS sind grundsaetzlich auch nicht unbedingt zu verachten...

Member
Beiträge: 89
Registriert: 12.06.2007, 14:04

Re: Upgrade schlägt fehl, Conflicting VIB

Beitragvon pcpanik » 17.05.2018, 16:34

Da bin ich jetzt etwas verwirrt ... muss ich nochmal schauen.
Danke für diesen Hinweis. Da bin wohl in die Irre gelaufen. Stimmt, das U1 Image ist 412-1.
Ich habe versehentlich ein alte Version herunter geladen. Ggf. löst das mein Problem schon.

Danke sehr, ich werde berichten.

Member
Beiträge: 89
Registriert: 12.06.2007, 14:04

Re: Upgrade schlägt fehl, Conflicting VIB

Beitragvon pcpanik » 18.05.2018, 10:56

Jap, das war des Rätsels Lösung.

Vielen Dank für die Hilfe.


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste