Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Netzwerkkarten "verschwinden"

Alles zum Thema vSphere 7.0, ESXi 7.0 und vCenter-Server bzw VCSA7.

Moderatoren: irix, Dayworker

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Netzwerkkarten "verschwinden"

Beitragvon pcpanik » 23.03.2022, 15:54

Hallo,

es klingt sicher verrückt, aber in unserer vSphere 7u3 Umgebung (3 ESXi Essentials Plus / vCenter ) verlieren manche Windows Server 2019 VMs unerwartet ihre Netzwerkverbindung, weil die Netzwerkkarte plötzlich "weg" ist.
Unser Monitor zeigt an, dass sie nicht mehr per Ping erreichbar sind.

Schaue ich nach, ist auf der VM kein Netzwerk mehr da.
Schaue ich in den Eigenschaften der VM ist die Netzwerkkarte vorhanden und verbunden (VMXNET3).

Fahre ich die VM herunter, verschwindet die Netzwerkkarte .... als wenn sie halt aus der Konfiguration entfernt worden wäre.

Auch wenn ich den Server aus der Bestandsliste entferne und wieder aufnehme, die Netzwerkkarte ist und bleibt weg. Ich muss eine Neue hinzufügen.
Damit verbunden ist natürlich auch die alte MAC Adresse weg.

Das ist jetzt zunächst in den letzten Wochen insgesamt 3x passiert. Heute hat es gleich auf einen 3 Server betroffen. Allerdings Zeitversetzt innerhalb einiger Minuten.

Hat dieses Phänomen schon mal jemand erlebt?

King of the Hill
Beiträge: 12808
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Netzwerkkarten "verschwinden"

Beitragvon irix » 23.03.2022, 21:43

Lass mich raten... betrifft nur VMs mit VMXNET3?

Gruss
Joerg

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Netzwerkkarten "verschwinden"

Beitragvon pcpanik » 24.03.2022, 08:45

Ich habe eigentlich nix anderes .... wenn Du aber sooooo anfängst ... erzähl :-)

Und schon mal Danke für Deine Antwort.

King of the Hill
Beiträge: 12808
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Netzwerkkarten "verschwinden"

Beitragvon irix » 24.03.2022, 09:08

Nun..
1. Es ist ein USB Device und das kann man leicht da unten Recht in der Windows Leiste entfernen und in der Tat wird fuer die VM die NIC deaktiviert/Entfernt
2. Da es ein USB Device ist koennen die Windows Stromsparfunktionen da rein greifen. Setze die Policy mit powerdfg auf der Kommandozeile auf Hoehstleistung

In der Praxis sehe ich meistens Punkt 2. und in Ausnahmefaellen Punkt 1.

Gruss
Joerg

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Netzwerkkarten "verschwinden"

Beitragvon pcpanik » 24.03.2022, 13:03

Das ist eine ausgesprochen gute Idee. Ich bedanke mich da herzlich für Deine Antwort. Werde das untersuchen, konfigurieren und berichten, sobald ich mehr weiß.

Spannend ist aber, dass die NIC aus der Hardwarekonfiguration der VM verschwindet. Sie ist also nach einem Neustart komplett weg. Das ist aus dem Windows OS möglich? (Muss ich gleich mal verifizieren)....

Edit: Gesagt getan, ja, ist so! USB auswerfen im Windows entfernt die NIC aus der VM Konfig. Geile Nummer :?

Danke für Deinen Hinweis.

King of the Hill
Beiträge: 12808
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Netzwerkkarten "verschwinden"

Beitragvon irix » 24.03.2022, 13:10

Ja die ist (damals) definitv verschwunden und auch aus der VM konfig.
Einfach mal per VMRC sich zur VM verbinden, von extern nen Dauerping und dann mal die NIC da unten rechts entfernen und im vCenter dann gucken.



Powercfg -l zeigt dir die Stromsparsettings und mit powercfg -s <GUID> dann auf Hoechstleistung. Fuer eine Windows Version ist die GUI immer gleich und evtl. auch mal ueber Versionen hinweg aber in meinem Deploy Script hab ich je Nach Windows Version auch andere.

Gruss
Joerg

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Netzwerkkarten "verschwinden"

Beitragvon pcpanik » 24.03.2022, 13:20

Jau, alles genau so, wie Du schreibst. Super, Dankeschön, Joerg.

HG

King of the Hill
Beiträge: 12808
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Netzwerkkarten "verschwinden"

Beitragvon irix » 24.03.2022, 13:33

Guck mal ob da auch eine Loesung bei war.
https://communities.vmware.com/t5/vSphe ... d-p/363650

Das ist schon seit 10 Jahren so!

Gruss
Joerg

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Netzwerkkarten "verschwinden"

Beitragvon pcpanik » 24.03.2022, 13:39

Tatsächlich ist da nie was gewesen bei uns, ist auch nur seit einigen Wochen so auf dem vSphere 7 Cluster und nur auf unseren Remotedesktops ... in sofern habe ich da eine andere Vermutung, als das Powermanagement :twisted:

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Netzwerkkarten "verschwinden"

Beitragvon pcpanik » 24.03.2022, 17:06

Folgende Ergänzung, um das Problem insbesondere bei RDP Servern zu beseitigen:

In den Konfigurationsparametern der erweiterten VM Optionen folgendes eintragen:

devices.hotplug FALSE

So lassen sich weder die VMXNET3 noch die iSCSI Devices mehr auswerfen. :idea:


Zurück zu „vSphere 7.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast