Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Alles zum Thema vSphere 7.0, ESXi 7.0 und vCenter-Server bzw VCSA7.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 9
Registriert: 09.03.2022, 13:25

Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon ESXi86 » 09.03.2022, 13:44

Gibt es eine Möglichkeit in ESXi 7u2 die SVGA-Grafik für eine Linux-VM komplett zu deaktivieren?
Mein Problem ist, dass Linux immer die SVGA nutzt und nicht die per Passtrough durchgereichte Grafikkarte.
Alle meine bisherigen Bemühungen in Linux den SVGA-Adapter von vmware zu deaktivieren sind gescheitert. Die einfachste und beste Lösung wäre deshalb die Deaktivierung der SVGA-Grafik.
Leider funktioniert bei mir der Parameter 'svga.present = false' nicht wie gewünscht.
Gibt es hierfür noch eine andere Möglichkeit?

King of the Hill
Beiträge: 13416
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon Dayworker » 09.03.2022, 23:06

Ist das eine offiziell für vDGA spezifierte GPU?
Ich würde den SVGA-Adapter nicht deaktivieren, sondern die Reihenfolge der Grafik ändern. Dann ist die durchgereichte GPU die Primäre und der VMware-Adapter die Sekundäre Grafik.

Member
Beiträge: 9
Registriert: 09.03.2022, 13:25

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon ESXi86 » 09.03.2022, 23:22

Dayworker hat geschrieben:Ist das eine offiziell für vDGA spezifierte GPU?


Vielen Dank für deine Rückmeldung. Nein, es ist eine Nvidia Quadro K2000.
Das mit der Reihenfolge wäre super, aber wie kann ich das bitte in ESXi einrichten, dass die Quadro K2000 die primäre und die vmware SVGA die sekundäre GPU ist?

In Windows habe ich mir bisher so beholfen, dass ich die SVGA-Grafik von vmware einfach im Gerätemanager deaktiviert habe, aber unter Linux Mint oder Ubuntu ist mir das setzten der Quadro K200 auf die Blacklist bisher nicht gelungen.
Aber falls dein Vorschlag in ESXi umzusetzen wäre, dann wäre das so und so die Permiumlösung! ;)

King of the Hill
Beiträge: 13416
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon Dayworker » 10.03.2022, 15:24

Das richtest du nicht im ESXi sondern direkt im Gast-OS ein.

Member
Beiträge: 9
Registriert: 09.03.2022, 13:25

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon ESXi86 » 10.03.2022, 17:07

Dayworker hat geschrieben:Das richtest du nicht im ESXi sondern direkt im Gast-OS ein.


Dirket im Gast-OS habe ich das in Linux schon über Tage versucht. :(
Ist einfach nicht zu deaktivieren. :(
Hast du ggf. einen Befehl oder einen Hinweis mit dem ich es weiterversuchen könnte?

King of the Hill
Beiträge: 13416
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon Dayworker » 10.03.2022, 17:50

Wenn ich Hardware Compatibility List (HCL) für vDGA durchgehe, werden mir für vDGA überraschenderweise nur Windows-Gäste angeboten.
Wenn du in die Gast-Einstellungen reingehst, kannst du unter "Grafic Devices" nicht zwischen "Shared" (VMware shared virtual graphics) und "Shared Direct" (Vendor shared passthrough graphics) umschalten?



[edit]
Das Wiki bei Thomas Krenn hilft dir auch nicht wirklich weiter: VMware vSphere vDGA und vSGA konfigurieren.

Member
Beiträge: 9
Registriert: 09.03.2022, 13:25

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon ESXi86 » 10.03.2022, 18:46

Dayworker hat geschrieben:Wenn du in die Gast-Einstellungen reingehst, kannst du unter "Grafic Devices" nicht zwischen "Shared" (VMware shared virtual graphics) und "Shared Direct" (Vendor shared passthrough graphics) umschalten?


Nein leider nicht.
Es ist auch nur eine Nvidia Quadro K2000 und keine Karte die vGPU unterstützt. Ich denke für vDGA bräuchte man da eine Karte die vGPU unterstützt. :(

Member
Beiträge: 9
Registriert: 09.03.2022, 13:25

Re: Deaktivierung der SVGA-Grafik bei PCI-Passthrough

Beitragvon ESXi86 » 11.03.2022, 15:45

Das Problem hat sich halbwegs gelöst. Es liegt am Host.
Passthrough geht immer nur nach dem Reboot! :(
Ich mach zu dem Thema lieber mal ein neues Thema auf!


Zurück zu „vSphere 7.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast