Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Lifecycle Manager, kein Update o. Upgrades möglich

Alles zum Thema vSphere 7.0, ESXi 7.0 und vCenter-Server bzw VCSA7.

Moderatoren: irix, Dayworker

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Lifecycle Manager, kein Update o. Upgrades möglich

Beitragvon pcpanik » 04.02.2022, 13:27

Hallo zusammen, ich weiß hier im Augenblihk einfach nicht weiter. Vielleicht bin ich Betriebsblind.
Es geht um die Online-Aktualisierung einer vSphere 7.0.2 Umgebung.

Es gibt in der Umgebung einen Proxy-Server für den Internetzugriff, welcher einzutragen ist, der zudem ein Zertifikat benötigt, dass es zu installieren gilt. Das habe ich bei der Installation/Bereitstellung des vCenters auch gemacht.

Zunächst die Information, dass die vCenter Appliance einwandfrei Updates herunterladen und installieren kann.
Stand der Appliance ist jetzt 7.0.3 19234570

Der Update-Manager heißt ja nun Lifecycle-Manager und hier beginnen meine Probleme, denn ich bin nicht in der Lage Updates abzufragen.
Im Vcenter unter Updates / Update-Planer steht bereits:

Internal server error occured on authorization: failed while looking for com.vmware.cis.plugin-api endpoint in LS

Wenn ich auf einen Host wechsel und dort Konformität prüfen betätige erscheint:

upgrade agent kann nicht bereitgestellt werden. vergewissern sie sich, dass vsphere lifecycle manager offiziell signiert ist. Überprüfen Sie die Netzwerkkonnektivität und die Protokolle von Hostagent und "vpxa" um weitere Details zu erhalten.

Im vpxa-Log finde ich zum Zeitpunkt nichts auffälliges, keine Fehlermeldung. Da steht immer das Gleiche Drin.

2022-02-04T11:42:26.979Z info vpxa[2101333] [Originator@xxxx sub=vpxaInvtHost opID=SWI-xxxxxxxx] Increment master gen. no to (xxxx): ResourcePool:VpxaInvtHostResPoolListener::ConfigChanged
2022-02-04T11:42:29.650Z info vpxa[2101314] [Originator@xxxx sub=vpxLro opID=HB-host-14@xxxx-xxxxxxx-x] [VpxLRO] -- BEGIN lro-11041 -- vpxa -- vpxapi.VpxaService.getChanges -- xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
2022-02-04T11:42:29.650Z info vpxa[2101314] [Originator@xxxx sub=vpxLro opID=HB-host-14@xxxx-xxxxxxx-x] [VpxLRO] -- FINISH lro-11041
2022-02-04T11:42:32.877Z info vpxa[2101333] [Originator@xxxx sub=vpxLro opID=PollQuickStatsLoop-xxxxxxx-xx] [VpxLRO] -- BEGIN lro-11042 -- vpxa -- vpxapi.VpxaService.fetchQuickStats -- xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
2022-02-04T11:42:32.878Z info vpxa[2101333] [Originator@xxxx sub=vpxLro opID=PollQuickStatsLoop-xxxxxxx-xx] [VpxLRO] -- FINISH lro-11042


Beim hostd.log bin ich mir nicht sicher, ob ich den richtigen Punkt eingegrenzt habe, hatte es nochmal versucht und das log direkt nochmal geöffnet.

2022-02-04T12:04:11.765Z info hostd[2101493] [Originator@xxxx sub=Solo.Vmomi opID=xxxxxxxx-xx-xxxx user=vpxuser:com.vmware.vcIntegrity] Throw vim.fault.AgentInstallFailed
2022-02-04T12:04:11.765Z info hostd[2101493] [Originator@xxxx sub=Solo.Vmomi opID=xxxxxxxx-xx-xxxx user=vpxuser:com.vmware.vcIntegrity] Result:
--> (vim.fault.AgentInstallFailed) {
--> reason = "UnknownInstallerError",
--> statusCode = 126,
--> installerOutput = "Extracting...Done
--> Vua endpoint successfully added.
--> VMware HTTP reverse proxy signalled.
--> nohup: can't execute '/usr/share/vua/vua': Operation not permitted
--> ",
--> msg = "",
--> }


Kann aber auch gut sein, dass ich 1km daneben liege. Alles anderen Meldungen erscheinen mir aber nicht passend.

Jedenfalls bin ich nun hergegangen und habe das neueste ESXi ISO heruntergeladen, importiert, eine Baseline erstellt und will diese nun anwenden.
Aber auch da machen die Hosts den gleichen Fehler. :( Ich gehe davon aus, dass das ISO verifiziert wird, bzw. es wird versucht dies zu tun.

Mir gehen jetzt die Ideen aus. Auf dem Hosts finde ich keien Möglichkeit den Proxy einzutragen oder das Proxy-Zertifikat zu importieren.
Im vCenter aber auch nicht. (Wie gresagt, die vCenter Appliance aktualisert sich mit angabe des Proxies fehlerfrei)
Das "witzige" ist, ich habe noch zwei weitere vSphere umgebungen auf 6.7. Da klappt das alles einwandfrei, und zumindest eine davon habe ich auch eingerichtet und frage mich: was habe ich anders gemacht? Wo habe ich die Zertifiakte hinterlegt?

Vielleich kann mir hier mal jemand den richtigen Fingerzeig geben? Denn ich komme nicht weiter.

King of the Hill
Beiträge: 12808
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Lifecycle Manager, kein Update o. Upgrades möglich

Beitragvon irix » 04.02.2022, 15:32

War 19234570 welche zurueck gezogen wurde? Es gab auch eine 7er Version wo man mit einem angemeldeten AD User den LCM nicht verwenden konnte und es einer aus @vsphere.local sein musste.

Ansonsten was passiert wenn du per ISO nen upgrade versuchst?

Gruss
Joerg

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Lifecycle Manager, kein Update o. Upgrades möglich

Beitragvon pcpanik » 07.02.2022, 07:39

Hallo Joerg,

Dankeschön für Deine Antwort.

Per ISO passiert genau das Gleiche, ich erhalte die gleiche Fehlermeldung.

Jedenfalls bin ich nun hergegangen und habe das neueste ESXi ISO heruntergeladen, importiert, eine Baseline erstellt und will diese nun anwenden.
Aber auch da machen die Hosts den gleichen Fehler. :( Ich gehe davon aus, dass das ISO verifiziert wird, bzw. es wird versucht dies zu tun.


Ich habe erst am 04.02. das vCenter auf diese Version 19234570 aktualisiert. Wenn die zurückgezogen wäre, hätte das nicht klappen sollen, oder?

Herzlichen Gruß

King of the Hill
Beiträge: 12808
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Lifecycle Manager, kein Update o. Upgrades möglich

Beitragvon irix » 07.02.2022, 08:22

Ja die 19234570 ist die aktuelle Version. Das passt also.

Gruss
Joerg

Member
Beiträge: 109
Registriert: 12.06.2007, 14:04

Re: Lifecycle Manager, kein Update o. Upgrades möglich

Beitragvon pcpanik » 08.02.2022, 14:44

Ich habe die Lösung nun in der vmware community gefunden:

https://communities.vmware.com/t5/Updat ... -p/2821267

Ich bin nach der dortigen Anweisung vorgegangen und nun klappt es. Es war also das Problem, dass sich der Update-Agent nicht installieren ließ, da er als nicht signiert angesehen wurde.

Ich konnte die Hosts nun mit dem neuesten ISO Image aktualisieren.

Das einzige was ich noch tun muss, und wo mir der Weg gerade nicht mehr einfällt, ist den Wiederherastellungsschlüssel (TPM) zu sichern, da ich einen Host mal aus dem Cluster entfernt und wieder hinzugefügt habe ....


Zurück zu „vSphere 7.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast