Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Datenspeicher nach Downgrade 7.01 -> 6.7 weg

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 431
Registriert: 28.01.2005, 11:14

Datenspeicher nach Downgrade 7.01 -> 6.7 weg

Beitragvon Wirrkopf » 23.04.2022, 15:46

Ich hatte einen ESXi 7.0.1 laufen und darunter eine NVME auf PCI Karte als Datenspeicher eingerichtet. Dazu auch normale SATA SSDs. Keine Ahnung mehr welche Version von VMFS.

Das es Abstürze beim Server gab habe ich ESXi 6.7 frisch installiert da dieses auf den anderen zwei Servern (Dell T140) gleicher Hardware problemlos lief.
Nach der Installation werden leider nur die Datenspeicher auf den SATA SSDs erkannt. Die haben VMF6.

Die NVME SSD wird nur als Gerät erkannt aber nicht der darauf befindliche Datenspeicher.
Ich könnte jetzt da einen neuen Datenspeicher anlegen aber dann wären ein paar VMs weg die ich ungern verlieren würde.

Bevor ich nun wieder hinfahre und ESXi 7.01 nochmal installiere und der Datenspeicher hoffentlich wieder auftaucht gibt es eine Möglichkeit den Datenspeicher auch unter ESXi 6.7 wieder hervorzuzaubern?

Member
Beiträge: 431
Registriert: 28.01.2005, 11:14

Re: Datenspeicher nach Downgrade 7.01 -> 6.7 weg

Beitragvon Wirrkopf » 24.04.2022, 16:01

Ich hab die NVME SSD mal von einem Host auf den anderen umgesteckt um auszuschließen das es damit was zu tun hat.

Ändert leider nix. Die SSD wird erkannt und auch die VMFS Partition.

Würde mich über einen Tipp freuen wie ich den Datenspeicher vielleicht doch noch wieder eingebunden bekomme.

Bild

Member
Beiträge: 431
Registriert: 28.01.2005, 11:14

Re: Datenspeicher nach Downgrade 7.01 -> 6.7 weg

Beitragvon Wirrkopf » 24.04.2022, 18:07

Für mich als Erinnerung wenn ich nach Jahren mal wieder das selbe Problem habe:

Per SSH auf den ESXi Host draufschalten und folgendes ausgeführt:

Code: Alles auswählen

esxcli storage vmfs snapshot list


Ergebnis:

Code: Alles auswählen

[root@localhost:~] esxcli storage vmfs snapshot list
61227a10-91950a68-c678-b8cb29ac85c1
   Volume Name: 1 TB NVME 7155B611B3382500
   VMFS UUID: 61227a10-91950a68-c678-b8cb29ac85c1
   Can mount: true
   Reason for un-mountability:
   Can resignature: true
   Reason for non-resignaturability:
   Unresolved Extent Count: 1


Dann

Code: Alles auswählen

[root@localhost:~] esxcfg-volume -r "1 TB NVME 7155B611B3382500"


Und schwupp war der Datenspeicher wieder da. :-)

Lösung habe ich abgeleitet aus diesem alten Posting bei dem mir schon mal hier geholfen wurde


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast