Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

vSwitch - Performance

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 8
Registriert: 24.01.2019, 09:46

vSwitch - Performance

Beitragvon vmwareguy90 » 01.04.2020, 16:03

Hallo zusammen,
ich habe folgendes Szenario und weiß einfach nicht, ob ich einen Denkfehler habe.

Aktuell haben wir in einer anderen Umgebung Performanceprobleme und dabei bin ich auf das Tool "iperf" gestoßen. Mit diesem Tool kann die Netzwerkgeschwindigkeit gemessen werden, ohne dass die Festplatten oder andere Komponenten mit einbezogen werden. Sprich dies sind dann recht theoretische Werte.

Ich habe für diesen Test zwei virtuelle W2k19 Server installiert, die auf einem gemeinsamen HP Blade laufen. Beide VMs sind in der der gleichen Portgroup auf dem gleichen vSwitch. Der vSwitch hat 2x10Gbit/s Uplinks und sonst kein Traffic-Shaping oder irgendwas anderes.

Jetzt habe einen Test durchgeführt und bekomme nur eine Rate von ca 3-4Gbit/s durch, obwohl meine Erwartungen >8Gbit/s waren.

Folgende Dinge habe ich gecheckt:
VMware Tools aktuell
Treiber aktuell
VMXnet 3 Treiber bei beiden

Wenn ich z.B 4 Threads abfeuere, komme ich auch auf ca. 9Gbit/s, was ja oka ist, aber dies will ich eigentlich auch im SingleThread sehen
Hat der vSwitch an sich eine Beschränkung?

Habt Ihr sonst noch Ideen, woran das liegen kann oder mal den Test machen, was bei euch rauskommt?

Liebe Grüße,

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: vSwitch - Performance

Beitragvon ~thc » 01.04.2020, 17:14

Ich habe diese Art Tests damals unter ESXi 5.x mit isolierten vSwitches und verschiedenen OS mit E1000E/VMXNET3 gemacht. Dabei kamen beliebige Werte zwischen 1 und 22 GBit/s heraus, so dass ich das als bedeutungslose Test-Lotterie abgehakt habe.

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: vSwitch - Performance

Beitragvon Dayworker » 01.04.2020, 18:30

Irgendwelche Durchsätze in einer VM zu messen ist nutzlos, weil die Zeit in einer VM in Abhängigkeit zur Host/Gast-Auslastung immer etwas flexibel und keine feste Grösse ist.
Neben der von "~thc" genannten Testlotterie sollte man auch bedenken, daß derselbe Durchsatz auch mit einer virtuellen 10MBit-Karte erreicht wird. Der reale Durchsatz wird am Ende nur von der im Host steckenden NIC und aktivierte Jumbo-Frames bestimmt.

Member
Beiträge: 8
Registriert: 24.01.2019, 09:46

Re: vSwitch - Performance

Beitragvon vmwareguy90 » 02.04.2020, 10:00

Danke für eure Antworten, ich schaue mir nochmal genauer die Bladeinfrastruktur da, irgendwie muss ich ja auf die 10Gbit/s kommen :grin:

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: vSwitch - Performance

Beitragvon Dayworker » 03.04.2020, 15:47

Die Angaben in einer VM sind ein rein hypothetischer Wert, der mit der Realität nix zu tun hat und zudem aus den bereits genannten Gründen nicht reproduzierbar bleibt.


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste