Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Datastore nicht sichtbar

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 3
Registriert: 01.02.2020, 16:45

Datastore nicht sichtbar

Beitragvon MatriX76 » 08.03.2020, 15:36

Hallo zusammen,

ich habe aktuell ein Problem auf meinem ESXI Server.
Mein Datastore mit der Produktiv VM wird nicht mehr im Webbrowser angezeigt.
Auch werden die Virtuellen Maschinen nicht mehr angezeigt.

Das fehlende Datastore sollte (Storage1) heißen. (wie zusehen fehlt es aber)
2020-03.png


Gehe ich über SSH auf den Server finde ich die Festplatte und das Datastore (samt Inhalt und VMs)
Zusatz: Befehl esxcfg-volume -l == Zeigt gar nichts. Jedoch mit diesem Befehl im Bild.
3.png


Neustart wurde bereits mehrfach versucht. Datastore bleibt "verschollen"
Ich habe nun versucht das Datastore zu Mounten über die VMFS UUID
Es Kommt jedoch der Fehler :"No matching volume .... /found!

Das Volume wurde per Tab autoverfollständigt
4.png


Ich habe den Befehl noch einmal versucht einzugeben. Jedoch kommt nun nicht mehr der Fehler sondern die <options> (Möglichkeiten mit dem Befehl Bsp. -l list...

Ich weiß aktuell nicht mehr weiter und würde mich über Hilfe jeglicher Art freuen.
Vielen Dank im Vorraus.
MatriX

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: Datastore nicht sichtbar

Beitragvon ~thc » 08.03.2020, 15:54

Der "esxcfg-volume" Befehl zeigt nur als "snapshot" registrierte Volumes an.

Der richtige lautet:

Code: Alles auswählen

esxcli storage filesystem list


Sollte dein Volume fehlen, kannst du mit

Code: Alles auswählen

esxcli storage core device list

schauen, ob die Festplatte dem ESXi noch bekannt ist.

Member
Beiträge: 3
Registriert: 01.02.2020, 16:45

Re: Datastore nicht sichtbar

Beitragvon MatriX76 » 08.03.2020, 16:08

Danke für die schnelle Antwort.
Die Festplatte wird vom System erkannt und über den Befehl angezeigt.
(Ich bin aktuell auch dabei die VM über sftp weg zukopieren. )


Jedoch funktioniert der andere Befehl nicht.

[root@localhost:/dev] esxcli storage filesystem list
Error getting data for filesystem on '/vmfs/volumes/5d3792b6-c4a3f864-9dee-484d7ed8c70a': Unable to get FS Attrs for /vmfs/volumes/5d3792b6-c4a3f864-9dee-484d7ed8c70a, skipping.
Error getting data for filesystem on '/vmfs/volumes/5d976519-94d1c7e2-6c32-503eaa09169f': Unable to get FS Attrs for /vmfs/volumes/5d976519-94d1c7e2-6c32-503eaa09169f, skipping.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: Datastore nicht sichtbar

Beitragvon ~thc » 08.03.2020, 16:35

Das ist nicht so schick - die Volume Struktur des Datastores ist beschädigt - hier im Forum ist "continuum" für so etwas der Experte.

Member
Beiträge: 3
Registriert: 01.02.2020, 16:45

Re: Datastore nicht sichtbar

Beitragvon MatriX76 » 08.03.2020, 17:02

ok,

Das gute ist das ich das Datastore und die VMs über die SSH noch sehe. Ich kopiere gerade die VMs in ein anderes Datastore.
Ich hoffe ich bekomme Sie von dort aus dann gestartet. Der Kopiervorgang dauert halt Ewigkeiten.


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast