Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

LSI MegaRaid SAS 9240-8i unter VMware 6.7

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 04.02.2020, 07:47

Hallo zusammen,

ich habe in meinem ESX Host einen Raidcontroller von LSI verbaut.
Es handelt sich um einen: MegaRaid SAS 9240-8i
Der Controller hat zwei SAS Anschlüsse und dort stecken jeweils über ein Adapterkabel 4 Festplatten dran.
Port 1: 4x4TB SATA
Port 2: 4x8TB SATA

Meine Frage ist nun wie kann ich im vCenter sehen ob alle Festplatten Online sind?
Ich sehe nur unter Datenspeicher bei zwei Datatsores aber nicht wie diese zusammengesetzt sind.
Gibt es da eine praktikable Lösung? Ich bin leider auch keine VMware Profi aber wenn mir da jemand helfen würde wäre das echt klasse.

Danke im Voraus.

Gruß Thomas

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 04.02.2020, 08:09

Du musst den passenden SMI(S)-Provider auf dem ESXi installieren (findet man in den LSI-Downloads unter Management) - dann siehst du den Status z.B. im Hostclient.

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Dayworker » 04.02.2020, 20:36

VMware hat dafür den KB-Eintrag LSI SMI-S CIM Provider Overview for ESXi 6.x (2001549) verfaßt. Im Endeffekt landest du dafür bei https://docs.broadcom.com/docs/12379275. Nach dem Abnicken des Download Agreement bekommst du hoffentlich den Download serviert.

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 05.02.2020, 10:49

Danke ihr zwei!
Ich hab es hinbekommen, dass ich über Putty angezeigt bekomme was Sache ist. Das ist nicht schön aber so kann ich wenigstens sehen ob die Platten alle Online sind.

Am schönsten war der Moment in dem ich im vSphereclient vom Host gesehen habe das man den Controller mit Passthrough durchschleifen kann.
Host neu gestartet und siehe da … alle VMs weg :shock: Ich dachte erst an die Installation der Treiber aus diesem Beitrag:
Beitragvon UrsDerBär » 09.07.2019, 13:27
Zur Storage Authorithy noch ein paar Infos:

1. CIM-Kommunikation muss auf dem ESXi erst freigegeben werden:
esxcli system wbem set –enable true
--> Nur so lässt sich der CIM-Provider dienst überhaupt starten (ansonsten passiert nix, er startet nicht und man erhält auch keine Erklärung)

Aktuelle CIM-Provider installieren (aktuell gibts nur den für 6.5, die sind soooo lahm und die Website so unübersichtlich brrrrr)
esxcli software vib install -d /vmfs/volumes/datastore1/NameDesZipFiles.zip
--> Ich nehme jeweils das Offline-Bundle

Der ESXi kommunizert nur via SSL, Storage Authority standarmässig aber via http
1. Installation der LSI Storage Authority (LSA)
--> die Port-Nummern aufschreiben, insbesondere wenn man sie ändert (braucht man nachher)

2. Folgende Dienste stoppen: LSAService und NginxService

3. Änderungen in der Konfiguration von LSA
Pfad: c:\Programme (x86)\LSI\LSIStorageAuthority\startupLSAUI.bat
--> "Start http:" ersetzen mit "start https":

Pfad C:\Programme (x86)\LSI\LSIStorageAuthority\server\conf\nginx.conf umbennen in z.B. ngingx.conf.bak
Aus Unterordner Sample_SSL_https die Files: nginx.conf / ssl.crt / ssl.key kopieren und einfügen

Das neue nginx.conf Ändern:
Alle "nginx_default" ersetzen mit dem Webserver-Port aus der Installation: Normal 2463
Alle "LSA_default" ersetzen mit dem LSA Server Port aus der Installation: Normal 9000

Die Services wieder starten, dann sollte LSA per SSL starten und somit die Kommunikation mit VmWare möglich sein.
(Quelle SSL: https://www.youtube.com/watch?v=Orgtf7l2JHc)

Aber nein es war zum Glück das Passthrough. Rückgängig gemacht StorCLI installiert und dann ging eine Abfrage über Putty per StoreCLI.

Danke euch!

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 05.02.2020, 11:16

Wenn man einen RAID-Controller im ESXi so betreibt, dass er die Datastores für die VMs bereitstellt, und dann den Controller per PCI-Passthrough an eine VM weiterreicht, dann sind alle Datastores und VMs natürlich weg.

DIe StorCLI kommuniziert direkt mit dem Treiber - man braucht weder CIM noch LSA noch SMI-Provider.

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 05.02.2020, 11:51

Ich habe das dann schon gemerkt :-D
Aber zum Glück war alles wieder da als ich das rückgängig gemacht habe. Schwitz

Ich habe das LSA nicht zum laufen bekommen. ich habe das auf einer VM installiert und hoffte durch die Umstellung auf https erkennt das Tool irgendwas wenn man die IP vom ESX angibt aber ne das klappt nicht. Jedenfalls bei mir nicht.

Darum hab ich das Thema jetzt bei Seite gelegt und mache das jetzt einmal die Woche per Putty.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 05.02.2020, 12:05

Wie schon oben erwähnt: Wenn der SMI-Provider korrekt läuft, kannst du den Status auch im Hostclient (https://ip.des.esxi) unter Monitor/Hardware sehen.

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 05.02.2020, 14:20

Okay … Ich bin also direkt auf den ESX gegangen. Dort dann links auf Host->Überwachen geklickt und im rechten Fenster auf Hardware.
Da gibt es dann Systemsensoren und Speicher
Leider wird weder in dem einen noch in dem anderen etwas von LSI angezeigt oder deutet etwas auch 8 Festplatten hin.
Dann läuft wohl irgendwas nicht so wie es soll. :-)

Danke aber für den Tipp!!!

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon JustMe » 05.02.2020, 14:26

Welcher Treiber wird denn verwendet (esxcli storage core adapter list), und welche Komponentenversionen sind installiert (esxcli software vib list | grep -i lsi)

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 05.02.2020, 15:06

Hier der Output:
[root@ESX01:~] esxcli storage core adapter list
HBA Name Driver Link State UID Capabilities Description
-------- ------------ ---------- -------------- ------------------- ---------------------------------------------------------------
vmhba0 vmw_ahci link-n/a sata.vmhba0 (0000:00:11.4) Intel Corporation Wellsburg AHCI Controller
vmhba1 vmw_ahci link-n/a sata.vmhba1 (0000:00:1f.2) Intel Corporation Wellsburg AHCI Controller
vmhba2 megaraid_sas link-n/a unknown.vmhba2 (0000:06:00.0) LSI / Symbios Logic MegaRAID SAS GEN2 Controller
vmhba64 iscsi_vmk online iscsi.vmhba64 Second Level Lun ID iSCSI Software Adapter
vmhba32 vmkusb link-n/a usb.vmhba32 () USB


[root@ESX01:~] esxcli software vib list | grep -i lsi
scsi-megaraid-sas 6.604.54.00-1OEM.550.0.0.1331820 LSI VMwareCertified 2020-02-04
vmware-storcli-007.0606.0000.0000 007.0606.0000.0000-01 LSI PartnerSupported 2020-02-04
lsi-mr3 7.702.13.00-4vmw.670.0.0.8169922 VMW VMwareCertified 2019-03-27
lsi-msgpt2 20.00.04.00-4vmw.670.0.0.8169922 VMW VMwareCertified 2019-03-27
lsi-msgpt35 03.00.01.00-10vmw.670.0.0.8169922 VMW VMwareCertified 2019-03-27
lsi-msgpt3 16.00.01.00-1vmw.670.0.0.8169922 VMW VMwareCertified 2019-03-27
lsu-lsi-lsi-mr3-plugin 1.0.0-12vmw.670.0.0.8169922 VMware VMwareCertified 2019-03-27
lsu-lsi-lsi-msgpt3-plugin 1.0.0-8vmw.670.0.0.8169922 VMware VMwareCertified 2019-03-27
lsu-lsi-megaraid-sas-plugin 1.0.0-9vmw.670.0.0.8169922 VMware VMwareCertified 2019-03-27
lsu-lsi-mpt2sas-plugin 2.0.0-7vmw.670.0.0.8169922 VMware VMwareCertified 2019-03-27

Das sagt mir ehrlich nicht so wirklich was. Dafür bin ich nicht genug Linux oder VMware Spezi.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 05.02.2020, 15:20

Wäre der SMI-Provider richtig installiert, würde folgende Zeile in der vib-Liste auftauchen:

Code: Alles auswählen

lsiprovider   500.04.V0.66-0002   LSI   VMwareAccepted   2019-04-03

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon JustMe » 05.02.2020, 16:22

Oder auch V0.71-0004 oder noch neuer.

Was mich auch ein wenig verwundert, ist die Versionsangabe "550" beim RAID-Treiber.
Hier in einem 6.7u3 heisst das

Code: Alles auswählen

scsi-megaraid-sas                  6.603.55.00-2vmw.670.0.0.8169922
, zwar noch die vorhergehende Nummer 603 statt 604, dafuer aber 55 statt 54, und auch VMwareCertified. OK, VMware verlinkt selber den 5.5er Treiber auf der HCL, aber ob der mit dem entsprechenden lsiprovider zusammenspielen wuerde (selbst wenn er installiert waere), steht auf einem anderen Blatt.

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 05.02.2020, 16:45

Das bedeutet für mich konkret? :-)
Sorry die Frage... :cry:

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon JustMe » 05.02.2020, 17:21

Naja, das bedeutet zum Einen, dass die Installation des CIM-Providers "lsiprovider" wie von ~thc erwaehnt noch nicht geklappt hat oder noch nicht vorgenommen wurde (ohne den ganz sicher keine RAID-Platten-Informationen im ESXi-Interface angezeigt werden, und auch ein LSA keinerlei Daten erhaelt), und andererseits, dass moeglicherweise auch noch mit den Versionen der Software (Treiber und Provider) ein wenig gespielt werden muss, um es letztlich (und hoffentlich) miteinander zum Laufen zu bringen.

Ach ja: Die Firmware des Controllers ist auch auf dem neuesten Stand, nehme ich an?

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Dayworker » 05.02.2020, 21:21

Vielleicht kommst du auch anders zum Ziel. Was willst du denn eigentlich mit dem Controller machen?
Soll der Controller nur den raidgesicherten Speicherplatz für den ESXi abbilden oder wolltest du den Speicherplatz per NFS oder iSCSI dem ESXi als Storage anbieten?
Bei ersterem fehlt mir leider komplett die Erfahrung, in welchem Umfang die SMI(S)-Provider nachher Informationen zu Controller, Raidlevel und Raidteilnehmer verfügbar halten. Falls da im Ernstfall nur "Raid degraded" aber nicht welche Platte angezeigt wird, ist dir damit vermutlich nicht geholfen. In diesem Fall wärest du dann mit einer Storage-VM besser bedient, weil du per durchgereichtem Controller deutlich umfangreicheren Zugriff haben würdest. Allerdings müßtest du dann diese VM auf einen zusätzlichen, vom Raid-Controller nicht verwalteten Datenträger ausführen. Das schafft zusätzliche Komplexität, die nicht jeder haben will.

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon JustMe » 06.02.2020, 01:11

...und bei jedem Patch erst einmal die gewaehlte Gottheit anbeten, dass das (fuer die allermeisten Controller sowieso nicht offiziell supportete) Durchreichen weiter funktioniert? Waere nicht das erste Mal, dass da was "weggebessert" wurde. Das muss man auch erst einmal wollen :-)
Andererseits kann das genausogut in nicht allzu ferner Zukunft die einzige Moeglichkeit zur Weiterverwendung sein, wenn diese 6G-SAS-Controller (Gen2) nicht mehr unterstuetzt werden. Dann kann man so schon einmal ueben...

Ich hatte den bisherigen Thread-Verlauf so verstanden, dass der (untaugliche) Versuch mit VMDirectPathIO nur deshalb unternommen wurde, weil darauf gehofft wurde, dass damit die LSA-VM auf den Controller zur Ueberwachung zugreifen koennte.

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 06.02.2020, 07:12

Ich habe derzeit die zwei Raid 5 Verbunde als Datastore angebunden und es soll auch so bleiben.
Firmware ist aktuell, ja. :-)
Ich habe übrigens gestern gesehen und bitte jetzt nicht steinigen es ist ein 9260-8i :roll:
Ich werde es dann mit dem CIM Provider versuchen. Habt ihr da zufällig schon was herumliegen. Dann müsste ich nicht suchen oder das falsche finden.

Ich möchte aber bemerken wie toll ich das finde, dass ich mir hier so eure Unterstützung gewährt. Sowas ist nicht selbstverständlich.

Ganz vielen herzlichen Dank dafür!!!

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 06.02.2020, 08:25

Sorry, aber es ist mir gerade unmöglich, die Downloads für den 9260 zu finden. Diese beknackte Broadcom-Website treibt mich zum Wahnsinn.

So - auf der Website sind für mich nur die neueren Modelle (9266 und höher) zu finden - probier es mal mit den Treibern für den 9266.

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon JustMe » 06.02.2020, 08:47

Ich denke mal, dass die Treiber und der CIM-Provider sich nicht unterscheiden fuer 9240 und 9260.
Allerdings wird der mr3-Treiber nicht funktionieren (er ist ja auch schon im ESXi des OP installiert, wird aber nicht angezogen, sondern der megaraid_sas): Der ist fuer 12Gbps-Adapter (Chip-Serie 3xxx), waehrend die 92x0-8i noch zur "alten" 6Gps-Serie gehoeren.
Ich habe auch kurz mal geschaut, ob man den Treiber nicht bei VMware lutschen kann, aber weil der 6.603.55 wohl zum Lieferumfang von 6.7u3 gehoert, finde ich ihn auch nur als Link zur 5.5er-ESXi-Reihe zum Einzel-Download. Sonst muesste man sich den Treiber aus dem ESXi-Installations-Image/Package herauskratzen.

Ah, und PS: Sorry, aber ich habe leider keine Ahnung, welche der Ziffern im Namen nun den neueren oder aelteren Treiber identifiziert (s.o.) ;)

Member
Beiträge: 87
Registriert: 15.11.2011, 11:09

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Neopolis » 06.02.2020, 11:54

Ich habe dashier gemacht:
Navigate to the Avago (LSI) Documents & Downloads site.
Select RAID controllers for Product Family.
Select All for Product.
Select Management Software and Tools for Asset Type.
Click Search.
Click + for Management Software and Tools.
Click the column title OS to sort the list by Operating System and collect all VMware entries together.
Find VMWare SMIS Provider VIB - MR 5.6 in the VMware list entries.
Click + next to VMWare SMIS Provider VIB - MR 5.6.
Click the Download Icon (arrow) in column 5 to download the file.
Unpack the zip archive. For an ESXi host you will find a file named VMWare-ESXi-Provider.zip.
Copy the file found in step 11 to the host using any convenient binary transfer utility.
Connect to the host using SSH or open a shell on the host console and change to the folder containing VMWare-ESXi-Provider.zip.
Run this command to load the VIB:

Code: Alles auswählen

esxcli software vib install -d /path/to/VMWare-ESXi-Provider.zip


Reboot the ESXi host.
Quelle: https://kb.vmware.com/s/article/2001549

Den Horst reboote ich jetzt gerade nicht aber ich melde mich bei euch, wenn ich das gemacht habe und poste die neuen Outputs.

Bis denne

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Dayworker » 06.02.2020, 17:36

@JustMe
Komischerweise hatte ich beim Durchreichen bisher immer nur Probleme mit GPUs. Raid-Controller und HBAs liefen bisher immer vollkommen problemlos und ich hatte da inzwischen einiges an Legacy-HW auf mehreren Systemen installiert.
Storage als VM wird inzwischen fast akzeptiert, wenn das Geld für ein richtiges Storage fehlt und man trotzdem eine nutzbare HW-Anzeige haben will. Kann ja sein, daß das mit den 12G-Controllern/HBAs von LSI oder allgemein mit Adaptec besser läuft, aber bei einem Raid nicht den Gesundheitszustand aller Raidteilnehmer angezeigt zu bekommen, kann keine Lösung sein. Wenn ein Raid wegen Ausfall heruntergestuft wird, will zumindest ich den Grund sehen und dafür nicht erst noch das System rebooten oder sogar stromlos machen und einen Controller-Test starten.


@Neopolis
Bei deinen Plattengrössen würde ich kein Raid5 mehr machen. Die 12 und 24TB müßtest du im Ernstfall erstmal wegkopierenn und vom Gedanken eines Rebuilds bei den Plattengrössen würde ich mich sowieso verabschieden. Der dabei entstehende Streß ist meistens ausreichend hoch, daß dann ein weiteres Raidmitglied sich verabschiedet. In deisem Fall wäre das Raid sowieso verloren. Von daher ist es bei einem Raid5 meist sicherer und vermutlich auch schnellerer, alle Daten zu sichern, die Platte zu tauschen und dann alles wieder auf das Raid zurück zu kopieren.


@~thc
Alle LSI-Treiber finden sich hinter https://www.broadcom.com/support/download-search. Als "PRODUCT GROUP" halt Legacy, bei "PRODUCT FAMILY" auf "All Legacy Products", bei "PRODUCT NAME" kommt die 9260 rein und dann landet man genau hier https://www.broadcom.com/support/download-search?pg=Legacy+Products&pf=Legacy+Products&pn=MegaRAID+SAS+9260-8i&pa=&po=&dk=. Geht man dann auf "Management Software and Tools" wird einem weiter unten auf der Seite der Treiber unter https://docs.broadcom.com/docs/12379275 verlinkt. Allerdings auch wieder mit einer seltsamen Versionsnummer. Die ReadMe dazu verlinkt auf https://docs.broadcom.com/docs/VMW-ESX-5.5.0-lsiprovider-500.04.V0.66-0002-5751577.txt und ist auch wenig erhellend.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 06.02.2020, 18:33

@Dayworker: Nach "Legacy" hatte ich Ausschau gehalten, aber nicht im ersten Auswahlfeld :roll: .Danke für den Tipp.

Normalerweise sollte Broadcom die Treibergenerationen auch richtig verlinken, aber da liegt einiges im Argen. Die Generationen habe kurze Release-Nummern (z.B. "MR 6.14" für den 9260) und die dazugehörigen Treiber sollten dann auch korrespondierende Release Nummern haben.

Der für den 9260 angebotene VMWare Treiber soll der 6.14er sein, hinter dem Link steckt aber der "lsi_mr3" des Sets "MR 7.02", der nicht für diesen Controller geeignet ist.

Der für den 9361 angebotene Treiber ist aktuell (MR 7.12), aber der SMI-Provider dafür uralt (MR 6.14).

Sucht man dagegen nach allen Modellen, bekommt man den SMI-Provider vom MR 7.9 angeboten, der laut README auch für diesen Controller gedacht ist... :?

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Dayworker » 06.02.2020, 19:12

@~thc
Wo findest du den MR 6.9 ??? Ich lande immer wieder bei MR 6.14 ....

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon ~thc » 06.02.2020, 19:17

In der ersten beiden Feldern "Storage Adapters..." und "RAID Controller..." und dann "All" und "All".

Und es ist die 7.9, nicht die 6.9.

King of the Hill
Beiträge: 12998
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: LSI MegaRaid SAS 9240-8i unter VMware 6.7

Beitragvon Dayworker » 06.02.2020, 19:47

@~thc
Okay, gefunden. Steht der 9260 im Treiber mit drin oder in der verlinkten ReadMe beim SMIS-Provider zum 7.9er? Weil in letzterem werden nur die Reihen 9300 und 9400 geführt.
Wenn man sich den Treiber runterlädt, steht in der enthaltenen Textdatei "VMWare-ESXi5.5-Provider: ESXi5.5 is forward compatible provider package, Can be used with ESXi6.0,ESXi6.5 etc." drin. Das sollte also theoretisch doch passen...
Aber du hast schon recht, übersichtlich sieht anders aus :D


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste