Die Foren-SW läuft schon geraume Zeit ohne erkennbare Probleme. Sollte etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Sehr langsame Netzwerk Performance

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: continuum, irix, Dayworker

Member
Beiträge: 1
Registriert: 26.03.2019, 22:25

Sehr langsame Netzwerk Performance

Beitragvon DerOelli » 26.03.2019, 22:40

Hallo,

Ich betreibe mehrere ESXi Hosts.
- Alle nutzen Intel Xeon Gold CPUs (3 Ghz Basistakt)
- 10 Gbit Intel NICs
- 10 Gibt SFP HP Switch
- Enterprise SSDs im Raid 10 an LSI Raid Controllern
- Zusätzlich 2x Qnap NAS Systeme mit 10 Gbit NICs
- Jumbo Frames aktiviert (phy. Switch, virt. Switch, VM Lan Karten Einstellungen)
- VMnext3 Treiber

Allerdings haben meine Windows VMs gefühlt zu wenig Datendurchsatz, wenn es um die Netzwerkverbindungen geht.

Getestet habe ich folgendes:
IPerf von Qnap NAS zu Qnap NAS: Volle 10 Gbit
IPerf von ESX Hostsystem zu ESX Hostsystem: Volle 10 Gbit
IPerf von ESX Hostsystem zu Qnap: Volle 10 Gbit

Soweit sieht alles gut aus.

Starte ich IPerf um die Netzwerkgeschwindigkeit von einer Windows VM zur anderen Windows VM (gleicher Host) zu messen komme ich auf maximal 3 Gbit. Ebenso von Windows Gast zu Qnap. Nehme ich eine Linux VM und testet dort mit IPerf komme ich auch auf volle 10 Gbit.
Lasse ich auf einer Windows VM den IPerf Server + Client laufen komme ich auch nur auf 3 Gbit.
Die Gast VMs haben alle 4 Kerne und 16 GB Ram. Das Hostsystem ist nicht überprovisioniert (sonst würden die Linux VMs ja nicht 10 Gbit liefern).

IPerf habe ich genutzt um Probleme wie Festplattenperformance auszuschließen. Aber die Festplatten sind in der Lage weitaus höhere Datenraten zu liefern. Das Problem läßt sich meiner Meinung nach auf Windows VMs eingrenzen. Faktoren wie: Festplattengeschwindigkeit und CPU Auslastung beeinflussen hier nichts.

Hat jemand eine Idee wie ich meine Windows Gäste schneller bekomme? Wenn ich einen simpleren Test laufen lassen (Datei über Windows Freigabe von VM zu VM zu kopieren) komme ich ebenfalls nicht über die 3 Gbit hinaus.

Jenseits von Gut & Böse
Beiträge: 11813
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Sehr langsame Netzwerk Performance

Beitragvon irix » 27.03.2019, 05:54

Schon mal sehr gut das du iperf verwendet hast und das Physik und ESXi schon mal ausgeschlossen werden kann und es auf Windows VMs eingegrenzt werden kann.

- Mach mal die Windows FW aus
- Gibt div. KBs welche sich mit Windows RSS und co. beschaeftigen

Ich persoenlich haette mich mit 3Gbit/s wahrscheinlich abgefunden :)

Gruss
Joerg


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast