Die Foren-SW läuft schon geraume Zeit ohne erkennbare Probleme. Sollte etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Image von VMWare oder vom Hersteller?

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: continuum, irix, Dayworker

Member
Beiträge: 28
Registriert: 05.02.2019, 15:29

Image von VMWare oder vom Hersteller?

Beitragvon darkrain » 05.02.2019, 15:54

Hallo Gemeinde,

ich habe eine Frage zu den Vor- und Nachteilen der Hersteller Images für VMWare. Welche seht Ihr da?

Ist es besser mit den Images von VMWare zu installieren oder sollte man die entspechenden Hersteller Images bevorzugen und warum?

Danke!


(Nehmen wir als Beispiel HP Proliant DL325 Server und nehmen wir an, das Vanilla VMWare vSphere 6.7 U1 installiert darauf problemlos.
Jetzt könnte man noch das VMWare Treiber und Sensoren Paket von HP installieren.)

King of the Hill
Beiträge: 12611
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Image von VMWare oder vom Hersteller?

Beitragvon Dayworker » 05.02.2019, 17:30

Das Hersteller-ISO enthält gleich alle vom jeweiligen Hersteller benötigten Treiber. Mit dem Vanilla-ISO kann in den meisten Fällen nicht die gesamte HW erkannt werden. Trifft es dabei sowas existentielles wie die NIC, verweigert der ESXi die Installation.

Für mich wäre eher die Frage interessant, weshalb es bei dir der leider weiterhin mit vielen Bugs bedachte 6.7er sein soll?

Jenseits von Gut & Böse
Beiträge: 11813
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Image von VMWare oder vom Hersteller?

Beitragvon irix » 05.02.2019, 18:42

Wir nehmen immer das Hersteller ISO. Erfahrungen habe ich extrem viel mit Dell und dann HPE und Fujitsu.

Ich habe schon als Argument dagegen gehoert das der VMware Support sich dann querstellt bzw. die Nase ruempft aber die eigene Erfahrung der letzten 11 Jahre zeigt da nix an.

Gruss
Joerg

Member
Beiträge: 28
Registriert: 05.02.2019, 15:29

Re: Image von VMWare oder vom Hersteller?

Beitragvon darkrain » 06.02.2019, 10:06

Danke für Eure Antworten!

Wenn ich das richtig verstehe, benutzt jeder von Euch die Hersteller Images vorzugsweise vor denen von VMWare?
(Dachte vorher, wenn es macht keinen großen Unterscheid, wenn die Hardware in beiden erkannt wird. Ok, man kann ja noch das Paket von HP dazu installieren.)

Mixen, von sagen wir HP und Dell Servern mit customized HW-Hersteller Image Installationen mache auch kein Problem?

Updates / Patches von VMWare machen auch kein Problem. Die kann man normal mit dem Update Manager oder der CLI installieren? Man muss nicht auf irgendwelche Anpassungen der HW-Hersteller warten?

Die Sache mit dem Support interessiert mich noch genauer. Jemand irgenwelche Negativbeispiele, dass man von VMWare zu HP und zurück verwiesen wird?

@Dayworker - wir haben bisher nur eine 3 Server Testinstallation davon. Da hatten wir 0 Probleme (wir sind Citrix XS gewohnt ;-)). Was nehmt Ihr aktuell bevorzugt als Version?

Danke!

Guru
Beiträge: 2146
Registriert: 23.02.2012, 12:26

Re: Image von VMWare oder vom Hersteller?

Beitragvon ~thc » 07.02.2019, 17:17

Ich habe das mal an einem Beispiel aus einem anderen Thread nachvollzogen:

Einen "Vanilla" 6.7er auf das Level Update01 (10302608) gebracht und anschließend das Patchbundle (VMware-ESXi-6.7.0-10302608-Fujitsu-v460-1-offline_bundle) von Fujitsu für diese Server eingespielt. (Ich musste dazu "--no-hardware-warning" einschalten, da ich keinen Fujitsu-Server habe...)

Am Ergebnis

Code: Alles auswählen

   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: Avago_bootbank_lsi-mr3_7.703.15.00-1OEM.650.0.0.4598673, ELX_bootbank_elx-esx-libelxima.so_12.0.1108.0-03, EMULEX_bootbank_emulex-esx-brcmfcoecli_12.0.1113.0-01, EMULEX_bootbank_emulex-esx-elxlpfccli_11.4.334.5-01, EMULEX_bootbank_emulex-esx-elxnetcli_12.0.1115.0-03, EMU_bootbank_brcm-cim-provider_12.0.1113.0-01OEM.670.0.0.7535516, EMU_bootbank_brcmfcoe_12.0.1115.0-1OEM.670.0.0.7535516, EMU_bootbank_elxiscsi_12.0.1108.0-1OEM.670.0.0.7535516, EMU_bootbank_elxnet_12.0.1115.0-1OEM.670.0.0.7535516, EMU_bootbank_emulex-cim-provider_11.4.341.0-01OEM.670.0.0.7535516, EMU_bootbank_lpfc_11.4.341.0-1OEM.670.0.0.7535516, Fujitsu_bootbank_fujitsu-conf_6.7.0-460.1.0, Fujitsu_bootbank_pci-fujitsu-hti_8.20.04-1OEM.600.0.0.2494585, Fujitsu_bootbank_raid0_8.51.02-01, Fujitsu_bootbank_svscimprovider_8.51-02.65, INT_bootbank_i40en_1.7.1-1OEM.670.0.0.8169922, INT_bootbank_igbn_1.4.4-1OEM.670.0.0.7535516, INT_bootbank_intel-nvme-vmd_1.4.0.1016-1OEM.670.0.0.8169922, INT_bootbank_ixgben_1.7.1-1OEM.670.0.0.7535516, LSI_bootbank_lsiprovider_500.04.V0.65-0003, MEL_bootbank_nmlx5-core_4.17.13.8-1OEM.670.0.0.8169922, MEL_bootbank_nmlx5-rdma_4.17.13.8-1OEM.670.0.0.8169922, QLC_bootbank_qedentv_3.9.18.0-1OEM.670.0.0.7535516, QLogic_bootbank_qlnativefc_3.1.8.0-1OEM.670.0.0.7535516, QLogic_bootbank_qlogic-adapter-provider_1.6.96-1045108
   VIBs Removed: VMW_bootbank_brcmfcoe_11.4.1078.5-11vmw.670.1.28.10302608, VMW_bootbank_elxiscsi_11.4.1174.0-2vmw.670.0.0.8169922, VMW_bootbank_elxnet_11.4.1095.0-5vmw.670.1.28.10302608, VMW_bootbank_i40en_1.3.1-22vmw.670.1.28.10302608, VMW_bootbank_iavmd_1.2.0.1011-2vmw.670.0.0.8169922, VMW_bootbank_igbn_0.1.0.0-15vmw.670.0.0.8169922, VMW_bootbank_ixgben_1.4.1-16vmw.670.1.28.10302608, VMW_bootbank_lpfc_11.4.33.3-11vmw.670.1.28.10302608, VMW_bootbank_lsi-mr3_7.702.13.00-5vmw.670.1.28.10302608, VMW_bootbank_nmlx5-core_4.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_nmlx5-rdma_4.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_qedentv_2.0.6.4-10vmw.670.1.28.10302608, VMware_bootbank_elx-esx-libelxima.so_11.4.1184.0-0.0.8169922, VMware_bootbank_qlnativefc_3.0.1.0-5vmw.670.0.0.8169922
   VIBs Skipped: ...

sieht man, dass alle spezifischen Treiber und die CIM-Provider für die Hardware in Fujitsu-Servern installiert wird, die zum Teil "Vanilla"-Treiber ersetzen: Avago, Emulex, Fujitsu, Intel, Mellanox und QLogic. Interessant ist auch "Fujitsu_bootbank_fujitsu-conf_6.7.0-460.1.0", das auf der DCUI-Login-Seite des ESXi den aktuellen Patchstand (aus Fujitsu-Sicht) anzeigt.

Aus Sicht eines Minimalisten reicht es also, den aktuellen 6.7er mit allen Treibern und CIM-Providern für die vorhandene Hardware zu versehen. Ob das der Hardware-Anbieter im Support-Fall auch so sieht, sei mal dahingestellt.

Experte
Beiträge: 1582
Registriert: 04.10.2011, 14:06

Re: Image von VMWare oder vom Hersteller?

Beitragvon JustMe » 07.02.2019, 19:59

Naja, dass der "Hardware-Hersteller" im Support-Fall die Installation von Treibern fuer nicht vorhandene Geraete verlangt, wage dafuer ich zu bezweifeln :-)

Und der (vielleicht nur in meinen Augen) Vorteil der Customer-ISOs liegt eben gerade darin, dass man eben nicht alle Treiber und Provider muehsam zusammenklauben und installieren muss, sondern alles in einem Schritt erledigt bekommt. OK, auch hier muss man einschraenkend einsehen, dass das ein Vorteil nur fuer die ist, die halt Hersteller-Hardware verwenden, und keine WhiteBox-Wundertueten...
Hatte ich meine Unterstellung erwaehnt, dass die Hardware-Hersteller die Custom-ISOs wohl eher mit Blick auf die eigene Produktpalette erstellen? :lol:

Aber so wie sich VMware im Laufe der Jahre abgewoehnt hat, den (OS-)Support fuer Installationen mit HW-Hersteller-Erweiterungen zu verweigern, so wird auch kein Hersteller von Custom-ISOs grundsaetzlich den Support fuer Installationen mit VMware-ESXi verweigern. Dass je nach Problemfall dann schon mal die Installation eines bestimmten Treibers (und ggfs. der dazugehoerigen Firmware; einem Detail, dem VMware bisher aber so gar keine Beachtung schenkt) verlangt wird, steht auf einem anderen Blatt...

King of the Hill
Beiträge: 12611
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Image von VMWare oder vom Hersteller?

Beitragvon Dayworker » 09.02.2019, 16:57

Das bedeutet dann wohl, daß es im Endeffekt keine Unterschiede zwischen Vanilla mit nachinstallierter Hersteller-SW und dem Hersteller-ISO gibt, solange die vorliegende HW grundlegend vom Vanilla unterstützt wird und keine existenzielle HW wie zumindest 1 unterstützte NIC fehlt.


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast