Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Netzwerk nicht erreichbar

Alles zum Thema vSphere 6.7, ESXi 6.7 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 7
Registriert: 23.05.2018, 11:14

Netzwerk nicht erreichbar

Beitragvon cwb-it » 08.12.2020, 10:56

Hallo zusammen,

ich hatte vor ein paar Tagen, folgendes Problem.

Mein ESXI 6.7 Server sowie alle laufeneden VM´s waren im Netzwerk nicht mehr erreichbar(Ping/SSH/HTTP etc.). Über die KVM Schnittstelle des Servers hat er ganz normal reagiert. Nach einem Neustart hat es dann wieder funktioniert. Danach wollte ich die Logs durchsuchen, dabei war der Server( und die VM´s) wieder nicht erreichbar.
Nach dem 2ten Neustart ist es bis jetzt nicht mehr aufgetreten. Ich habe mir Logs angeschaut konnte aber nicht wirklich etwas finden, bis auf diese Einträge:

2020-12-04T06:27:35Z DCUI[2099741]: RoutingInfo: Unable to restore VMkernel default gateway (192.168.17.31) :Unable to set VMkernel gateway address (192.168.17.31) :Unable to Set: Sysinfo error: Network unreachableSee VMkernel log for details.. Please verify your IP settings and try again.

Im VMKernel Log steht dann leider nicht viel mehr als:
2020-12-04T06:27:35.869Z cpu2:2099741)WARNING: Tcpip_Vmk: 1156: Failed to set default gateway (51): Network unreachable

Das Netzwerk war aber zu keinem Zeitpunkt das Problem.
Hatte jemand dieses Problem schon einmal, oder einen Anhaltspunkt wo ich schauen könnte?

Viele Grüße
Sebastian

King of the Hill
Beiträge: 13141
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Netzwerk nicht erreichbar

Beitragvon Dayworker » 08.12.2020, 11:34

Überprüfe bitte mal deine gemachten Angaben, ob du mit diesen - ohne vor dem Rechner zu sitzen - wirklich helfen könntest.
Wir wissen bis jetzt nur, daß du mit ESXi-6.7 und dem Gateway ein Problem hast...

Das Minimum an Informatinen wäre:
Buildnummer, wichtig wegen Patchstand
HW auf der HCL
Netzwerk
Router
VLan
VCSA/vCenter

Member
Beiträge: 7
Registriert: 23.05.2018, 11:14

Re: Netzwerk nicht erreichbar

Beitragvon cwb-it » 11.12.2020, 12:19

Hi Dayworker,

1. Version: 6.7.0 Update 3 (Build 16316930)
2. Server Hardware:
-Supermicro 2HE Chassis 825TQ
-Supermicro Servermainboard H8DGi/U-F Dual Opteron
-8 Port Hot Swap Backplane
-32GB (4 x 8GB Samsung DDR3-1600 CL11)
-ADAPTEC RAID 6805E Controller 6Gb/s SAS 2.0
-2 x GBit LAN (on Board)
-2 x OPTERON 12-CORE 6344 2.6GHZ
-4 x INTEL SSD 520 Series 120GB 2.5in SATA 6Gb/s
-1 x WD Caviar Black 2TB 7200rpm 6Gb/s 64MB

3. Kein VLAN
4. Router hat damit nichts zutun.
5.VCSA/vCenter: Was möchtest du hier wissen?

Das Problem ist nicht wirklich das Gateway. Aus dem gleichen Subnetz ist Server und die VM´s nicht erreichbar, dafür wird kein Gateway benötigt.

Ich hoffe die Angaben helfen weiter.

Experte
Beiträge: 1714
Registriert: 04.10.2011, 14:06

Re: Netzwerk nicht erreichbar

Beitragvon JustMe » 11.12.2020, 12:47

Alles sehr interessant, was Du hier anfuehrst, aber...

Wie waere es mal mit "esxcfg-vmknic -l" auf der Kommandozeile?

Weil es nach Reboots wieder funktionierte, und ich hier einfach mal eine heimische Spielwiese postuliere: Hat irgendwann vielleicht mal ein anderes Geraet eine vom ESXi gewuenschte IP-Konfiguration verwendet?

Guru
Beiträge: 2407
Registriert: 23.02.2012, 12:26

Re: Netzwerk nicht erreichbar

Beitragvon ~thc » 11.12.2020, 12:56

Deine WhiteBox kann unter 6.7 funktionieren - muss aber nicht. Die VMKernel-Meldungen deuten an, das zu diesem Zeitpunkt keine Kommunikation möglich war. Das deutet auf den vmnic-Treiber oder die dazugehörende Karte oder die Verkabelung/Switchport.

Besitzt die KVM-Schnittstelle einen eigenen Netzwerkport/eigenes Kabel/Switchport?

Member
Beiträge: 7
Registriert: 23.05.2018, 11:14

Re: Netzwerk nicht erreichbar

Beitragvon cwb-it » 16.12.2020, 15:38

Folgende Ausgabe bei esxcfg-vmknic -l:

Code: Alles auswählen

Interface  Port Group/DVPort/Opaque Network        IP Family IP Address                              Netmask         Broadcast       MAC Address       MTU     TSO MSS   Enabled Type                NetStack
vmk0       Management Network                      IPv4      192.168.17.242                          255.255.255.0   192.168.17.255  00:25:90:a8:74:34 1500    65535     true    STATIC              defaultTcpipStack
vmk0       Management Network                      IPv6      fe80::225:90ff:fea8:7434                64                              00:25:90:a8:74:34 1500    65535     true    STATIC, PREFERRED   defaultTcpipStack


Ein IP Adresskonflikt ist fast ausgeschlossen, da dies ein eigener Serverbereich ist. Wenn es so wäre kann ich es natürlich nicht mehr nachvollziehen., ich gehe aber wirklich nicht davon aus, dass es vorgekommen ist.

Ja, KVM hat eine eigene Schnittstelle/Kabel etc.


Edit: By Moderator

Experte
Beiträge: 1714
Registriert: 04.10.2011, 14:06

Re: Netzwerk nicht erreichbar

Beitragvon JustMe » 16.12.2020, 16:45

Kleiner Hinweis:
Fuer solche Textausgaben bietet sich die "code"-Umgebung an.

Und sorry, leider vergessen: Es braucht auch noch

Code: Alles auswählen

esxcli network ip interface ipv4 get

Kommt Dir denn die in Deinem obersten Post genannte Adresse 192.168.17.31 als Default Gateway bekannt vor?

Member
Beiträge: 7
Registriert: 23.05.2018, 11:14

Re: Netzwerk nicht erreichbar

Beitragvon cwb-it » 18.12.2020, 09:22

esxcli network ip interface ipv4 get:

Code: Alles auswählen

Name  IPv4 Address    IPv4 Netmask   IPv4 Broadcast  Address Type  Gateway        DHCP DNS
----  --------------  -------------  --------------  ------------  -------------  --------
vmk0  192.168.17.242  255.255.255.0  192.168.17.255  STATIC        192.168.17.31     false


Die 192.168.17.31 ist auch tatsächlich das Default Gateway.

Experte
Beiträge: 1714
Registriert: 04.10.2011, 14:06

Re: Netzwerk nicht erreichbar

Beitragvon JustMe » 18.12.2020, 13:29

Hm, tja, dann sieht so weit leider alles ok aus...

...und es bleibt nur die Moeglichkeit, die ~thc frueher schon andeutete: Dass es bei den fehlerhaften Verbindungsversuchen tiefere Probleme gibt bzw. gab, z.B. eine vom Treiber nicht richtig initialisierte Netzwerkkarte, usw. usf.

Hast Du das komplette (vmkernel.)Log eines fehlgeschlagenen Startversuchs noch?

King of the Hill
Beiträge: 13141
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Netzwerk nicht erreichbar

Beitragvon Dayworker » 18.12.2020, 13:50

Intel, Treiber und unwillige NICs erinnern mich an LSI und deren FW-Abhängigkeiten. Hast du mal nachgesehen, ob deine FW noch zum Treiber passen oder ob Intel da neue FW-Versionen nachgeschoben hat?

Member
Beiträge: 7
Registriert: 23.05.2018, 11:14

Re: Netzwerk nicht erreichbar

Beitragvon cwb-it » 13.01.2021, 11:34

Hi JustMe,

ja das Log habe ich noch. Zeitpunkt müsste so zwischen 6:20 Uhr - 6:40 Uhr gewesen sein.
Dateianhänge
vmkernel.log
(1018.86 KiB) 12-mal heruntergeladen

King of the Hill
Beiträge: 13141
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Netzwerk nicht erreichbar

Beitragvon Dayworker » 13.01.2021, 14:07

Code: Alles auswählen

2020-12-04T06:32:37.506Z cpu13:2099790)Vmxnet3: 18592: indLROPktToGuest: 0, vcd->umkShared->vrrsSelected: 1 port 0x2000005
2020-12-04T06:32:37.506Z cpu13:2099790)Vmxnet3: 18833: Using default queue delivery for vmxnet3 for port 0x2000005
2020-12-04T06:32:37.506Z cpu13:2099790)NetPort: 1359: enabled port 0x2000005 with mac 00:0c:29:a0:a8:89
2020-12-04T06:32:41.431Z cpu2:2099927)Vmxnet3: 18592: indLROPktToGuest: 0, vcd->umkShared->vrrsSelected: 1 port 0x2000006
2020-12-04T06:32:41.431Z cpu2:2099927)Vmxnet3: 18833: Using default queue delivery for vmxnet3 for port 0x2000006
2020-12-04T06:32:41.431Z cpu2:2099927)NetPort: 1359: enabled port 0x2000006 with mac 00:0c:29:57:55:54

Welchen VMs sind die MAC-Adressen "00:0c:29:57:55:54" und "00:0c:29:a0:a8:89" zugeordnet?

King of the Hill
Beiträge: 13141
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Netzwerk nicht erreichbar

Beitragvon Dayworker » 14.01.2021, 06:46

Wenn ich auf https://www.supermicro.com/Aplus/support/resources/OS/OS_Comp_SR5690.cfm gehe und mir die drittletzte Spalte bei "H8DGi" ansehe, ist bei ESXi 5.5 das Ende erreicht.

[add]
2020-12-04T06:31:05.126Z cpu0:2097152)Power: 1545: Current power management policy was set to "Balanced"
Stell mal den ESXi um auf "Höchstleistung" und schau auch im BIOS/UEFI nach, ob da noch irgendetwas auf Energiesparen eingestellt ist. Da die Probleme ziemlich regelmäßig auftauchen, würde ich von irgendwelchen Spareinstellungen ausgehen.


Zurück zu „vSphere 6.7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast