Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

[solved] Replikation/Snapshot

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

[solved] Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 09:47

Guten Morgen zusammen,

bin neu hier mit der Hoffnung auf Hilfe :-)
Zu dem was wir haben:

ESXI 6.5
dort installiert eine virtuelle Maschine (win2012 Server)
Lizenz: vpshere 6 Essentials Plus
Auf dem Windwos 2012 Server sind die VMWare Tools installiert und aktuell.

Ich Versuche diese Maschine mit Veeam zu replizieren auf ein angebundenes LUN Laufwerk. (QNAP NAS)
Folgenden Fehler erhalte ich immer:

Snapshot der virtuellen Maschine erstellen Server.xy
Der Vorgang ist im aktuellen Zustand nicht zulässig.


Was habe ich bisher versucht:

Dienste laut Anleitung über SSH alle neu gestartet.
Komplette Maschine neu gestartet
Vmware Tools neu installiert
Virtuelle Maschine neu registriert
Sichergestellt das auf den Festplatten mehr als 20% freier Speicher vorhanden ist
Das ganze Testweise mit Acronis getestet um auszuschliessen das es ein Veeam Problem ist (gleicher Fehler)

Der Fehler bleibt immer bestehen , ich habe nun Stundenlang das internet durchsucht, finde aber nichts was irgendwie hilft. :-(

Ich hoffe nun das jemand hier einen Tipp hat der mir weiterhelfen kann.

Gruss und danke schonmal für die Hilfe

King of the Hill
Beiträge: 12413
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Replikation/Snapshot

Beitragvon irix » 28.06.2019, 10:59

Bitte lass Veeam und Co mal aussen vor... da kommen wir gleich noch mal zu

1. Mach einen normalen VM Snapsthot OHNE Quiescing
2. Mach einen normalen VM Snapshot MIT Quiescing (Disk...nicht Memory)

Was davon funktioniert und was steht unter Tasks/Events?

Veeam kann auf 2 Arten das Quiesing(Stillegen) sorgen
1. Wir oben mittels den VMware Tools und deren VSS Support
2. Es kopiert eigene VSS Tools in das Windows und benutzt diesen. Das kopieren geht im ersten anlauf ueber $ADMIN und im weiteren Versuch durch die VMware Tools

Wenn VSS abgearbeitet ist wird der normale VM Snapshot durchgefuehrt ohne deren Quiescing.

In 99% liegt der Fehler im Windows bzw. den Tools und nich am aussen am Hypervisor. Es gibt natuerlich VM Settings wie FT 1.0 welche das durchfuehren eines VM Snapshot nicht erlauben. Hast du die Probleme generell mit jeder VM oder nur mit dieser? Unterscheidet sich diese VM von anderen?

Gruss
Joerg

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

Re: Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 11:32

danke für die schnelle Antwort,

wir nutzen diese Konstallation bei mehreren Firmen , Problem besteht nur bei dieser.
Ich arbeite mal eben eine Punkte ab und gebe dir gleich Bescheid :-)

gruss

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

Re: Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 11:35

ok,

1. Mach einen normalen VM Snapsthot OHNE Quiescing
2. Mach einen normalen VM Snapshot MIT Quiescing (Disk...nicht Memory)

beides gemacht, gibt den gleichen fehler aus wie oben beschrieben

King of the Hill
Beiträge: 12413
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Replikation/Snapshot

Beitragvon irix » 28.06.2019, 11:44

Ok.. dann sind Veeam und Co. schon mal raus weil es ist ein generelles Problem.

Wenn aber 1. nicht geht... dann muesste es an der VM liegen. Verwendest du PCI Passtrough oder anderen Dummheiten? Paste mal bitte die *.vmx.

Gruss
Joerg

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

Re: Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 12:01

.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "11"
vmci0.present = "TRUE"
floppy0.present = "FALSE"
numvcpus = "8"
memSize = "24000"
sched.cpu.affinity = "all"
sched.mem.affinity = "all"
scsi0.virtualDev = "lsisas1068"
scsi0.present = "TRUE"
scsi0:1.deviceType = "scsi-hardDisk"
scsi0:1.fileName = "/vmfs/volumes/594d5697-8d7441dc-171a-901b0e4c0cc9/Serverneu.local/Serverneu.local_1.vmdk"
scsi0:1.present = "TRUE"
scsi0:2.deviceType = "scsi-hardDisk"
scsi0:2.fileName = "/vmfs/volumes/594d5697-8d7441dc-171a-901b0e4c0cc9/Serverneu.local/Serverneu.local_2.vmdk"
scsi0:2.present = "TRUE"
scsi0:3.deviceType = "scsi-hardDisk"
scsi0:3.fileName = "/vmfs/volumes/594d5697-8d7441dc-171a-901b0e4c0cc9/Serverneu.local/Serverneu.local_3.vmdk"
scsi0:3.present = "TRUE"
displayName = "Serverneu.local"
guestOS = "windows7srv-64"
uuid.bios = "56 4d 31 f2 21 90 81 a5-8e f1 1b 2f 5c 26 8f ff"
uuid.location = "56 4d 31 f2 21 90 81 a5-8e f1 1b 2f 5c 26 8f ff"
vc.uuid = "52 23 63 dc c4 55 50 01-8f b2 4a 6d 5d 70 76 af"
sched.cpu.units = "mhz"
toolScripts.afterPowerOn = "TRUE"
toolScripts.afterResume = "TRUE"
toolScripts.beforeSuspend = "TRUE"
toolScripts.beforePowerOff = "TRUE"
tools.syncTime = "FALSE"
tools.upgrade.policy = "manual"
sched.cpu.min = "0"
sched.cpu.shares = "normal"
sched.mem.min = "24000"
sched.mem.minSize = "24000"
sched.mem.shares = "normal"
vmci0.id = "1546031103"
svga.vramSize = "8388608"
cleanShutdown = "FALSE"
extendedConfigFile = "Serverneu.local.vmxf"
ide0:0.deviceType = "atapi-cdrom"
ide0:0.fileName = "/vmfs/devices/cdrom/mpx.vmhba0:C0:T1:L0"
ide0:0.present = "TRUE"
ide0:0.startConnected = "TRUE"
usb.present = "TRUE"
ehci.present = "TRUE"
pciPassthru0.present = "TRUE"
pciPassthru1.present = "TRUE"
sched.scsi0:1.throughputCap = "off"
sched.scsi0:1.shares = "normal"
scsi0:0.deviceType = "scsi-hardDisk"
scsi0:0.fileName = "/vmfs/volumes/5b922739-c1491d2c-fba8-901b0e4c0cc9/Serverneu.local/Serverneu.local.vmdk"
scsi0:0.present = "TRUE"
sched.scsi0:0.throughputCap = "off"
sched.scsi0:0.shares = "normal"
ethernet0.virtualDev = "e1000"
ethernet0.networkName = "VM Network"
ethernet0.addressType = "generated"
ethernet0.present = "TRUE"
ethernet0.generatedAddress = "00:0c:29:26:8f:ff"
vmotion.checkpointSVGAPrimarySize = "8388608"
vmotion.checkpointFBSize = "8388608"
vmci0.pciSlotNumber = "35"
usb:1.speed = "2"
usb:1.present = "TRUE"
usb:1.port = "1"
usb:1.parent = "-1"
usb:1.deviceType = "hub"
usb.pciSlotNumber = "32"
toolsInstallManager.updateCounter = "9"
toolsInstallManager.lastInstallError = "0"
tools.remindInstall = "FALSE"
tools.guest.desktop.autolock = "FALSE"
svga.present = "TRUE"
svga.guestBackedPrimaryAware = "TRUE"
softPowerOff = "FALSE"
scsi0.sasWWID = "50 05 05 62 21 90 81 a0"
scsi0.pciSlotNumber = "160"
sched.swap.derivedName = "/vmfs/volumes/594d5652-c1eac888-7107-901b0e4c0cc9/Serverneu.local/Serverneu.local-01bff67e.vswp"
sched.cpu.latencySensitivity = "normal"
pciPassthru1.vendorId = "0x8086"
pciPassthru1.systemId = "594d5361-e7a1-ad63-cfbc-901b0e4c0cc9"
pciPassthru1.pciSlotNumber = "224"
pciPassthru1.id = "00000:000:29.0"
pciPassthru1.deviceId = "0x8c26"
pciPassthru0.vendorId = "0x8086"
pciPassthru0.systemId = "594d5361-e7a1-ad63-cfbc-901b0e4c0cc9"
pciPassthru0.pciSlotNumber = "192"
pciPassthru0.id = "00000:000:26.0"
pciPassthru0.deviceId = "0x8c2d"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.present = "TRUE"
pciBridge7.pciSlotNumber = "24"
pciBridge7.functions = "8"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.present = "TRUE"
pciBridge6.pciSlotNumber = "23"
pciBridge6.functions = "8"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.present = "TRUE"
pciBridge5.pciSlotNumber = "22"
pciBridge5.functions = "8"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.present = "TRUE"
pciBridge4.pciSlotNumber = "21"
pciBridge4.functions = "8"
pciBridge0.present = "TRUE"
pciBridge0.pciSlotNumber = "17"
nvram = "Serverneu.local.nvram"
numa.autosize.vcpu.maxPerVirtualNode = "8"
numa.autosize.cookie = "80001"
monitor.phys_bits_used = "42"
mem.hotadd = "TRUE"
hpet0.present = "TRUE"
ethernet0.pciSlotNumber = "33"
ethernet0.generatedAddressOffset = "0"
ehci.pciSlotNumber = "34"
disk.EnableUUID = "TRUE"
cpuid.coresPerSocket = "8"
migrate.hostLog = "./Serverneu.local-01bff67e.hlog"
scsi0:0.redo = ""
scsi0:1.redo = ""
scsi0:2.redo = ""
scsi0:3.redo = ""
ctk.diskSize.BusSCSI0:1 = "839123968"
ctk.diskSize.BusSCSI0:2 = "488284160"
ctk.diskSize.BusSCSI0:3 = "243863552"
ctk.diskSize.BusSCSI0:0 = "734748672"
ctkEnabled = "TRUE"
scsi0:1.ctkEnabled = "TRUE"
scsi0:2.ctkEnabled = "TRUE"
scsi0:3.ctkEnabled = "TRUE"
scsi0:0.ctkEnabled = "TRUE"
usb:0.present = "TRUE"
usb:0.deviceType = "hid"
usb:0.port = "0"
usb:0.parent = "-1"
acronisTag.ReplicationInProcessFlag = "GuidKey=4C0A2C11-6AE8-4775-8A7E-EE12AAB2CAA3|0AOperationTypeKey=replicate|0ATimeKey=28.06.2019 09:47:04"

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

Re: Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 12:03

Verwendest du PCI Passtrough oder anderen Dummheiten?

Ja :oops:

King of the Hill
Beiträge: 12413
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Replikation/Snapshot

Beitragvon irix » 28.06.2019, 12:04

Code: Alles auswählen

pciPassthru1.vendorId = "0x8086"
pciPassthru1.systemId = "594d5361-e7a1-ad63-cfbc-901b0e4c0cc9"
pciPassthru1.pciSlotNumber = "224"
pciPassthru1.id = "00000:000:29.0"
pciPassthru1.deviceId = "0x8c26"
pciPassthru0.vendorId = "0x8086"
pciPassthru0.systemId = "594d5361-e7a1-ad63-cfbc-901b0e4c0cc9"
pciPassthru0.pciSlotNumber = "192"
pciPassthru0.id = "00000:000:26.0"
pciPassthru0.deviceId = "0x8c2d"


VMs welche PCI Passtrough verwenden koennen keinen Snapshot machen und somit nciht auf diese Weise gesichert werden. Du must nun traditionell einen Agenten verwenden oder das Windows soll sich selber sichern.

Gruss
Joerg

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

Re: Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 12:10

VMs welche PCI Passtrough verwenden koennen keinen Snapshot machen und somit nciht auf diese Weise gesichert werden. Du must nun traditionell einen Agenten verwenden oder das Windows soll sich selber sichern.

Wie meinst du das mit dem Agenten?

Am einfachsten ist vermutlich das Passtrough rauszunehemen, habe ich nur eingerichtet da ich das USB Faxgerät nicht an die Maschine bekommen
habe ohne :-(

gruss

King of the Hill
Beiträge: 12413
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Replikation/Snapshot

Beitragvon irix » 28.06.2019, 12:14

Feuerglut hat geschrieben:Wie meinst du das mit dem Agenten?


Ein traditioneller Backup Agent...... Veeam hat die auch.


Am einfachsten ist vermutlich das Passtrough rauszunehemen, habe ich nur eingerichtet da ich das USB Faxgerät nicht an die Maschine bekommen
habe ohne :-(


Das "normale" USB Connect vom ESXi ging nicht? Ansonsten koennte man es noch mit einem USB LAN Adapter wie die von Siliex und co versuchen.

Gruss
Joerg

Member
Beiträge: 7
Registriert: 28.06.2019, 09:21

Re: [solved] Replikation/Snapshot

Beitragvon Feuerglut » 28.06.2019, 12:19

normales Backup läuft schon , ohne Probleme :-)


Das "normale" USB Connect vom ESXi ging nicht?
nein , keine chance das Gerät ans laufen zu bekommen.

Ansonsten koennte man es noch mit einem USB LAN Adapter wie die von Siliex und co versuchen.
Gute Idee , werde ich mal umsetzen. Nun aber erst eine Woche Urlaub, gebe dann aber nochmal Bescheid ob es geklappt hat.

Danke Dir für deine Hilfe.


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast