Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 5
Registriert: 13.02.2019, 15:38

ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon MaxD91 » 13.02.2019, 16:33

Hallo zusammen,

ich habe ein Problem mit einer VM Maschine da ich keine Snapshots mehr machen kann. Immer wenn ich einen Snapshot machen möchte bekomme ich die Meldung das es in dem aktuellen Zustand nicht möglich sei.

Folgende Konstellation:

Ich habe eine ESXI Maschine beim Kunden mit drei VM's wobei die dritte VM von einer andere ESXI Maschine rüberkopiert wurde. Bei den beiden VM's die von anfang an bei der ESXI Maschine drauf waren funktioniert es ohne Probleme Snapshots zu machen im laufenden Betrieb nur bei der rüberkopierten nicht. Nun habe ich allerhand gelesen über das Problem da es andere auch hatten/haben. Der Lösungsvorschlaf von Vmware selbst das man die Management Dienste neustarten soll habe ich auch schon leider erfolglos versucht. Ich finde einfach nicht heraus ich das behoben bekomme. Würde mich freuen wenn Ihr noch Ideen oder Lösungsansätze habt wie ich wieder im laufenden Betrieb Snapshots machen kann.

Experte
Beiträge: 1730
Registriert: 04.10.2011, 14:06

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon JustMe » 13.02.2019, 16:36

Irgendwie herrscht Funkstille in meiner Glaskugel...

Wie waere es denn mal mit einem vmware.log der betroffenen Maschine?

Vielen Dank im Voraus.

Member
Beiträge: 5
Registriert: 13.02.2019, 15:38

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon MaxD91 » 13.02.2019, 17:00

Kein Problem hier das Log

vmware.log
(391.02 KiB) 73-mal heruntergeladen

Experte
Beiträge: 1730
Registriert: 04.10.2011, 14:06

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon JustMe » 13.02.2019, 18:24

Also, ich sehe da diese Zeilen im Log:

Code: Alles auswählen

2019-02-12T22:54:59.848Z| vmx| I125: DICT      pciPassthru0.present = "TRUE"
2019-02-12T22:54:59.848Z| vmx| I125: DICT           pciPassthru0.id = "00000:135:00.0"
2019-02-12T22:54:59.848Z| vmx| I125: DICT     pciPassthru0.deviceId = "0x323a"
2019-02-12T22:54:59.848Z| vmx| I125: DICT     pciPassthru0.vendorId = "0x103c"
2019-02-12T22:54:59.848Z| vmx| I125: DICT     pciPassthru0.systemId = "589082ff-1dfe-8762-d242-70106fb81390"

und

Code: Alles auswählen

2019-02-12T22:55:07.562Z| vmx| I125: PCIPassthru: Device 0000:87:00.0 barIndex 0 type 3 realaddr 0xc8000000 size 4194304 flags 4
2019-02-12T22:55:07.562Z| vmx| I125: PCIPassthru: Device 0000:87:00.0 barIndex 2 type 3 realaddr 0xc8400000 size 4096 flags 4
2019-02-12T22:55:07.562Z| vmx| I125: PCIPassthru: Device 0000:87:00.0 barIndex 4 type 1 realaddr 0xa000 size 256 flags 1
2019-02-12T22:55:07.562Z| vmx| I125: PCIPassthru: Device has PCI Express Cap Version 2(size 60)
2019-02-12T22:55:07.562Z| vmx| I125: PCIPassthru: Registered a PCI device for 0000:87:00.0 vIRQ 0x10, physical MSI = Enabled (vmmInt = Enabled), IntrPin = 1

und VMware sagt, dass das Snapshots verhindert...

Bei ausgeschalteter VM geht's dann natuerlich, weil zu einem solchen Zeitpunkt das Device nicht zugewiesen ist.

Guru
Beiträge: 2450
Registriert: 23.02.2012, 12:26

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon ~thc » 13.02.2019, 18:37

Laut korrespondierender PCI-ID (PCI\VEN_103c&DEV_323a) ist das ein HP SmartArray P410 Controller, der an die VM durchgereicht wird.
Das kann ja beim Kopieren der VM nicht passiert sein...

Member
Beiträge: 5
Registriert: 13.02.2019, 15:38

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon MaxD91 » 14.02.2019, 08:31

An der ESXI Maschine ist ein Bandlaufwerk angeschlossen das ist richtig und die Sicherungen werden auf dem Server gemacht bei dem keine Snapshots im laufenden Betrieb möglich sind.

Bedeutet das das Bandlaufwerk verhindert das Snapshots im laufenden Betrieb möglich sind? Wenn ja wie kommt das eigentlich das das Probleme macht?

Experte
Beiträge: 1730
Registriert: 04.10.2011, 14:06

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon JustMe » 14.02.2019, 08:52

Nein, das hast Du missverstanden.

Also hier nicht nur die Diagnose, sondern deren Deutung:

An der VM, die sich im laufenden Betrieb nicht snapshotten laesst, haengt per VMDirectPathIO ein PCI-Express-Geraet, naemlich der von ~thc erwaehnte Controller.
VMs, die per VMDirectPathIO angehaengte Geraete verwenden, lassen sich nicht im laufenden Betrieb snapshotten.

Das Bandlaufwerk verhindert rein gar nichts; es ist das Durchreichen des Controllers, was die Snapshots im laufenden Betrieb verhindert.

Und die Probleme kommen daher, dass jemand irgendwas versucht, aber sich nicht ueber die Konsequenzen bzw. Einschraenkungen im Klaren ist.

Member
Beiträge: 5
Registriert: 13.02.2019, 15:38

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon MaxD91 » 14.02.2019, 12:01

Vielen Dank für die schnellen Rückmeldungen damit kann ich arbeiten und habe auch schon eine Lösung entwickelt die noch umgesetzt werden muss.

PS. das hatte nichts mit rumprobieren zutun sondern damit das bestimmte Dinge neu sind und man nun mal lernt. Ich bin kein Anfänger aber auch kein Experte und dankbar wenn ich von Ihnen und andere Experten Informationen bekomme. Und was die Konsequenzen angeht es wird nichts ohne Sicherungen und Absicherungen generell gemacht da man sich nicht nur auf eine Sicherungs Art verlassen darf.

Da ich hier neu bin wird der Thread vom Admin geschlossen oder muss ich das machen da mein Problem damit gelöst und verstanden worden ist?

Experte
Beiträge: 1730
Registriert: 04.10.2011, 14:06

Re: ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich

Beitragvon JustMe » 14.02.2019, 12:28

Soweit ich es bisher gesehen habe, sollte vom TE einfach eine entsprechende Info im Betreff des Threads vorgenommen ([solved], [geloest], ...) werden.

Gegen ein geruettelt Mass an Entdeckergeist ist grundsaetzlich nichts zu sagen. Wie sollte die Welt sonst vorangebracht werden...
Aber wenn man etwas "Neues" ausprobiert, und sich danach verbal ueber ein geaendertes Verhalten wundert, dann sollte fuer die, die gefragt werden, nach Moeglichkeit alles erwaehnt werden, was passiert ist. Das erspart denen dann u.U. einiges an Sucherei und "Voodoo".

Egal; wichtig ist, dass Dir (in diesem Falle zumindest erlaeuternderweise) weitergeholfen werden konnte.

Member
Beiträge: 5
Registriert: 13.02.2019, 15:38

ESXI 6.5 VMServer Snapshots im laufenden Betrieb nicht möglich [solved]

Beitragvon MaxD91 » 14.02.2019, 12:45

Alles klar dann markiere ich es als behoben.


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste