Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 94
Registriert: 12.06.2007, 14:04

ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon pcpanik » 27.03.2018, 07:27

Hallo zusammen, ich habe hier ein Phänomen.
Ich habe hier einen Fujitsu TX100 S3 "Server". Mainboard ist ein D3009 A1. Aktuelle Firmware R1.10 ist geflasht.
Drinnen stecken 4 S-ATA Seagate HDDs, angeschlossen am On-Board Controller.
Der Controller ist im BIOS auf RAID eingestellt und es sind 2 RAID 1 Virtual Disks angelegt und Online.
Laut Beschriebung der Fujitsu Seite handelt es sich um einen Intel C202 Controller, melden tut er sich im POST allerdings als LSI MegaRAID und auch die angebnotenen Windows Treiber lauten auf LSI Logic Embedded MegaRAID.

Nun das verrückte: starte ich die Installation von ESXi 6.5 (Fujitsu Image) werden mir 4 einzelne HDDs angeboten. Das RAID wird ignoriert. :?
Installiere ich ESXi auf eine der vorgeschlagenen HDDs wird das RAID im Controller auch als inkonsistent angezeigt und ein Rebuild (auf die mit ESXi installierte HDD) vorgeschlagen. Sprich, das RAID will sich reparieren indem die Installation gelöscht wird.

Zur Kreuzprobe habe ich mal eine Installation von Windows Server 2016 angestoßen. Hier werden mir korrekt zwei Disks angezeigt. Ich kann Windows korrekt auf einer der beiden RAID Virtual Disks installieren.

Aus der Not heraus habe ich ESXi jetzt erst mal auf einen USB Stick installiert. Wenn ich nun einen Datastore anlegen will habe ich aber das identische Problem: statt der zwei RAID Laufwerke sehe ich wieder 4 einzelne HDDs. :cry:

Nun bin ich mir natürlich darüber im klaren, dass dieser "Server" eine bessere Workstation darstellt und die vmware Matrix kennt nicht mal das Modell :lol: Dennoch bin ich erstaunt. Hat das schon mal jemand gehabt? Und weiß ggf. um eine Lösung?

Danke fürs lesen in jedem Fall.

Experte
Beiträge: 1427
Registriert: 04.10.2011, 14:06

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon JustMe » 27.03.2018, 08:18

Das war so, das ist so, und das wird vmtl. auch fuer immer so bleiben:

ESXi unterstuetzt keine Fake-RAID-Controller.

Ursache ist, dass es fuer solche Controller keine zertifizierten Treiber in ESXi gibt, und die ganze "Intelligenz" dieser aus genau diesem Grund "Fake"-RAID genannten Controller steckt halt im Treiber.

Fuer Windows gibt's die, deshalb wird dort auch das "RAID" erkannt.

Abgesehen davon ist auch der ganze TX100s3 nicht fuer ESXi zertifiziert.

Experte
Beiträge: 1299
Registriert: 30.03.2009, 17:13

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon UrsDerBär » 27.03.2018, 08:21

Hi,

Der RAID-Controller dürfte effektiv kein Hardware-RAID Controller sein sondern ein Software-Controller. Diese brauchen ein Stück Software, damit sie vom OS als solche erkannt werden. VmWare unterstützt solche Controller nicht.

Das einzige was gehen würde: Durchreichen an eine VM und den Storage vie NFS an ESXi präsentieren. Allerdings bleibt er auch so immer noch ein Software-Controller ohne Cache-Schutz. Bei einem Stromausfall ist das ziemlich Fatal oder grottenlahm (Festplattencache deaktiviert). Das einzige performante in so einer Konstellation sind SSD mit niedriger Zugriffszeit (nicht nur durchschnittlich niedrig sondern generell niedrig).

EDIT: Bei Storage VM mag ich dann diese Software-RAID-Controller nicht und vertraue lieber auf Windows StorageSpaces. Andere auf ZFS.

Experte
Beiträge: 1936
Registriert: 23.02.2012, 12:26

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon ~thc » 27.03.2018, 09:02

Hardware-RAID: Wird realisiert vom RAID-Controller mit eigenem OS, eigenem RAM und eigener CPU - erscheint als normale "Disk".
Fake/BIOS/Embedded-RAID: Wird realisiert von Teilen des BIOS und einem speziellen Treiber (nutzt CPU/RAM des Mainboards)
Software-RAID: Wird nur im OS realisiert.

Auch auf einem voll von ESXi unterstützten Mainboard kann man ein Fake-RAID aktivieren und sieht dann unter ESXi einzelne Disks - das ist normal, da ESXI der Fake-RAID-Treiber fehlt.

Member
Beiträge: 94
Registriert: 12.06.2007, 14:04

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon pcpanik » 27.03.2018, 09:08

Danke für eure Antworten. Na dann ist das eben so. Danke für die Erläuterungen. ;)

Jenseits von Gut & Böse
Beiträge: 11422
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon irix » 27.03.2018, 10:19

Was nun auf jeden Fall ist...... die Performance ist bescheiden. Man merkt nun wie traege drehende Festplatten auf einmal sein koennen wenn Parallel mit ihnen gearbeitet werden soll.

Gruss
Joerg

Member
Beiträge: 94
Registriert: 12.06.2007, 14:04

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon pcpanik » 27.03.2018, 14:09

Jo, aber das ist zum Glück nicht mein Problem :-)

Experte
Beiträge: 1299
Registriert: 30.03.2009, 17:13

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon UrsDerBär » 27.03.2018, 14:18

haha, der war gut. Das wird es in der Regel schneller als einem lieb ist :lol:

Member
Beiträge: 19
Registriert: 12.07.2016, 18:32

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon andipc » 31.03.2018, 17:14

Hallo,
bin gerade über deine SSDs gestolpert.
Auch bei einem brandneuem Server von Fujtsu (RX2560M2R4 mit PRAID EP400I SAS/SATA RAID CONTR.12 GB/S) werden die Sata-SSDs nicht als solche im Storage erkannt.
Hier ist Handarbeit gefragt.
Such dir mal folgenden KB Artikel raus:
https://kb.vmware.com/s/article/2013188
Hat geklappt :)
SSD werden nun auch als solche angezeigt.


Gruß Andreas

Experte
Beiträge: 1427
Registriert: 04.10.2011, 14:06

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon JustMe » 31.03.2018, 17:33

Die aus SSDs aufgebauten Laufwerke, die der ESXi sieht, sind auch jetzt noch keine SSDs.
Sie werden nur als solche ausgezeichnet.

Es handelt sich immer noch, auch wenn es aus SSDs aufgebaut ist, um ein (oder auch mehrere) Virtual Drive des PRAID-Controllers.

Member
Beiträge: 19
Registriert: 12.07.2016, 18:32

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon andipc » 31.03.2018, 18:55

Hallo,
wenn das so ist wäre es ja eine schöne Mogelpackung seitens der Serverhersteller.
Frage - wie verhält sich ein SSD Raid dann richtig, wenn das mit obigem Arbeitsschritten keine richtige wird - sondern nur Kosmetik.
War natürlich bis jetzt so blauäugig dem Frieden zu trauen.

Gruß Andreas

Jenseits von Gut & Böse
Beiträge: 11422
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: ESXi 6.5 erkennt LSI (intel C202) S-ATA RAID Disks nicht

Beitragvon irix » 31.03.2018, 19:01

Was haben denn nun SSD bzw. SSD Tagging mit dem Problem des OP zutun?

Gruss
Joerg


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast