Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

passthru ausschalten, server merkt sich die einnstallung nicht

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon Conan » 15.02.2018, 01:14

Hallo erst mal.
Ich hab mit meinem escxi server rum gespielt und hab die option "passthru" bei meiner Adaptec 5405 aus probiert.
Jetzt findet mein esxci innstallation meine datenspeicher nicht mehr.
Also wollte ich die passthru funktion wieder ausschalten, also auf <ip>/ui/#/host/manage/hardware/pci-devices beim "Adaptec SCSI" nochmal auf Passthrough umschalten geklickt und neu gestartet, aber die einstellung wird nicht gespeichert, nach dem neustart ist der "Adaptec SCSI" immer noch auf "passthru" also google befragt, auf einer vmwar eseite hab ich die info gefunden, das ich in der datei /etc/vmware/esx.conf das gerät von "/device/000:02.0/owner = "passthru"" auf "/device/000:02.0/owner = vmkernel"" zu ädern, nach einem neustart, nach kontrolle das die datei wirklich bertragen worden ist, ist immer noch passthru angeschalten.

Was muss ich machen damit der gott ver... passthru modus auszu bekommen?
Ohne meine beiden datenspeichern, starten meine vms ja nicht.
bitte helft mir.

Gruss Conan

Experte
Beiträge: 1730
Registriert: 04.10.2011, 14:06

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon JustMe » 15.02.2018, 08:04

Lass' mich mal raten:
Deine ESXi-Installation liegt auf einem ge-passthru-ten Geraet?
Dann waere eine Neuinstallation (ohne Loeschen des VMFS) der schnellste Weg zur Loesung.

King of the Hill
Beiträge: 12414
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon irix » 15.02.2018, 08:05

Ist der ESXi selber auch auf einer LUN dieses Adaptec installiert? Wenn ja ist das das Problem weil du ihm nach dem Start seinen Datenstraeger wegnimmst. Er selber laueft ja in der RAM Disk und fuer den Neustart schreibt er sein Konfig in die Bootbaenke..... und das klappt nun nicht mehr.

Ausser einer Neuinstallation weis ich nicht was helfen koennte :(

Anders waeren wenn du das Geraet bereits einer VM zugeordnet haettest un deren Automatischer Start das Problem ist.

Gruss
Joerg

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon Conan » 15.02.2018, 08:25

Jup. Mein Server hat 4hdds die alle an dem ge-passthru-ten Gerät hängen.
Wie installieren ich es I neu ohne Löschen der vmfs?

King of the Hill
Beiträge: 12414
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon irix » 15.02.2018, 08:32

Versuch mal bitte im BIOS das IntelVT zu deaktivieren oder eine der anderen Vorraussetzungen fuer das Passtrough. Evtl. besteht Hoffnung das er das dann nicht ausfuehren kann.

Das Risiko nun bei der Neuinstallation haette man vermeiden koennen in dem man aus dem RAID Set eine 20GB Boot LUN entnommen haette und den ESXi dorthin installiert.

Bei einer erneuten Installation fragt er nach ob du ein Upgrade oder Neuinstallieren willst. Er zeigt auch alle VMFS Partitionen an so das man nicht ausversehen eine auswaehlt. Ich meine mich auch zu erinneren das da eine Frage kommt. Aber wissen tu ich es nicht mehr.

Frage: Von wann ist dein letztes Backup der VMs? Evtl. solltest du eine Parallelinstallation eines ESXi auf einen USB Stick machen um zumind. die Moeglichkeit eines Backup machen zubekommen.

Gruss
Joerg

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon Conan » 15.02.2018, 08:39

ok ich probiere es aus, Es ist ein root server dder nicht bei mir steht, sondern bei hetzner, also keine backups.
ich hab passthru aus probiert, wei das verschieben von daten zwischen den 2raids seeeehr langsam, ich dachte so wird es schneller, ist ganz ungewohnt das es sooooooo lahm war.

King of the Hill
Beiträge: 13223
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon Dayworker » 16.02.2018, 09:59

Ist das wirklich langsam bzw hast du mal mit "esxtop" auf dem ESXi geschaut oder gehst du dabei von der Geschwindigkeit in der VM aus?

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Re: passthru ausschalten, server merkt sich die einnstallung nicht

Beitragvon Conan » 16.02.2018, 10:43

Ich beziehe mich auf das verschieben von datein, von einer virtuellen HDD zu einer anderen virtuellen hdd verschiebe liegt der speed bei <2000kbytes/s wen ich auf meinem notebook was verschiebe hab ich werte von bis zu (oder mehr) 80000kbytes/s (keine ssd, von einer hdd zu einer anderen) auf dem esxi läuft nur eine router vm fürs internet und eine Windows 7 x64 innstallion wo das problem hat.

Ich konnte gestern esxi mit hilfe von einem usb stick (per iso mount hat es nicht geklappt) wieder innstallieren, ich hab eu innstallation gewählt, so das alle einstellungen weg waren, aber die datenstores noch da. also hatte ich keinen verlust, nur die downtime. Ich danke euch für eure hilfe dafür :) darauf wäre ich nicht gekommen.


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast