Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

ERROR: 2 Passthru Geräte mit der gleichen ID...

Alles zum Thema vSphere 6.5, ESXi 6.5 und vCenter Server.

Moderatoren: irix, continuum, Dayworker, Tschoergez

Member
Beiträge: 151
Registriert: 31.01.2014, 12:08

ERROR: 2 Passthru Geräte mit der gleichen ID...

Beitragvon lord_icon » 21.01.2018, 14:55

hach ja... die Stolpersteine reißen nicht ab. Da weicht man einmal ein wenig vom default ab und ESXi zickt rum.

Hat einer einen Heißen Draht zu VMWare ?
Ich hab hier ein fetten Bug.

Das MB X11DPH-i hat 2 x M2.-Slots. Ergo: liegt es ja nahe, die zum Raid 1 zu verbinden. (ich trauhe der SSD's Technologie noch nicht wirklich; ausserdem: Doppelte Lesegeschwindigkeit.)

Also 2 Samsung 960 Pro 512GB besorgt.

Leider kann das MB kein RAID im M2.Slot bilden. Was mir aber recht ist, weil ich gern die Samsung Tools verwenden möchte, die mir den Gesundheitsstatus melden. Wenn ich eine Platte oder SSD als think einreiche, dann gehen ja diese Informationen flöten.

Also per Passthru. Das geht mit diesen "Geräten".
Blöd ist hier nur wieder Esxi, weil dieser Behauptet, dass ich 2 gleiche SSD vom gleichen Slot eingereicht habe.

"Das Starten der virtuellen Maschine ist fehlgeschlagen.
Doppelter pciPassthru1.id-Eintrag angegeben. 101:0.0 ist bereits registriert.
Einschalten des Moduls 'DevicePowerOn' fehlgeschlagen. "


im html5 browser sieht es so aus:
esxi config.jpg


Wenn man aber speichert, werden aus der ID 2 x die 000:65.00.0 was dann diesen Fehler verursacht.

Anbei einmal hier alle Logs und vmx Datein für vmware.
esxi.rar
(49.9 KiB) 10-mal heruntergeladen



Das Interessante dabei: der vsphere schafft es. Ich habe hier virtualHW.version 8 genommen.
Also wieder mal ein Bug von HTML client :evil:

Wie gesagt... vlt. hat ja einer n heißen Draht und kann diesen Bug melden.

Member
Beiträge: 151
Registriert: 31.01.2014, 12:08

Re: ERROR: 2 Passthru Geräte mit der gleichen ID...

Beitragvon lord_icon » 21.01.2018, 15:13

Bug gefunden:

virtualHW.version 8

Code: Alles auswählen

pciPassthru0.id = "00000:101:00.0"
pciPassthru0.deviceId = "0xa804"
pciPassthru0.vendorId = "0x144d"
pciPassthru0.systemId = "5a647da0-bb0a-8672-d905-ac1f6b60f176"
pciPassthru0.present = "TRUE"
pciPassthru1.id = "00000:102:00.0"
pciPassthru1.deviceId = "0xa804"
pciPassthru1.vendorId = "0x144d"
pciPassthru1.systemId = "5a647da0-bb0a-8672-d905-ac1f6b60f176"
pciPassthru1.present = "TRUE"


virtualHW.version 12

Code: Alles auswählen

pciPassthru0.id = "00000:101:00.0"
pciPassthru0.deviceId = "0xa804"
pciPassthru0.vendorId = "0x144d"
pciPassthru0.systemId = "5a647da0-bb0a-8672-d905-ac1f6b60f176"
pciPassthru1.id = "00000:101:00.0"
pciPassthru1.deviceId = "0xa804"
pciPassthru1.vendorId = "0x144d"
pciPassthru1.systemId = "5a647da0-bb0a-8672-d905-ac1f6b60f176"


Wie man bei der 12er Version sieht, wird pciPassthru1.id 2mal die gleiche Nummer vergeben.
Eine manuelle Anpassung bringt hier im Übrigen wenig erfolg. Der Fehler ist zwar weg.. aber die VM startet nur kurz (ohne Buildschirmausgabe) und ist ca. 3-4 Sek später wieder beendet.
Zur Erinnerung: im Version 8 lassen sich beide Geräte ansprechen.

Ich spiel mal weiter rum ;-)

Benutzeravatar
King of the Hill
Beiträge: 12220
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: ERROR: 2 Passthru Geräte mit der gleichen ID...

Beitragvon Dayworker » 21.01.2018, 15:23

Ohne die Logs angeschaut zu haben, möchte ich anmerken, daß daran nicht unbedingt der ESXi Schuld ist bzw nur zum Teil Schuld hat. Wenn vom UEFI bzw BIOS schon irgendwelche halbgaren Infos zur HW kommen, hat der ESXi damit immer Probleme. Der ESXi ist nicht Linux, aber jeder der Linux auf einem neuen NB mal installiert hat, kennt das Katz-und-Maus-Spiel. Erst wenn man sich den Boot-Log unter Linux mal angesehen hat, sieht man wie schräg die ACPI-Tabellen durch den $Vendor aufgesetzt wurden und wenn diese Tabellen falsch geführt werden, paßt auch die Gerätezuordnung nicht mehr. In solchen Fällen fällt Linux einfach auf die Nase. M$ dagegen geht mit seinem Kernel über solche Fehler meist kommentarlos hinweg und wenn man keinen BSOD erhält, bekommt man als Anwender von der im Grunde fehlerhaften HW überhaupt nix mit...

Member
Beiträge: 151
Registriert: 31.01.2014, 12:08

Re: ERROR: 2 Passthru Geräte mit der gleichen ID...

Beitragvon lord_icon » 21.01.2018, 15:23

boah... kotz mich dieser Bug an.

Einmal (1) kann man die Config bearbeiten.... dann kommt dieser mist und der ganze HTML Client muß neu gestartet werden.
Boaahhhaaaa..... SON Hals hab ich grad :evil:

esxi fehler.jpg

Benutzeravatar
King of the Hill
Beiträge: 12220
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: ERROR: 2 Passthru Geräte mit der gleichen ID...

Beitragvon Dayworker » 21.01.2018, 16:06

Solche Sachen einfach mal im Fling https://labs.vmware.com/flings/esxi-embedded-host-client melden. Etienne Le Sueur als einer der 3 Maintainer ist da recht fix im Bughunting und gibt auch hilfreiche Hinweise zu benötigten ESXi-Updates.


Zurück zu „vSphere 6.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast