Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Probleme mit Windows 10 Gastsystemen auf VMware vSphere 6.0 Host

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 1
Registriert: 11.09.2019, 14:32

Probleme mit Windows 10 Gastsystemen auf VMware vSphere 6.0 Host

Beitragvon TuT » 11.09.2019, 16:06

Hallo,

ich hoffe, dass ich hier richtig bin.
Ich brauche Hilfe bei einem eigenartigem Problem mit verschiedenen Windows 10 Gastsystemen auf unseren beiden vSphere 6 Hostsystemen.
Auf unseren beiden vSphere 6 Hostsystemen laufen die verschiedensten Gastsysteme, von Windows 7 bis Windows 10 Clients, sowie verschiedene Windows Server 2012 R2 und Windows Server 2016.
Die Serverbetriebssysteme und die Windows 7 Clients verursachen keine Probleme, nur bei den Windows 10 Gastsystemen habe ich inzwischen arge Probleme in Ihrem Betrieb.
Das Problem äußert sich darin, dass sich die Gastsysteme jedes Mal aufhängen, wenn ich versuche auf diese die VMware Tools, egal welche Version, zu deinstallieren oder installieren. Die Installation oder Deinstallation hängt sich immer auf. Auch erhalten die betroffenen Gastsysteme keine Windows Updates mehr. Der entsprechende Vorgang wird von Windows immer mit einer Timeout Fehlermeldung beendet.
Was ich herausgefunden habe, ist dass es nur ältere Windows 10 Systeme betrifft. Das sind Systeme, die vor langer Zeit mit der Buildversion 1607 von Windows 10 installiert wurden. Es wurden auch immer schön die Updates installiert, so dass auch diese Systeme vor ein paar Wochen die Buildversion 1903 erhalten haben. Ab da fing dann das Problem an. Ich merkte es daran, dass diese System so nach und nach keine Windows Updates mehr installierten.
Auch fahren diese System nicht mehr herunter, sondern werden beim Herunterfahren nach einem Bluescreen mit der Fehlermeldung "Driver_Power_State_Failure" neu gestartet.
Ich hatte das gleiche Problem schon Mal nach dem Update auf die Buildversion 1803. Damals konnte ich aber das Problem mit einem Update der VMware Tools auf die Version 10.3.10 beheben. Das ist auch die mir zur Zeit zur Verfügung stehenden Version.
Gibt es da schon eine aktuellere und wo kann ich diese erhalten. Ich habe zwar auf den VMware Seiten gesucht, aber nichts aktuelleres gefunden. Auch das automatische Update von vSphere 6 scheint keine neuere Version zu finden.
Das eigenartige ist aber, dass das Problem nur bei den alten Windows 10 Gastsystemen auftritt. Bei den aktuelleren Windows 10 Gastsystemen, also diese, die gleich mit einem Windows 10 1809 Build installiert wurden, tritt dieses Problem nicht auf.

Leider helfen auch die zur Sicherheit erstellten Snapshots oder auch die Sicherheits-OVA Datei nichts. Da dann das Problem nach kurzer Zeit wieder auftritt. Wie ich feststellen musste.
Ich will jetzt vermeiden diese Systeme durch neuere zu ersetzten, da dieses einen nicht unerheblichen Konfigurationsaufwand und damit auch Systemausfall bedeuten würde.

Leider geben die Ereignisprotokolle sowohl vom Hostsystem, als auch den betroffenen Gastsystemen wenig her.
Im Hostsystem kommt nur eine Ereignismeldung nach dem Bluescrren beim Herunterfahren: "Das Gastsystem ist ausgefallen" gefolgt mit der Meldung beim Neustart : "Installieren Sie das VMware Tools-Paket auf dieser virtuellen Maschine". Was ja nicht geht, weil 1. die VMwareTools schon installiert sind und 2. die De- und Neuinstallation sich immer aufhängt.

In den Systemprotokollen des Windows 10 Gastsystems sind 2 immer wiederkehrende Fehlermeldungen enthalten:
1. EventID: 7022; Quelle: Service Control Manager; Meldung: Der Dienst "Netzwerkverbindungsbroker" wurde nicht richtig gestartet.
2. EventID: 7001: Quelle: Service Control Manager; Meldung: Der Dienst "Plattformdienst für verbundene Geräte" ist vom Dienst "Netzwerkverbindungsbroker" abhängig, der auf Grund folgenden Fehlers nicht gestartet wurde: Der Dienst konnte nicht gestartet werden.

Ich habe schon versucht ob es hilft, die Netzwerkadapter in den VM-Einstellungen zum Gastsystem zu entfernen und wieder neu zuzuweisen. Hat leider auch nicht geholfen.

Wer kann mir da helfen?

Vielen Dank schon einmal.
Viele Grüße
Heiko Witt

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Re: Probleme mit Windows 10 Gastsystemen auf VMware vSphere 6.0 Host

Beitragvon ~thc » 11.09.2019, 16:37

Dann frag' dich doch einmal selbst: Was ist der Unterschied zwischen den laufenden und den nicht laufenden Systemen? Die Antwort ist: "Feature update" (Funktionsupdate).

Diese heißen zwar "Updates", sind aber keine. Ein Funktionsupdate beinhaltet eine komplette Neuinstallation der Version (bei dir: 1903), ein Verschieben der Altinstallation nach "C:\Windows.old" und einem Lauf des "Migrationsassistenten", der versucht, alle Programme, Daten und Einstellungen in die neue Version zu migrieren - wie du selbst siehst, mit mäßigem Erfolg. Dieser Schwachsinn führt dann zu endlosen Problemen mit Software, die Microsoft nicht "auf dem Schirm" hat.

Lösungsmöglichkeiten:
- 10 Pro nutzen und alle 18 Monate selbst komplett neu aufsetzen
- 10 Enterprise LSTB/LTSC einsetzen
- 10 Pro/Enterprise vermeiden

King of the Hill
Beiträge: 12568
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Probleme mit Windows 10 Gastsystemen auf VMware vSphere 6.0 Host

Beitragvon irix » 11.09.2019, 17:10

Zum Thema 1903 gibt es auch im VMTN einiges. Das laeuft langsam bis extrem schlecht. Es gibt einen Adv. Setting Eintrag welcher bei vielen Besserung gebracht hat. Aber ich wuerde da mal ein Ticket bei VMware aufmachen bzw. warten bis es supportet ist.

Ja ich mag dieses Rolling Update bei Windows 10 auch nicht.

Gruss
Joerg


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: Majestic-12 [Bot] und 2 Gäste