Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Virtuelle Maschine auf einem von zwei ESXi im HA-Cluster plötzlich unerreichbar

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 1
Registriert: 20.09.2018, 08:48

Virtuelle Maschine auf einem von zwei ESXi im HA-Cluster plötzlich unerreichbar

Beitragvon kb1501 » 20.09.2018, 10:53

Wir nutzen einen HA-Cluster mit zwei ESXi , 6.0.0 , 6921384

"Plötzlich", am 2018-08-03 verloren mehr und mehr physische Netzendgeräte den Kontakt zum Netzwerk, nachdem dieser einmal unterbrochen war. Schlussendlich fand ich heraus, dass unser Radius-Server auf ESXi (Nr1) nicht mehr erreichbar war. Der Radiusserver ist ein Debian GNU/Linux 5 (64-bit), keine VMware-Tools. Lief bis dahin ohne jedes Problem.

Von einem zum anderen Tag war er nicht mehr erreichbar. Möglicherweise interessant: am 2018-07-25 wurde von einem mittlerweile abgegangenen Kollegen nach Updates für die ESXi gescannt und möglicherweise auch etwas installiert. Habe ich noch nicht nachvollziehen können, ein Hinweis auf den korrekten Log wäre hilfreich.

Am physischen, wie auch am VM-Netzwerk ist nichts verändert worden.
Offenbar sind andere virtuelle Maschinen auf dem selben Host auch nicht betroffen von diesem seltsamen Verhalten.

Ich beschreibe die Situation kurz am Beispiel der...
...ESXi(Nr1) und ESXi(Nr2)
...der virtuellen Server DC01, DC01 und Radius
--> alle 3 vServer befinden sich auf ESXi(NR1), jeder kann jeden pingen
--> DC01 computing-ressource wird migriert auf ESXi(Nr1), DC01 & DC02 können einander weiterhin pingen. DC02 & Radius ebenfalls, DC01 & Radius können einander nicht mehr erreichen

Nun laufen zu Sicherheit erst einmal alle virtuellen Server auf ESXi(Nr2) und alles funktioniert. Die Konfigurationen scheinen prinzipiell auf beiden Hosts gleich zu sein. Ich finde keine Erklärung, warum ein vServer auf einem ESXi(Nr1) Probleme macht, andere nicht, und auf ESXi(Nr2) alles läuft.

Irgendeine Idee, vielleicht soagar Lösungen..?

Experte
Beiträge: 1441
Registriert: 04.10.2011, 14:06

Re: Virtuelle Maschine auf einem von zwei ESXi im HA-Cluster plötzlich unerreichbar

Beitragvon JustMe » 20.09.2018, 18:01

Das kann man ohne weitere Details zur ESXi- und externen Netzwerkkonfiguration so leider nicht aus der Glaskugel entziffern, fuerchte ich, und es deutet eigentlich eher auf ein externes Routing- oder auch Firewall-Problem hin.

Allerdings werde ich aus dem Geschriebenen an einer Stelle noch nicht so ganz schlau:
- Radius und DC's auf demselben Host, egal ob 1 oder 2, ist OK -> gebongt.
- Radius auf ESXi2 und DC1 auf ESXi1 erreichen sich nicht mehr -> verstanden.

-> Was ist mit "Radius auf ESXi1 und DC auf ESXi2"? Wuerde ich aus dem Gelesenen erwarten, dass es auch nicht geht. Und was geht dann noch?

Experte
Beiträge: 1945
Registriert: 23.02.2012, 12:26

Re: Virtuelle Maschine auf einem von zwei ESXi im HA-Cluster plötzlich unerreichbar

Beitragvon ~thc » 20.09.2018, 18:50

kb1501 hat geschrieben:Der Radiusserver ist ein Debian GNU/Linux 5 (64-bit), keine VMware-Tools. Lief bis dahin ohne jedes Problem.

Der Support für Lenny endete im Februar 2012. Und das ist ein sicherheitsrelevanter Authentifizierungsserver?

Lest mal die Geschichte mit NotPetya und Maersk - die fanden das auch eine gute Idee, im Jahr 2017 noch Windows 2000 - Domänencontroller produktiv zu nutzen.

Und die ESXi laufen mit dem Patch ESXi600-201711001 von vor einem Jahr. Aktuell wäre 9919195. Was immer der Kollege installiert hat, die damals aktuelle Version des ESXi war es nicht.


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast