Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Problem mit ESXi-Server in einer virtuellen Maschine

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 2
Registriert: 18.06.2017, 16:44

Problem mit ESXi-Server in einer virtuellen Maschine

Beitragvon Kampi » 18.06.2017, 16:58

Hallo zusammen,

ich arbeite z. Z. an einem Vortrag zum Thema Virtualisierung und möchte gerne mal Beispielhaft eine Virtualisierung vorführen.
Dafür habe ich mir gedacht, dass ich mir mit VMware Workstation eine virtuelle Maschine mache die meinen ESXi-Server darstellt und innerhalb dieses ESXi-Servers setze ich dann meine virtuelle Umgebung auf.
Dafür habe ich mir eine virtuelle Maschine erzeugt und mir dann dort den ESXi-Server installiert (Server.jpg).
Dieser Server bekommt im Moment die IP-Adresse 192.168.149.131 (DHCP).
Über vSphere habe ich mir dann auf dem ESXi-Server ein Gastsystem eingerichtet, welches als Betriebssystem Windows Server 2008 bekommen sol (Gast.jpg). Diese Maschine ist auch schon eingerichtet und das Betriebssystem installiert. Dieser Gast bekommt im Moment die IP-Adresse 192.168.149.132 (DHCP).
Das einzige Problem was ich nun habe, ist dass dieses Gastsystem keinen Internetzugang hat. Wie kann ich meine VMware Workstation bzw. den ESXi-Server oder das Gastsystem so konfigurieren, dass das Gastsystem Zugriff auf den Internetzugang des Hostsystems der Workstation (also mein vorhandener PC) hat. Geht das überhaupt?

Vielen Dank für die Hilfe.
Dateianhänge
Gast.jpg
Server.jpg

Experte
Beiträge: 1776
Registriert: 04.10.2011, 14:06

Re: Problem mit ESXi-Server in einer virtuellen Maschine

Beitragvon JustMe » 18.06.2017, 19:59

Wer verteilt denn im "virtuellen Netzwerk" die IP-Adressen?
Da die nested VM eine Adresse aus demselben Bereich wie der Host bekam, waere es z.B. moeglich, dass Du das VM Network an die Host-Only Netzwerkkarte des virtualisierten Hosts statt der NAT-Karte gebunden hast...

Zeig' doch zusaetzlich mal die komplette Netzwerkkonfiguration des ESXi- und des physischen Hosts.

Guru
Beiträge: 2934
Registriert: 27.12.2004, 22:17

Re: Problem mit ESXi-Server in einer virtuellen Maschine

Beitragvon rprengel » 18.06.2017, 21:14

Kampi hat geschrieben:Hallo zusammen,

ich arbeite z. Z. an einem Vortrag zum Thema Virtualisierung und möchte gerne mal Beispielhaft eine Virtualisierung vorführen.
Dafür habe ich mir gedacht, dass ich mir mit VMware Workstation eine virtuelle Maschine mache die meinen ESXi-Server darstellt und innerhalb dieses ESXi-Servers setze ich dann meine virtuelle Umgebung auf.
Dafür habe ich mir eine virtuelle Maschine erzeugt und mir dann dort den ESXi-Server installiert (Server.jpg).
Dieser Server bekommt im Moment die IP-Adresse 192.168.149.131 (DHCP).
Über vSphere habe ich mir dann auf dem ESXi-Server ein Gastsystem eingerichtet, welches als Betriebssystem Windows Server 2008 bekommen sol (Gast.jpg). Diese Maschine ist auch schon eingerichtet und das Betriebssystem installiert. Dieser Gast bekommt im Moment die IP-Adresse 192.168.149.132 (DHCP).
Das einzige Problem was ich nun habe, ist dass dieses Gastsystem keinen Internetzugang hat. Wie kann ich meine VMware Workstation bzw. den ESXi-Server oder das Gastsystem so konfigurieren, dass das Gastsystem Zugriff auf den Internetzugang des Hostsystems der Workstation (also mein vorhandener PC) hat. Geht das überhaupt?

Vielen Dank für die Hilfe.


Wie schon geschrieben vermutlich ein Konfigurationsproblem. Du solltest für den Anfang allen Systemwn feste IPs aus einem Kreis zuweisen und darauf achten das das Gateway überall gleich ist. dann sollten Firewall aus sein und danach systematisch ping von allen Systemen auf alle Systeme auf die IP-Adresse ausführen. Dabei hilft eine Tabelle die du dann systematisch abarbeitest.
Gruss

Member
Beiträge: 2
Registriert: 18.06.2017, 16:44

Re: Problem mit ESXi-Server in einer virtuellen Maschine

Beitragvon Kampi » 19.06.2017, 16:59

Hallo und danke für die Antworten.
Leider habe ich keine tiefgehenden Kenntnisse in Netzwerktechnik bzw. das Einrichten von solchen virtuellen Maschinen (woraus auch die Probleme entstanden sind ;) ).
Anbei mal die Netzwerkkonfigurationen:
VM mit ESXi-Server:
- 2 Netzwerkadapter
- 1x NAT
- 1x Host-only
ESXi-Server:
- Network Adapters: vmnic0 (Ethernet0)
- IPv4 Config:
Use dynamic IPv4 address and network configuration
Address: 192.168.149.131
Subnet Mask: 255.255.255.0
Default Gateway: Not Set
- IPv6 Config - Sollte egal sein, da ich nur IPv4 nutzen möchte
- DNS Configuration
Primary DNS Server: 192.168.149.1
Physischer Host (also der Rechner wo die VMware Workstation drauf läuft):
- 3 Netzwerkadapter
- 1x Killer E2200 Ethernet Controller (TCP/IPv4 mit DHCP)
- 1x VMware Network Adapter VMnet1 (TCP/IPv4 und TCP/IPv6 mit DHCP)
- 1x VMware Network Adapter VMnet8 (TCP/IPv4 und TCP/IPv6 mit DHCP)

Hoffe das reicht als Information. Danke nochmals für die Hilfe und falls was fehlen sollte, bitte Bescheid sagen.

Gruß
Daniel

Guru
Beiträge: 2934
Registriert: 27.12.2004, 22:17

Re: Problem mit ESXi-Server in einer virtuellen Maschine

Beitragvon rprengel » 19.06.2017, 19:11

Kampi hat geschrieben:Hallo und danke für die Antworten.
Leider habe ich keine tiefgehenden Kenntnisse in Netzwerktechnik bzw. das Einrichten von solchen virtuellen Maschinen (woraus auch die Probleme entstanden sind ;) ).
Anbei mal die Netzwerkkonfigurationen:
VM mit ESXi-Server:
- 2 Netzwerkadapter
- 1x NAT
- 1x Host-only
ESXi-Server:
- Network Adapters: vmnic0 (Ethernet0)
- IPv4 Config:
Use dynamic IPv4 address and network configuration
Address: 192.168.149.131
Subnet Mask: 255.255.255.0
Default Gateway: Not Set
- IPv6 Config - Sollte egal sein, da ich nur IPv4 nutzen möchte
- DNS Configuration
Primary DNS Server: 192.168.149.1
Physischer Host (also der Rechner wo die VMware Workstation drauf läuft):
- 3 Netzwerkadapter
- 1x Killer E2200 Ethernet Controller (TCP/IPv4 mit DHCP)
- 1x VMware Network Adapter VMnet1 (TCP/IPv4 und TCP/IPv6 mit DHCP)
- 1x VMware Network Adapter VMnet8 (TCP/IPv4 und TCP/IPv6 mit DHCP)

Hoffe das reicht als Information. Danke nochmals für die Hilfe und falls was fehlen sollte, bitte Bescheid sagen.

Gruß
Daniel


Tja,
dann fang an zu lesen und zu lernen. Aktuell hast du dich fachlich offenbar übernommen.
Stell die Netzwerkkarten auf bridges um und vergib feste IPs.
Dann teste systematisch durch.
Dein Setup erinnert stark an Aufgabwn für Fachinformatiker in der Berufsschule bzw. Für ITA's.
Gruss


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast