Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

kann VM nach verschieben nicht mehr starten

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Benutzeravatar
Profi
Beiträge: 503
Registriert: 20.10.2011, 17:55

kann VM nach verschieben nicht mehr starten

Beitragvon MarroniJohny » 22.11.2016, 15:56

Hi

Ich habe blöderweise eine VM verschoben, die jetzt nicht mehr startet.

Da kommt der Fehler: Datei (BS Bot XP_3.vmdk) konnte nicht gesperrt werden.

Ich habe versucht, die VM vom der Bestandsliste zu entfernen, und sie wieder hinzuzufügen. Ausserdem habe ich nach der Anleitung

https://communities.vmware.com/thread/457770?start=0&tstart=0

die Snapshots gelöscht und konsolidiert. Ausserdem habe ich mit WinSCP die Rechte auf 774 gesetzt. Passt das?

Wär schon schön, wenn ich die VM wieder zum laufen kriegen könnte! Es handelt sich um eine Win XP VM.

Gruss und Danke

Experte
Beiträge: 1778
Registriert: 04.10.2011, 14:06

Re: kann VM nach verschieben nicht mehr starten

Beitragvon JustMe » 22.11.2016, 16:13

Dann zeig' doch mal ein paar hilfreiche weitere Informationen

- .vmx-Konfigdatei der VM
- letztes vmware.log
- "ls -la" aus dem Verzeichnis der VM (und NICHT aus WinSCP oder gar dem Datastore Browser!)

Wenn die nicht sperrbare Datei vorhanden sein sollte, pruefe damit bzw. damit, wer die evtl. sperren koennte.
MarroniJohny hat geschrieben:die Snapshots gelöscht und konsolidiert. Ausserdem habe ich mit WinSCP die Rechte auf 774 gesetzt.

Du weisst aber schon, was Du da tust, oder?

Benutzeravatar
Profi
Beiträge: 503
Registriert: 20.10.2011, 17:55

Re: kann VM nach verschieben nicht mehr starten

Beitragvon MarroniJohny » 22.11.2016, 21:59

Hi

Ja danke. Mit dieser Anleitung habe ich es hin gerkriegt:

https://kb.vmware.com/selfservice/micro ... alId=10051

Benutzeravatar
Profi
Beiträge: 503
Registriert: 20.10.2011, 17:55

Re: kann VM nach verschieben nicht mehr starten

Beitragvon MarroniJohny » 22.11.2016, 23:50

Hi

Ich habe noch von einer zweiten VM (SuseLinux) die vmdk auf eine zweite Platte kopiert. Ausserdem habe ich das Original Volume umbenannt.

Nun habe ich das Problem, dass ich die vmdk nicht mehr zur Maschine hinzufügen kann. Die vmdk wird gar nicht angezeigt im Datastore.

So sieht die vmdk aus:

Code: Alles auswählen

# Disk DescriptorFile
version=1
encoding="UTF-8"
CID=873127a3
parentCID=ffffffff
isNativeSnapshot="no"
createType="vmfs"

# Extent description
RW 140509184 VMFS "Teamspeak Suse_1-flat.vmdk"

# The Disk Data Base
#DDB

ddb.adapterType = "lsilogic"
ddb.geometry.cylinders = "8746"
ddb.geometry.heads = "255"
ddb.geometry.sectors = "63"
ddb.longContentID = "9ff7e03f2782797c3cbd6143873127a3"
ddb.toolsVersion = "2147483647"
ddb.uuid = "60 00 C2 92 81 3f 4f 7d-fb 9d 91 d7 30 c8 97 4f"
ddb.virtualHWVersion = "11"


Ich habe probiert, die vm aus der Bestandsliste zu entfernen, und eine neue vm mit hw Version 11 und dem LSI Parallel (LSI SAS habe ich auch versucht) Controller zu erstellen. Wie gesagt, die VMDK taucht gar nicht im Auswahldialog auf. Im Datastore sind die Dateien aber vorhanden.

Benutzeravatar
Profi
Beiträge: 503
Registriert: 20.10.2011, 17:55

Re: kann VM nach verschieben nicht mehr starten

Beitragvon MarroniJohny » 23.11.2016, 01:38

Hi

Ja, ich bin ein Chaot. Ich hatte die vmdk umbenannt, und die Beschreibungsdatei nicht angepasst.

Jetzt läuft ein schöner Teil.


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast