Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Rapid Storage Driver

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Rapid Storage Driver

Beitragvon MarroniJohny » 10.10.2016, 21:38

Hi

Ich habe einen ESXi 6.0 U2, und möchte gerne einen Windows Server 2008 rc2 aufsetzen, bzw. patchen.

Nun bekomme ich von Windows Update den Fehler:

8024000E

Das scheint allem Anschein nach ein Problem mit dem rapid storage driver und ESXi zu sein:


Nur habe ich kein Raid, das ist eine normale vmdk auf einer SSD am Host.
    Ich dachte immer, den Rapid Storage Driver brauchts nicht ohne RAID?
    Und schon gar nicht in einer VM, ohne durchgereichten Controller?
    Lieg ich da flasch?

Guru
Beiträge: 2519
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 10.10.2016, 21:49

Der fehlende Rapid Treiber ist nur eine der möglichen Ursachen.

Versuch mal in einer Admin-Shell

Code: Alles auswählen

sfc /scannow


und/oder setze Windows Update zurück:
https://support.microsoft.com/de-de/kb/971058

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 11.10.2016, 23:33

Hi

Ich habe mehrmals Windows Update zurückgesetzt (siehe Bilder). Da kamen aber dauernd Fehlermeldungen während der Vorgänge.

Ich habe auch Windows Update zum Teil wieder zum Laufen gebracht. Ich glaube, es liegt am Internet Explorer. Den kann ich auch nicht händisch installieren. Ich konnte jedoch, als Windows Update wieder mal wollte, wenigstens das .NET Framework installieren.

Es gab auch kuriose Fehlermeldungen à la „es sind keine Updates vorhanden. Ihr Windows ist aktuell“.

Ich habe jetzt echt langsam die Schnauze voll. Bei Windows 7 zickt Windows Update auch manchmal rum am Anfang; aber das mit 2k8 ist recht hartnäckig. Ich habe auch schon Windows neu aufgesetzt.

Ich habe ein paar Screenshots gemacht. Aber ich habe noch viel mehr ausprobiert. Da kommen einfach immer andere Fehler. Den Internet Explorer habe ich in Verdacht, da ich die verstärkte Sicherheit deaktivieren, und immer wieder auch den Chache und das Temp Verzeichnis löschen musste. Ausserdem ist immer Firefox abgestürzt, wenn Windows Update wieder Mal fehlgeschlagen war.

Einmal konnte ich um die 200 Updates auswählen zum installieren (IE habe ich ausgelassen), dann ist während des Downloads die ganze vm „eingefroren“.

Könne es dann doch noch an dem rapid storage driver liegen? Ohne RAID, und so?

Ich häng einfach Mal die Bilder an, vielleicht kannst Du mir ja sagen, was ich noch versuchen könnte.

erster Versuch:

Bild

zweiter Versuch:

Bild

dritter Versuch:

Bild

Guru
Beiträge: 2519
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 12.10.2016, 09:18

Meine 2K8 R2 Server laufen zwar alle auf 5.x-Hosts, aber so etwas habe ich noch bei keinem je gesehen.

- Bist du die absolut sicher, dass der Hauptspeicher des Hosts einwandfrei funktioniert?
- Bist du die absolut sicher, dass das Installationsmedium des 2K8 R2 in Ordnung ist?

Experte
Beiträge: 1342
Registriert: 30.03.2009, 17:13

Beitragvon UrsDerBär » 12.10.2016, 10:06

Also die Probleme mit dem Patchen nach einer Neuinstallation kommen immer wieder mal. Habe es noch nie so wirklich begriffen was das eigentliche Problem ist. Ist aber bei fast allen OS der Fall.

Meistens läuft es so ab, dass man genau 1x nach Updates suchen kann bzw. Windows das selber einmal macht und nachher klappts nimmer. Gibt dann Fehler ohne wirkliche Fehlerbeschreibung wie in Deinem Fall. Ist aber eher bei der Verwendung von WSUS der Fall nicht wenn man via Internet geht.

Da manche Builds gehen, Tippe ich jetzt einfach mal auf nichtkompatible Versionen des Update Clients.

Abhilfe schafft hier nur die manuelle Installation eines aktuelleren Windows Update Clients. Oderer eben genügend schnell nach Installation. Danach läuft wieder alles wie gewohnt.
EDIT: Der Ordner Softwaredistribution sollte aber nach dem Update gelöscht werden.
- Stop wuauserv
- stop bits
- Software Distribution löschen
- start bits
- start wuauserv

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 12.10.2016, 16:15

Hi

Ich habe den Server nun nochmals aufgesetzt. Genau das gleiche Spiel wieder.

Ich muss dazu erwähnen, dass es sich um die 180 Tage Trial Version von Windows Server Enterprise RC1 SP1 x64 auf Deutsch handelt.

Beim Installieren gab es auch Probleme. Ich musste den Server 2x aufsetzten, weil einmal die Anmeldung nicht geklappt hat. Einen Blauen gabs auch Mal in der vm.

~thc hat geschrieben:- Bist du die absolut sicher, dass der Hauptspeicher des Hosts einwandfrei funktioniert?
- Bist du die absolut sicher, dass das Installationsmedium des 2K8 R2 in Ordnung ist?


Das Installationsmedium habe ich auch in Verdacht. Leider konnte ich keine MD5 Checksum auf der Microsoft Seite finden, beim Download.

Meine MD5 checksum wäre: e2508890839735dcfce216d17eefae2e.

Der Name der ISO ist: 7601.17514.101119-1850_x64fre_server_eval_de-de-GRMSXEVAL_DE_DVD.iso

Ich bin jetzt nochmals die ISO am runter laden.

Auch den Speicher kann ich nicht ausschliessen, da ich kein ECC habe. Der Host läuft aber wieder recht zuverlässig sonst, und da lauft einiges drauf.

Edit:

Ich habe das ISO nochmals runtergeladen. Das ISO hat die selbe checksumme wie das alte. Sonst setze ich dann halt Server 2012 auf, oder so. Obwohl ich auf Kacheln am Server verzichten könnte.

Experte
Beiträge: 1342
Registriert: 30.03.2009, 17:13

Beitragvon UrsDerBär » 12.10.2016, 18:31

Hast meinen Tipp mal beherzigt und den Update Client manuell installiert und dann nochmals gesucht?

King of the Hill
Beiträge: 13315
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 12.10.2016, 18:32

Wenn das normale 2008 wie Vista war, dann ist die R2 wie Win7 und hat somit auch diesen Pferdefuß (Stichwort Win7 Updates werden nicht gefunden oder die Suche dauert ewig) vererbt bekommen. Winzigweich könnte daran etwas ändern, zeigt jedoch seit Win10-Release wenig Interesse daran, dies auch umzusetzen.
Die c't vom Heise-Verlag hatte für Win7 unter http://www.heise.de/ct/ausgabe/2016-5-Windows-7-Windows-Update-Beine-machen-3100633.html eine Anleitung zum Lösung beschrieben. Die Downloads dazu sind immer noch vorhanden, folglich spielt nur noch die Reihenfolge der manuell einzuspielenden Updates eine Rolle und die kann ich dir heute Abend noch nennen.

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 12.10.2016, 20:02

UrsDerBär hat geschrieben:Hast meinen Tipp mal beherzigt und den Update Client manuell installiert und dann nochmals gesucht?


Ja natürlich. Ich hatte es an der alten Installation versucht, und bei der neuen Installation dann als Erstes gemacht (bevor ich Windows Update ausgeführt habe).

Dayworker hat geschrieben:... (Stichwort Win7 Updates werden nicht gefunden oder die Suche dauert ewig) vererbt bekommen.


Den Bug kenne ich bei Windows 7, da ich es relativ häufig aufsetze. Das KB3102810 installiere ich daher immer gleich als erstes, das reicht da aus bei dem Windows 7 Problem. Jedoch geht das bei 2k8 R2 nicht, und das Fehlerbild sieht zudem bei Win 7 ja anders aus.

Dayworker hat geschrieben: Die Downloads dazu sind immer noch vorhanden, folglich spielt nur noch die Reihenfolge der manuell einzuspielenden Updates eine Rolle und die kann ich dir heute Abend noch nennen.


Das wär nett ja. Wäre echt froh, wenn ich den Server noch zum geigen kriege.

King of the Hill
Beiträge: 13315
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.10.2016, 20:21

Schritt1 Windows6.1-KB3135445-x64.msu
Schritt2 Windows6.1-KB947821-v34-x64.msu

Wenn das noch nicht hilft, nur dann:
Schritt3 WindowsUpdateDiagnostic.diagcab


Das hilft mir zwar bei Win7, sollte aufgrund der Binärkompatibililililität zu Win2k8-R2 aber auch dort genauso funktionieren.


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast