Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

iSCSI-Storage lässt sich nicht erstellen

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 180
Registriert: 02.04.2010, 11:02

iSCSI-Storage lässt sich nicht erstellen

Beitragvon drnicolas » 06.02.2016, 14:53

Ich versuche mich gerade (erstmals) darin, einen neuen Datenspeicher auf iSCSI-Basis zu erstellen.
Scheitert aber.
Der Speicheradapter ist schon konfiguriert und listet auch "FreeBSD iSCSIDisk....", den Laufzeitnamen vmhba38:C0:T0:L0, 'Gemopuntet' und LUN0 sowie Kapazität 300GB auf.

Leider lässt sich dann doch kein Datenspeicher erstellen:

- ich wähle Fetsplatte/LUN
- danach finde ich die bereits beschr. iSCSI-Platte und wähle aus
- Im folgenden Screen "Aktuelles Festplattenlayout sehe ich nur "wird geladen ..." und nichts in der darüber liegenden Box.

- Das bleibt meist dabei
- manchmal kann ich zurück und wieder weiterblättern, gelegentlich steht dann die Information doch da.

- EVtl. bekomme ich dann nach langem Warten eine Meldung "Aufruf von "HostDatastoreSystem.QueryVmfsDatastoreCreateOptions" für Objekt "ha-datastoresystem" auf ESXi "192.168.1.230" ist fehlgeschlagen."
- In der o.g. Box stehen dann doch Angaben

- klicke ich jetzt weiter, kann ich einen Namen eingeben
- bei weiter kommt dann sofort eine Fehlermeldung "Im vSphere Client trat ein interner Fehler auf. Der Objektverweis wurde nicht auf eine Obejktinstanz festgelegt"

Kennt jemand die Meldung und ggf. Abhilfe ?

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 06.02.2016, 15:11

Wenn es eine normale Festplatte waere, die schon mal wo anderes Dienst tat dann liegts daran das er die Partition nicht lesen kann und dann schreibt man mit einem "fdisk" einfach eine leere Partitionstabelle. Die kann er es auch selber Formatieren fuer seine Zwecke.

Du kannst in deiner Verzeifelung das auch mal probieren. Ansonsten nimm mal ein anderes iSCSI Target.

Gruss
Joerg

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 06.02.2016, 17:58

Das ist scheinbar ein selbst gebasteltes iSCSI-Target auf Basis von FreeBSD. So etwas kann funktionieren - es gibt aber definitiv Target-Software, die ESXi nicht mag. Also bitte auch in den Logs der Target-Software (gegebenenfalls "Debug" einschalten) und im Log des ESXi schauen, ob ESXi mit dem unterstützten iSCSI-Befehlssatz vollständig zurechtkommt.

Member
Beiträge: 180
Registriert: 02.04.2010, 11:02

Beitragvon drnicolas » 06.02.2016, 19:05

Stimmt!
Ich benzutze NAS4Free ...2268.

Die zum Thema verfügbaren Anleitungen sind anscheinend auf Basis FreeNAS erstellt.
Insofern war ich guter Dinge alles 1:1 übernehmen zu können.

In welchem Log müsste ich denn nachgucken - auf den ersten Blick stand da nichts richtungsweisendes drin.

Allerdings wird man von den vielen Meldungen erschlagen.
Kann ich das betreffende Log kurz vor einem Versuch aktiv löschen ?

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 06.02.2016, 19:09

vmkernel.log

Gruss
Joerg

Member
Beiträge: 6
Registriert: 18.03.2008, 08:56

Beitragvon dirk12345 » 08.02.2016, 10:11

Verwendest Du evtl. Jumbo Frames? Prüfe auf jeden Fall mal ob auf allen involvierten Komponenten (NAS, Switch, vswitch, vmkernel port) die MTU Size korrekt eingestellt ist.

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 08.02.2016, 10:21

dirk12345 hat geschrieben:Verwendest Du evtl. Jumbo Frames? Prüfe auf jeden Fall mal ob auf allen involvierten Komponenten (NAS, Switch, vswitch, vmkernel port) die MTU Size korrekt eingestellt ist.


Code: Alles auswählen

vmkping -d -s 8972 <TargetIP>


sollte das zeigen.

Wenn man mehrere VMKs gemacht hat dann noch den Absender angeben und alle beteiligen VMKs testen.

Gruss
Joerg


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast