Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Überwachungs problem des vsphere server und deren VMs

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Überwachungs problem des vsphere server und deren VMs

Beitragvon Conan » 15.11.2015, 16:48

guten nabend zusammen.

Ich habe follgendes problem.
Ich lasse den server und seine seine VMs mit dem Programm PRTG Network Monitor überwachen.

das problem ist, das das programm nciht immer die Ssh und SNMP verbindung aufbauen kann.

kennt das jemand zufällig?

Gruss Conan

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 17.11.2015, 23:22

scheinbar niemand. ich werde mir woll anders helfen müssen,

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 04:39

Conan hat geschrieben:scheinbar niemand. ich werde mir woll anders helfen müssen,


Gemach,
was passiert wenn du im Zeitraum einer Störung manuell die Ports mit snmpwalk und telnet prüfst?
Falls möglich nutze mal check_mk als Alternative und schaue ob die gleichen Probleme auftauchen.
Gruss

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 18.11.2015, 14:03

SSH verbindung geht. Aber SNMP verbindungen gehen nicht.
Siehe ----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:53:48 (2 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:53:48 (2 ms) : SNMP V3
18.11.2015 13:53:48 (3 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:53:52 (4119 ms) : -------
18.11.2015 13:53:52 (4121 ms) : Value: 0
18.11.2015 13:53:52 (4122 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:53:52 (1 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:53:52 (2 ms) : SNMP V3
18.11.2015 13:53:52 (3 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:53:56 (4021 ms) : -------
18.11.2015 13:53:56 (4022 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:53:56 (4023 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:12 (2 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:12 (3 ms) : SNMP V3
18.11.2015 13:54:12 (4 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:12 (138 ms) : -------
18.11.2015 13:54:12 (139 ms) : Value: 0
18.11.2015 13:54:12 (140 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:23 (3 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:23 (4 ms) : SNMP V3
18.11.2015 13:54:23 (5 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:27 (4034 ms) : -------
18.11.2015 13:54:27 (4035 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:54:27 (4037 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:32 (5 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:32 (6 ms) : SNMP V3
18.11.2015 13:54:32 (16 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:36 (4042 ms) : -------
18.11.2015 13:54:36 (4046 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:54:36 (4058 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:37 (15 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:37 (22 ms) : SNMP V3
18.11.2015 13:54:37 (29 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:41 (4059 ms) : -------
18.11.2015 13:54:41 (4062 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:54:41 (4069 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:42 (12 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:42 (20 ms) : SNMP V3
18.11.2015 13:54:42 (30 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:46 (4066 ms) : -------
18.11.2015 13:54:46 (4069 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:54:46 (4078 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:47 (13 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:47 (20 ms) : SNMP V3
18.11.2015 13:54:47 (30 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:51 (4049 ms) : -------
18.11.2015 13:54:51 (4052 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:54:51 (4061 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:52 (18 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:54:52 (22 ms) : SNMP V3
18.11.2015 13:54:52 (29 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:54:56 (4036 ms) : -------
18.11.2015 13:54:56 (4040 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:54:56 (4050 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:54:57 (13 ms) : Device:
18.11.2015 13:54:57 (21 ms) : SNMP V3
18.11.2015 13:54:57 (32 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:55:03 (6137 ms) : -------
18.11.2015 13:55:03 (6139 ms) : Value: 0
18.11.2015 13:55:03 (6140 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:55:03 (16 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:55:03 (22 ms) : SNMP V3
18.11.2015 13:55:03 (30 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:55:07 (4059 ms) : -------
18.11.2015 13:55:07 (4062 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:55:07 (4072 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:55:07 (17 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:55:07 (24 ms) : SNMP V3
18.11.2015 13:55:07 (33 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:55:11 (4115 ms) : -------
18.11.2015 13:55:11 (4119 ms) : Value: 0
18.11.2015 13:55:11 (4127 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:55:12 (11 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:55:12 (20 ms) : SNMP V3
18.11.2015 13:55:12 (27 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:55:16 (4175 ms) : -------
18.11.2015 13:55:16 (4178 ms) : Value: 0
18.11.2015 13:55:16 (4186 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:55:17 (11 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:55:17 (25 ms) : SNMP V3
18.11.2015 13:55:17 (29 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:55:21 (4063 ms) : -------
18.11.2015 13:55:21 (4067 ms) : Value: No response (check: firewalls, routing, snmp settings of device, IPs, SNMP version, community, passwords etc) (SNMP error # -2003)
18.11.2015 13:55:21 (4079 ms) : Done


----------------------- New Test -----------------------
Paessler SNMP Tester 5.1.2
18.11.2015 13:55:22 (11 ms) : Device: XXX.XXX.XXX.XXX
18.11.2015 13:55:22 (19 ms) : SNMP V3
18.11.2015 13:55:22 (28 ms) : Custom OID 1.3.6.1.2.1.5.2.0
18.11.2015 13:55:28 (6128 ms) : -------
18.11.2015 13:55:28 (6131 ms) : Value: 0
18.11.2015 13:55:28 (6138 ms) : Done


manhmal gehts, machmal nciht.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 14:38

Conan hat geschrieben:SSH verbindung geht. Aber SNMP verbindungen gehen nicht.



Snmp ist eingeschaltet?
reagiert was auf port 161, z.B. mit telnet testen
Kannst du von einer Linuxbüchse ein snmpwalk absetzen?

Gruss

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 18.11.2015, 15:03

Geht SNMP garnicht oder nur ab und an nicht? Wenn man SNMP v3 verwenden moechte dann muss man auch etwas tun auf ESXi Host Seite.

Gruss
Joerg

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 18.11.2015, 15:26

@irix
snmp geht nur ab und an, mehr nicht als geht.

Was muss man machen auf esxi seite?

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 15:50

Conan hat geschrieben:@irix
snmp geht nur ab und an, mehr nicht als geht.

Was muss man machen auf esxi seite?


Setz dir ein Linux System auf und teste per Konsole mit snmpwalk etc. aus was genau das Problem ist.
Ich habe hier auch geht und geht nicht mit einem IBM Bladecenter und bin swoeit das klar ist das die Bladeseite das Probem ist.

Gruss

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 18.11.2015, 16:05

Conan hat geschrieben:@irix
snmp geht nur ab und an, mehr nicht als geht.


Bezogen auf einen Check oder aber gehen einige SNMP und andere gehen generell nicht?



Was muss man machen auf esxi seite?


Bei v1 muss man den Service nur aktiviert haben und den Comminuity String angeben wobei ich nicht weis ob er automatisch den Default "public" nimmt. Wir haben einen Non-Default un den muss ich aendern.

Wenn man v3 spricht dann muss man die Credentials/Hashes hinterlegt haben. Wenn man das nicht tut dann gehts es aber generell nicht.

Also sage uns
- Wird v1 oder v3 verwendet
- Tritt dein Problem bei den selben Checks auf?

Deine Ueberpruefung von oben spricht v3 und das kann generell nicht gehen wenn du auf ESXi Seite nichts gemacht hast. Das v3 ist auch eher unueblich weil es halt mehr Aufwand ist.

Gruss
Joerg

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 18.11.2015, 16:14

@irix
bezogen auf die checks, mal bekomme ich eine antwort mal nicht.
Sekunde!
Der esxi server wird per snmpv1 abgefragt,
https://www.dropbox.com/s/mnxpgkp3vu1d1 ... r.png?dl=0
Die Linux VMs werden per SNMPv3 abgefragt.
https://www.dropbox.com/s/g6p63yakk8qlf ... m.png?dl=0
Insgesamt 1xserver und 6xSysteme die abgefragt werden sollen.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 16:34

Conan hat geschrieben:@irix
bezogen auf die checks, mal bekomme ich eine antwort mal nicht.
Sekunde!
Der esxi server wird per snmpv1 abgefragt,
https://www.dropbox.com/s/mnxpgkp3vu1d1 ... r.png?dl=0
Die Linux VMs werden per SNMPv3 abgefragt.
https://www.dropbox.com/s/g6p63yakk8qlf ... m.png?dl=0
Insgesamt 1xserver und 6xSysteme die abgefragt werden sollen.


Bleib doch bitte erst mal bei dem ESX und teste nur den alleine.
Linux VMs die was nicht so machen wie sie sollen sind normalerweise kein Vmware-Thema.
Konkret:
Mach alle VMs aus wenn es geht und schaue ob der ESX Host sauber und zuverlässig antwortert. Wenn ja prima wenn erst mal genau dieses Problem ohne potentielle Seiteneffeke analysieren.
Und wie schon gesagt aus einer Linux-Büchse raus um auszuschliessen das prtg oder das System darunter Probleme macht. Mir fallen da z.B. Firewalls und Enpointsecurities ein. PRTG läuft ja unter Windows.
snmp kann auch schon mal auf timeouts laufen.

Dropbox ist bei mir gesperrt. Ich kann die Infos daher nicht einsehen.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 16:35

Conan hat geschrieben:@irix
bezogen auf die checks, mal bekomme ich eine antwort mal nicht.
Sekunde!
Der esxi server wird per snmpv1 abgefragt,
https://www.dropbox.com/s/mnxpgkp3vu1d1 ... r.png?dl=0
Die Linux VMs werden per SNMPv3 abgefragt.
https://www.dropbox.com/s/g6p63yakk8qlf ... m.png?dl=0
Insgesamt 1xserver und 6xSysteme die abgefragt werden sollen.



noch ein FAQ Artikel von prtg
http://kb.paessler.com/en/topic/46863-m ... t-can-i-do

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 18.11.2015, 16:52

in den beiden bilder auf der dropbox sieht man genau das der server als auch die vms, die auf dem vspere laufen, das gleiche problem haben.
Wen bei dir dropbox gesperrt ist, sieht du halt nicht die bilder.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 17:05

Conan hat geschrieben:in den beiden bilder auf der dropbox sieht man genau das der server als auch die vms, die auf dem vspere laufen, das gleiche problem haben.
Wen bei dir dropbox gesperrt ist, sieht du halt nicht die bilder.


Dann schau dir den FAQ Artikel an. GGf. kriegst du damit dein Problem weiter eingegrenzt.

Gruss

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 18.11.2015, 17:06

@Conan

Ist dir schon aufgefallen, dass PRTG ein Abfrageintervall von nur 5 Sekunden hat und die Antwort manchmal erst 6 Sekunden später eintrifft? Bei 7 SNMP-Targets bedeutet dass im Durchschnitt eine Abfrage alle 0,7 Sekunden.

Kompletter "Überwachungs-Overkill".

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 18.11.2015, 17:45

Jup, das hab ich absichtlich so eingestellt.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 17:50

Conan hat geschrieben:Jup, das hab ich absichtlich so eingestellt.


Warum?
Mit intensiven Messen kann man Systeme ganz schnell runter reißen.


Gruss

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 18.11.2015, 17:59

weil ich das wünsche.

aber auch mit 30sec, kommt es ständig zu fehlern.

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 18.11.2015, 18:18

Conan hat geschrieben:weil ich das wünsche.

aber auch mit 30sec, kommt es ständig zu fehlern.


Dafür ist snmp so erst mal nicht gedacht.
Fang mit 5 Minuten Intervallen an und arbeite dich runter bis es anfängt zu zu Problemen zu kommen. Und fange mit genau einem System an und arbeiten die FAQ durch.
Mehr ist dazu erst mal nicht zu sagen ohne sich im Kreis zu drehen.

Gruss

Guru
Beiträge: 2525
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 18.11.2015, 18:25

Man kann aus deinem Log-Ausschnitt ablesen, dass das Timeout 4 Sekunden zu sein scheint, aber manche Antworten länger brauchen (6 Sekunden) und trotzdem angenommen werden. Probier' einfach höhere Werte für das Timeout und das Intervall.

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 20.11.2015, 21:28

Also das die ssh verbindung nicht in ordnung war, war eine fehl interpretation, winscp hat die verbindung verloren, weil kein erhaltungs paket geschickt worden ist, war also kein fehler, sondern eine falsche einstellun von winscp die ich behoben haben.

Bei snmp hab ich kommplet auf v1/v2 umgestellt. Jetzt kommen zwar immer noch fehler, aber weniger wie vorher.

Ich danke euch für eure hilfe.

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 20.11.2015, 21:31

Deine Abfragefrequenz ist viel zu hoch und das ist der Grund fuer die Probleme.

Gruss
Joerg

Member
Beiträge: 119
Registriert: 19.01.2009, 15:54

Beitragvon Conan » 20.11.2015, 22:01

nope, auch mit 30sec & 60sec, kommen fehler.

King of the Hill
Beiträge: 12569
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 20.11.2015, 22:02

Conan hat geschrieben:nope, auch mit 30sec & 60sec, kommen fehler.


Doch... weil du den Sinn von SNMP bzw. Traps nicht verstanden hast.

Gruss
Joerg

Guru
Beiträge: 2938
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 21.11.2015, 08:38

irix hat geschrieben:
Conan hat geschrieben:nope, auch mit 30sec & 60sec, kommen fehler.


Doch... weil du den Sinn von SNMP bzw. Traps nicht verstanden hast.

Gruss
Joerg

Mal wieder knackig auf den Punkt gebracht.
Immer wieder gerne genommen das Leute glauben das Naturgesetzte etc. nicht für sie gelten.

Gruss


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast