Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

openWRT VPN Gateway auf dem ESXi

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: irix, continuum, Dayworker

King of the Hill
Beiträge: 13318
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 10.05.2016, 18:15

Also seit der Einführung von "libata" bei Linux, muß 2006/2007 gewesen sein, werden alle Datenträger mit SD beginnend angesprochen. Von der Warte spielt es keine Rolle mehr, über welchen Plattenanschluß ein Datenträger verbunden ist und demzufolge dürfte auch die "fstab" bzw "mtab" damit keine Probleme haben.

Wenn es wirklich kompatibel sein soll, bleib vorerst bei SCSI. Damit kannst du jederzeit noch mit niedrigeren v.HW-Versionen arbeiten, falls die Virtualisierungssoftware schon etwas älter sein sollte. IDE hat inzwischen zuviele Nachteile und SATA ist halt von der v.HW-Version abhängig.

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 15.05.2016, 18:16

Hi

Ich habe definitiv Probleme, die Version auf dem ESXi zum laufen zu bringen, die per SATA auf dem Laptop sowie paravirtualisiert läuft.

Ich habe IDE, lsilogic und SATA eingetragen. Und jedes Mal die VM aus dem Inventar genommen für die Versuche.

Wär echt nice, wenn ich das mit dem gleichen Image laufen lassen könnte auf vSphere.

Sonst müsste ich wieder die Box auslesen, um an das ide Image zu kommen. Aber vielleicht wär das die beste Lösung für alle Plattformen.

Guru
Beiträge: 2519
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 15.05.2016, 20:27

Lässt sich die VM nicht auf dem VMWare Player 12.0.1 mit S-ATA erstellen und dann einfach (Kopie) auf den ESXi übertragen?

King of the Hill
Beiträge: 13318
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 15.05.2016, 20:33

Unter ESXi6.x ist es fraglich, wielange dort IDE als Datenträger und/oder die niedrigeren v.HW-Versionen noch unterstützt werden. Bereits seit einigen ESXi-Versionen ergeben sich mit IDE-Datenträgern einige Einschränkungen, IDE kommt daher höchstens noch als virtualisiertes CD/DVD-Laufwerk zum Einsatz.

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 17.05.2016, 16:33

~thc hat geschrieben:Lässt sich die VM nicht auf dem VMWare Player 12.0.1 mit S-ATA erstellen und dann einfach (Kopie) auf den ESXi übertragen?


Beim ESXi gibts ja kein SATA, auch nicht mit VM Version 10 nicht. Das gibts anscheinend nur bei den Desktopprodukten.

Wie gesagt, auf dem ESXi hatte ich es per IDE am laufen. Mit Virtual Box und vmware WS per SATA und einer angehängten vmdk.

Ich mach das wenn möglich genau so, wie Dayworker sagt: per SCSI.

Allerdings hatte ich bei SATA, und dem nicht getesteten Image das Problem, dass ich kein Backup der Einstellungen der Box einspielen konnte. Auf die Hardwarebox wird vom LAN per Browser das Admin Interface geöffnet. Dort kann ich zwar die Zertifikate importieren, das läuft also. Diese lade ich auch per Browser hoch.

Aber das Backup der Einstellungen kann ich nicht so einspielen. Dazu wird bei der Hardwarebox direkt am Gerät ein USB Stick eingesteckt, dort wird das Backup geschrieben und ausgelesen. Der Upload funktioniert also leider nicht per Client (Browser).

Und witzig ist auch, dass der USB Stick auch per SCSI eingebunden wird, und der scheint im Moment grad zu funktionieren:

Bild

Per SSH hätte ich noch Zugriff auf eine Busy Box der VM, dort kann man aber nur sehr rudimentär arbeiten. Und mit Knoppix habe ich auch allen Tod und Teufel probiert :)

Ich möchte es jetzt mit dem offiziellen Image versuchen, bzw., habe das schon eingespielt. Ich habe also einen SCSI Controller mit einer VMDK konfiguriert.

Ich habs mit einer vmdk, und mit einer VHD versucht. Beides Mal kommt da wieder der Fehler
Waiting for root device PARTUUID=c907f805-02...

Wenn ich es mit dem offiziellen Image hinkriege, wär das super. Ich habe das Enigmabox.vbox Konfigurationsfile für Virtual Box, da eilt es grad -> wie auch auf dem ESXi, und die Ausgabe vom COM Port hochgeladen:

Serial_log_und_Configfile.txt

Sonst hätte es hier eine Anleitung, wie ich das ganze selber kompilieren könnte. Der Entwickler hatte da so einen Compiler aufgerufen, wo er alles irgendwie einzeln ändern konnte. So ähnlich dem Gentoo Kompiler.

https://docs.enigmabox.net/de/firmware.html

Da hats auch noch eine Anleitung:

https://wiki.openwrt.org/de/doc/howto/obtain.firmware

Hat da noch einer eine Idee dazu, wie ich das per SCSI hinkriege?[/url]

Nur wenn ich es selber kompiliere, habe ich das Problem, dass bei einem Update wieder das vom Entwickler gezogen wird. Da müsste man die VM auch auf ein andere Quelle verweisen. So wie ich verstanden habe, gibt es offiziell nur zwei Images, ein 32 bit und ein 64 bit.

Und dann noch die ominöse .vmdk, die der Entwickler kompiliert hat (welche per SATA läuft). Von den zwei Images gibt es dann noch verschiedene Versionen. im Moment ist es bei openWRT 2.2.0.

Guru
Beiträge: 2519
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 17.05.2016, 17:41

MarroniJohny hat geschrieben:Ich möchte es jetzt mit dem offiziellen Image versuchen, bzw., habe das schon eingespielt. Ich habe also einen SCSI Controller mit einer VMDK konfiguriert.

Ich habs mit einer vmdk, und mit einer VHD versucht. Beides Mal kommt da wieder der Fehler
Waiting for root device PARTUUID=c907f805-02...

Wenn ich das jetzt alles richtig verstanden habe - dann bist du doch wieder am Anfang des Threads:

1. Du hast ein offizielles Enigmabox-Image
2. Dieses Image enthält keinen Support für SCSI (braucht die Hardware-Enigmabox nicht)
3. An einem virtuellen SCSI-Controller bleibt der Bootvorgang stehen.

Wenn du jetzt - wie am Anfang - einfach eine SCSI-VM um das unveränderte enigmabox-Image herum baust, dann kann das nicht funktionieren. Du braucht es nicht noch einmal zu probieren.

Die Lösung wäre also, ein enigmabox-Image zu kompilieren, dass SCSI-Unterstützung mitbringt. Dann hast du das von dir beschriebene Update-Problem - das beißt sich also.

Der Kompromiss: Bleib bei IDE.

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 17.05.2016, 18:15

Ich habe jetzt dem Entwickler Mal eine Mail geschrieben. Vielleicht kann er ja ein modifiziertes Image machen, dass auf alle Controllertypen hört.

Für SCSI Support, müsste er da die LSI Treiber installieren in dem Image, oder ist das mit dem SCSI eine kleinere Sache? Hat mir da einer Info's dazu?

Er hat halt grad noch andere Projekte. Hoffe, er erbarmt sich, und setzt sich da nochmals hin dann.

Und ist es irgendwie möglich, die jeweiligen Gasterweiterungen per Live Linux zu installieren? Wie mach ich das? Das wird auch das Problem mit den USB Backup's lösen, denk ich.

Bei virtual Box habe ich ohne Gasterweiterungen nur USB 1.1. Das wird das Problem sein.

Und könnte er da theoretisch auch mehrere Gasterweiterungen in dem Image installieren, sprich für vmware, virtual Box, Parallels WS, und so?

Mit dem USB Stick siehts so aus:

Bild

Guru
Beiträge: 2519
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 17.05.2016, 18:43

MarroniJohny hat geschrieben:Für SCSI Support, müsste er da die LSI Treiber installieren in dem Image, oder ist das mit dem SCSI eine kleinere Sache? Hat mir da einer Info's dazu?

Der Kernel des OpenWRT muss SCSI-Support für einen der virtuellen LSI Controller mitbringen.

MarroniJohny hat geschrieben:Und ist es irgendwie möglich, die jeweiligen Gasterweiterungen per Live Linux zu installieren? Wie mach ich das? Das wird auch das Problem mit den USB Backup's lösen, denk ich.

Für USB braucht es keine Gast-Erweiterungen.

MarroniJohny hat geschrieben:Bei virtual Box habe ich ohne Gasterweiterungen nur USB 1.1. Das wird das Problem sein.

Du brauchst die Virtualbox-Extension für 2.0 und 3.0. Der Gast sollte zumindest 2.0 auch alleine können - es sein denn, OpenWRT sieht auch das nicht vor...

MarroniJohny hat geschrieben:Und könnte er da theoretisch auch mehrere Gasterweiterungen in dem Image installieren, sprich für vmware, virtual Box, Parallels WS, und so?

Das würde ich nicht versuchen.

Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Beitragvon MarroniJohny » 27.05.2016, 14:10

Dayworker hat geschrieben:Also seit der Einführung von "libata" bei Linux, muß 2006/2007 gewesen sein, werden alle Datenträger mit SD beginnend angesprochen. Von der Warte spielt es keine Rolle mehr, über welchen Plattenanschluß ein Datenträger verbunden ist und demzufolge dürfte auch die "fstab" bzw "mtab" damit keine Probleme haben.

Wenn es wirklich kompatibel sein soll, bleib vorerst bei SCSI. Damit kannst du jederzeit noch mit niedrigeren v.HW-Versionen arbeiten, falls die Virtualisierungssoftware schon etwas älter sein sollte. IDE hat inzwischen zuviele Nachteile und SATA ist halt von der v.HW-Version abhängig.


Hi

IDE und SATA habe ich ja schon am laufen. Der Entwickler meinte aber, dass die SCSI Unterstützung eventuell schon gegeben sei. Ich vermute, dass ich einfach die falschen Settings habe in der Virtualisierungsumgebung. Du hast ja auch Mal angedeutet, in dem Fred hier, dass wenn man den Controller ändert, man eventuell die Sektoren und Zylinder anpassen muss. Mir fehlen wohl einfach immer noch die Basics, für das Problem. Ich seh da echt noch nicht ganz dahinter.

Wenn der Entwickler mal Zeit hat dann, schauen wir uns die bestehnden Probleme an, und eventuell macht er dann ein passendes Image, falls notwendig.

Könnt Ihr nochmals sagen, was wir da genau machen müssen, dass das Image überall läuft? Die Host und Gast Seite interessiert mich.


Benutzeravatar
Profi
Beiträge: 500
Registriert: 20.10.2011, 17:55

Re: openWRT VPN Gateway auf dem ESXi

Beitragvon MarroniJohny » 27.06.2017, 18:26

Hi

Mal durch den Convertor zu jagen hilft Wunder :grin:


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast