Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

ESXi 6 - Samba Server (Ubuntu) - HDD sehr sehr langsam

Alles zum Thema vSphere 6, ESXi 6.0 und vCenter Server.

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

ESXi 6 - Samba Server (Ubuntu) - HDD sehr sehr langsam

Beitragvon kaineanung » 11.08.2015, 10:10

Hallo Leute,

ich bin ziemlich neu in der VM-Geschichte. Ich nutze VM zwar bei der Arbeit für diverse kleinere Geschichten, jedoch nicht im Bereich wo schnelligkeit und Leistung gefragt sind.
Nun habe ich zu Hause ein Samba-Server unter Ubuntu Core Server 14.04 eingerichtet und nutze diesen eben als Fileserver. Ich habe auch ein DLNA-Server auf der Maschiene laufen und da stockt das Bild unerträglich.
Dann habe ich einmal die Lese-/Schreibgeschwindigkeit getestet und siehe da: bis max. 5 MB/s lesen und 3 MB/s schreiben! Das ist ja irre langsam!

Ich habe ein Dell PowerEdge T20 mit Xeon 4x3.2 GhZ CPU, 8 GB RAM und 3 Festplatten.
1. HDD: 80 GB Systemplatte
2. und 3. HDD: jeweils 1 TB im RAID 1 Verbund (OnBoardcontroller)

Auf dem RAID 1 Verbund ist ein fast 1 TB großes Truecrypt-Volume welches gemountet ist und da drauf snid die Daten für den Fileserver.

Ohne VM hat alles gut und schnell funktioniert. Nachdem ich das alles nun neu aufgesetzt habe auf dem ESXi habe ich massive Geschwindigkeitsprobleme und weiß jetzt nicht wo ich ansetzen soll um die Geschwindigkeit zu erhöhen. Die Hardware ist sehr potent und hat auch, wie erwähnt, ohne VM bereits gut funktioniert.

Ich habe ein wenig an den Ressourcen gespielt und alles auf Anschlag gestellt (CPU-Aneile, RAM-Antiele, HDD-Anteile) aber das hat nichts gebracht.

VM-Tools sind natürlich installiert.

Was kann ich jetzt machen?
Vielen Dank schon einmal im Voraus für eure Hilfe.

King of the Hill
Beiträge: 12368
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 11.08.2015, 15:46

Der Dell T20 hat keinen HW-Raidcontroller, sondern nutzt den normalen Controller im Chipsatz, hat somit auch keinen Write-Cache und ohne Write-Cache wird jede HDD lahm. Ein HW-Controller schaltet bei Raid immer den Plattencache ab und die Cache-Funktion übernimmt dann der HW-Controller. Deine IO-Werte sind also als normal anzusehen für jeden Controller ohne Write-Cache.

Eventuell kannst du den Plattencache am Controller vorbei wieder anschalten. Dann droht dir aber bei Spannungsschwankungen immer eine Inkonsistenz in jedem Raid-Level. Ein HW-Controller bringt für diesen Fall eine BBU mit, die den Cacheinhalt für eine bestimmte Zeit, die HW-Hersteller haben sich da auf 2 Tage eingeschossen, speichert und dann zumindest die Raid-Konsistenz aufrechterhält. Das dann Daten ggf unvollständig sind, ist noch das kleinere Übel. Das grössere Übel wäre, wenn das Raid einen Rebuild startet. Das kann je nach Raidlevel, Plattenperformance und und vor allem Plattengrösse durchaus auch mehrere Tage dauern.

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 11.08.2015, 16:20

@Dayworker

Ich habe jetzt leider keine Geschwindigkeitsmessungen der gleichen HDDs im gleichen Raidverbund ohne VM (also auf der Hardware installiert). Ich garantiere jedoch das ich bei weitem mehr als diese mickrigen Schreib-/Leseraten, die ich im Moment habe, hatte und ich im gesamten Netzwerk auf die Clients, sogar parallel, Videoinhalte streamen konnte.

Somit glaube ich nicht das es am lahmen Plattenchache liegt (bestimmt ist die Geschwindigkeit im Gegensatz zu den Hardware-Controllern enorm niedrig, aber es hat ausgereicht um in der Praxis keine einbussen zu spüren).

Das Andere was mich davon überzeugt das es nicht am RAID-Verbund liegt:
die Geschwindigkeitsmessungen habe ich im Benutzer-Homeverzeichnis gemacht. Also auf der einzelnen Systemplatte. Den Raidverbund habe ich in das Verezichnis /medien gemountet und dort habe ich erst gar keine Messungen vollzogen da bereits auf der Systemplatte die Werte immens mies sind.

Also nicht vergessen:
Ich habe in der entsprechenden VM-Maschine 3 HDDs eingebunden. 1 ist eine einzelne 80-GB-Platte mit Ubuntu Server Core drauf. Die anderen 2 sind in einem RAID-1 Verbund welche dann in VM als eine HDD eingebunden wurde. Somit habe ich 2 angezeigte HDDs die in die VM eingebunden ist.

Die ohne Raid ist bereits so irre mies langsam so daß ich bezweifle daß dies mit dem RAID-Controller was zu tun hat.

Ich hoffe hier auf Hilfe weil ich sehr gerne meine Server virtuell halten will. Wenn das aber so bleibt mit den lahmen Platten, muss ich leider wieder zurück und das System auf die Hardware aufsetzen...

Hat denn niemand sonst ähnliche Probleme gehabt?

Profi
Beiträge: 991
Registriert: 31.03.2008, 17:26
Wohnort: Einzugsbereich des FC Schalke 04
Kontaktdaten:

Beitragvon kastlr » 11.08.2015, 16:46

Hallo,

welches Filesystem hast du denn auf dem RAID1 in Verwendung?
Deiner Beschreibung nach reichst du das 1TB große Volume nativ an die VM durch, somit hast du dort höchst wahrscheinlich kein VMFS Volume angelegt.
Und wo liegen denn eigentlich die System Disks deiner VM's, wenn du das RAID1 an eine VM durchgereicht haben solltest?

Trifft diese Annahme mit dem Durchreichen zu, könnte der Unterschied darin begründet sein, das die Treiber für deinen Controller beim Einsatz von ESXi nicht so performant sind wie beim Einsatz von Ubuntu.
Oder reichst du den Controller eventuell auch direct an die VM weiter?

Eventuell verwendet der ESXi Treiber auch andere Einstellungen wie. z. B. Queue Depth oder kein MSI-X.


Du könntest ja mal mit esxtop nachsehen, wie viele IO's und welchen Dursatz du dabei erzeugst, ein gutter Wert ist auch DAVG.

Gruß,
Ralf

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 11.08.2015, 23:41

@kastir

Das Filesystem ist ext4 auf dem RAID 1 wie auch auf allen anderen bis auf die boot-Partition wo ext2 angezeigt wird.

Ob ich das RAID 'durchreiche' oder nicht kann ich dir so nicht genau sagen. Ich habe eine HDD eingehängt, in Sphere 6 eine VM erstellt und die Festplatte ausgewählt als Speicherort.

So ähnlich, nur eben als 2. HDD, habe ich den RAID-1-Verbund hinzugefügt und bereit gestellt. Diese ist aber seperat (Modus: unabhängig) und wird auch von VM-Snapshot-Manager nicht abgebildet wenn ich ein Snapshot machen will.
In den Eigenschaften ist die 1. HDD 'Thick-Provision Lazy-Zeroed' und der Knoten des virt. Gerätes 'SCSI (0:0) Festplatte 1' und die 2. HDD( RAID 1) ebenso vom Typ angezeigt, Knoten 'SCSI (0:1) Festplatte 2' und der Modus 'Unabhängig - Dauerhaft'.

Wie gesagt, auch die Systemplatte ist irre langsam weil ich ja im user-homeverzeichnis in einem angelegten temp-ordner den lese-schreibtest gemacht habe mit 'dd if=/dev/zero of=tempfile bs=1M count=1024 conv=fdatasync,notrunc '. Und der ergab diese sehr sehr langsamen Messergebisse.

Ob ich den Controller so durchreiche kann ich auch nicht sagen. Wenn ihr mir sagt wo ich das nachschauen kann, so würde ich das euch wissen lassen.

Der SCSI-Controller der VM wird als 'LSI Logic SAS' angezeigt. An diesem habe ich aber bereits herumgespielt und diesen dann auf das gesetzt. Davor war 'LSI Logic Parallel'.
Als ich dies vor 2 Wochen gemacht hatte, hat es kurz ausgesehen als ob mit der Geschwindigkeit es besser geworden ist (plötzlich lesend über 10 MB/s). Aber jetzt, nach meinem Urlaub, ist es wieder wie vor der Umstellung.

esxtop und DAVG sagen mir leider nichts?. Auch das davor erwähnte 'Depth' oder kein 'MSI-X' sind für mich fremd.

Member
Beiträge: 206
Registriert: 09.09.2010, 14:12

Beitragvon Sven_B1982 » 12.08.2015, 09:49

Mal rein ins blau geschossen, du hast deiner VM nicht zufällig das maximum an zu verfügung stehenden Ressourcen zugewiesen? Also 4x3.2 GhZ und 8 GB RAM ?

Profi
Beiträge: 991
Registriert: 31.03.2008, 17:26
Wohnort: Einzugsbereich des FC Schalke 04
Kontaktdaten:

Beitragvon kastlr » 12.08.2015, 10:07

Hallo,

innerhalb der VM verwendest du natürlich das Filesystem, welches du während der Installation des Betriebssystems ausgewählt hast.
Meine Frage zielte darauf ab, ob du die am ESXi sichtbaren Platten/Volumes zuvor mit VMFS formartiert hast oder nicht.

Deine VM verfügt über zwei (virtuelle) Festplatten, somit muß dafür auf einer/mehreren physikalischen Komponente Platz belegt worden sein.

Vermutlich liegt deine Festplatte 1 (SCSI 0:0) auf der 80 GB Systemfestplatte, während deine Festplatte 2 (SCSI 0:1) auf dem RAID Liegt.
Dieses ist vermutlich als raw device (RDM) an deinen Ubuntu Server durchgereicht worden, somit befindet sich darauf nur dein ext4 Filesystem und kein VMFS, auf dem sich dann eine 1TB große vmdk Datei befindet.

Wenn du zum Testen deines Ubuntu Systems die Festplatte 1 (SCSI 0:0) verwendet hast verwundert mich die schlechte Performance nicht.
Da du beim Anlegen der vmdk "Lazy Zeroed" ausgewählt hast, wird dir zwar der Platz reserviert, aber dieser Bereich wird beim Anlegen der vmdk nicht initialisiert.
Wenn du nun einen Schreibvorgang auf einen nicht initialisierten Track durchführen möchtest, hat die Systemplatte zwei IO's zu bearbeiten.
Der erste IO führt eine zero out durch, im Anschluß daran kommen erst die Daten, welche deine VM schreiben möchte.
Und da nichts dadurch schneller wird das man es zweimal macht kriegst du aus Sicht deines Lasttests (dd) so schlechte Werte.

Dein dd Test weiß aber gar nichts von dem voran gestellten IO, somit kriegst du in der VM nur gesagt, das ein IO eine schlechte Response Zeit hat.
Denn dd mißt die Zeit vom Erzeugen des IO Request bis zum Erhalt des Acknowledge, und den reicht der ESXi Server erst dann an die VM zurück, wenn beide IO's abgeschlossen sind.

Da du mit einer Blocksize von 1 MB testest bist du offensichtlich eher an einem hohen Durchsatz und weniger an einer geringen Responsezeit des RAIDs interessiert.

Vermutlich befindet sich auch dein ESXi System auf dieser Systemplatte und da dieser die Platte auch zum Logging verwendet konkuriert deine VM mit dem ESX um diese physikalische Resource.

Und schließlich ist die Frage von Sven über die der VM zugewiesenen Resourcen ebenfalls berechtigt, denn so ein Konstrukt könnte ebenfalls zu Lasten der Performance gehen.

Die weiteren Punkte meines ersten Posts lasse ich hier noch mal unberücksichtigt, sofern erforderlich können wir darauf ja im Rahmen der weiteren Anaylyse eingehen.

Gruß,
Ralf

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 12.08.2015, 11:57

@Sven_B1982

Zuerst nicht, aber dann habe ich nachträglich alles auf das max. Hochgesetzt.
4 Kerne auf einem Sockel, 8 GB RAM.
In der Ressourcenzuteilung dann irgendwann mal später auch noch alles auf Anschlag. Dennoch sind die HDDs sehr langsam...

@kastir
Ach so, ja klar. Werde ich heute Abend mal nachschauen und dann posten welches FS die Festplatten haben die der VM zur verfügung stehen (also hardwaremäßig sozusagen).

Benutzeravatar
Moderator
Beiträge: 14693
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 12.08.2015, 16:58

Auch nach 3-maligem Lesen dieses Posts kann ich nicht nachvollziehen wo sich auf diesem System ein VMFS-datastore befinden soll, in dem eine 80GB Thickprovisioned vmdk gespeichert werden könnte.

Wahrscheinlich reden wir hier komplett aneinander vorbei :?:

Beantworte bitte mal folgende Fragen:

Wieviele Datastores werden im vSphere-client angezeigt und wie gross sind diese ?

Bitte zeig uns mal die Ausgabe von fdisk -l vom Ubuntu-server.

Wenn das Raid1 durch Linuxsoftware gebildet wird, sollte fdisk auflisten
/dev/md0
/dev/sda
/dev/sdb
/dev/sdc

Wemn das Raid1 durch den physikalischen Controller gebildet wurde sollten nur
/dev/sda
/dev/sdb
angezeigt werden.

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 12.08.2015, 17:07

kaineanung hat geschrieben:Zuerst nicht, aber dann habe ich nachträglich alles auf das max. Hochgesetzt.
4 Kerne auf einem Sockel, 8 GB RAM.
In der Ressourcenzuteilung dann irgendwann mal später auch noch alles auf Anschlag. Dennoch sind die HDDs sehr langsam...


Sowas ist eher kontraproduktiv. Der ESXi braucht ja auch noch was zum arbeiten. Man gibt einer VM immer nur soviel Resourcen wie sie WIRKLICH braucht.

Ansonsten müßten wir wirklich erst mal verstehen wie die Plattenkonfiguration denn nun genau aussieht sonst kann man gar nichts sagen.

Was ist denn T20 Onboardcontroller ? Intel Rapid Storage Controller 12.X ? Ist das ein FakeRAID ?

Profi
Beiträge: 991
Registriert: 31.03.2008, 17:26
Wohnort: Einzugsbereich des FC Schalke 04
Kontaktdaten:

Beitragvon kastlr » 12.08.2015, 17:13

Hi Ulli,

ich nehme einfach mal an, das die ESXi Installation auf der 80 GB SystemPlatte erfolgt ist.
Da bleibt aber noch einiges an Kapazität für andere Zwecke übrig, und dort wird dann normalerweise gleich ein VMFS drauf gelegt.

Kann aber auch sein, das ich mit meiner Annahme völlig daneben liege.

Warten wir mal ab, was für neue Erkenntnisse/Informationen wir demnächst erhalten warden.

Gruß,
Ralf

King of the Hill
Beiträge: 12368
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 12.08.2015, 17:31

Der T20 hat und das verwundert mich jetzt echt, den C226-Chipsatz verbaut. Wir sprechen daher über ein Fake-Raid oder hat hat der T20 noch einen anderen Controller?

Für so einen Leistungseinbruch könnte auch ein falsches Alignment sorgen. Aber wir sollten wirklich erst die Rückmeldung des TE abwarten...

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 13.08.2015, 08:24

@kastir

Also, in der Hostkonfiguration unter 'Speicher-Datenspeicher' sehe ich meine 2 HDDs (wie gesagt, eine 80 GB Platte Solo und 2x1 TB als Raid-1-Verbund) mit jeweils VMFS5 als FS.

Ich wollte gerade Anhänge (Bilder) hinzufügen. Leider sagt mir die Forumssoftware 'Attachment kann nicht hinzugefügt werden, da die maximale Anzahl von 0 Attachments in dieser Nachricht erreicht wurde'?!?

Naja, dann halt mit Erklärungen:
Datenspeicher:
2x virtuelle HDD mit Typ: VMFS5
Hardwarebeschleunigung: Unbekannt
Geräte:
3x HDD
Betriebszustand: gemountet (3x)
LUN: 0 (3x)
Transport: Blockadapter (3x)
Besitzer: NMP (3x)
Hardwarebeschleunigung: Unbekannt (3x)

In den Gerätedetails:

Systemplatte (80 GB):
Partitionsformat: GPT
Primäre Partitionen: 6 Ubuntu-Parititonen
1-3 Legacy-MBR (4 MB, 250 MB, 250 MB)
VMWare-Diagnose (110 MB)
Legacy-MBR (286 MB)
VMWare Diagnose (2,5 GB)
Transport: Blockadapter

1. Raid-1-Platte (931,51 GB):
Partitionsformat: GPT
Primiäre Partition: 1
1. VMFS (931,51 GB)
Transport: Blockadapter

2. Raid-1-Platte (931,51 GB):
Partitionsformat: Unbekannt
gar keine Partitionen (?!?!?)

Ach ja, und die Festplatte 1 ist auf dem SCSI (0:0) angelegt. Hätte ich da also noch eine weitere Festplatte einbauen sollen?
Eine die nur für den VM-Host abgestellt ist, eine die für meine virtuelle Maschine als Systemplatte dient und dann noch eben die 2x Raid-1 Platten für mein Fileserver?
Oje...

Und bei deinem letzten Post:
ich denke du hast das schon richtig erfasst... auf der 80 GB-HDD ist der VM Host als auch dann noch eine virtuelle Festplatte für den Gast (diese VDMK-DAtei oder wie die heisst).

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 13.08.2015, 08:31

@Dayworker

Nope, kein weiterer RAID-Controller ausser der 'onboard'. Ist bekannt das dieser RAID-Controller schlecht ist. Dennoch darf es ja nicht sein das die IO-Raten so im Keller sind! 3-7 MB/s ist trotzdem nicht nachvollziehbar, oder?

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 13.08.2015, 08:38

@continuum

3x Hardwaregeräte (Spoeicher->Geräte), 2x Datastores (Speicher->Datenspeicher) im Host.
In der Einstellung der virtuellem Maschine sind 2 virtuelle Festplatten hinzugefügt.

Im Linux ist kein RAID gebildet worden, dieser ist im RAID-Controller des DELL T20 gebildet worden. Also ein echter RAID und kein Software-RAID. Jedoch ist der echte RAID in dieser Maschine bzw. diesem Controller auch nur irgendein FAKE bzw. zumindest bekannt schlecht. Dennoch darf es die Leistung nicht so schlimm eingrenzen wie bei mir jetzt der Fall. Und wenn ich Ubuntu Server Core NATIV installiere dann klappt es ja auch. Nur im VM sind die IOs komplett im Eimer....

Jenseits von Gut & Böse
Beiträge: 11513
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 13.08.2015, 09:31

Aehhhh... Achtung!
Ich bin der Meinung das hier 2 Dinge auf einander treffen und aus diesem Grunde herrscht konfusion.

Das Tech Manual zum T20 sagt:

Code: Alles auswählen

Raidcontroller: Intel Rapid Storage Controller software RAID is integrated on the PowerEdge T20 with hardware RAID available with an optional storage controller card.  Visit the Storage controllers section for details.


Siehe dann auch http://accessories.us.dell.com/sna/bran ... &x=14&y=16

Es gibt das Geraet also mit unterschiedlichen Storageloesungen. Allerdings fallen beide in das was umgangssprachlich Fake oder Chipsatz Raid genannt wird.

Ich bilde mir ein das wir es hier auch schon im Forum hatten aber es scheint wohl in der Tat einige Konstellationen zugeben wo der Treiber des ESXi dies unterstuetzt. Dies ist dann aber mehr Zufall als gewollt.

Ich gehe davon aus das ein Linux Kernel mit dem Geraet einfach viel besser umgehen kann als der ESXi Kernel mit seinem Treiber welcher darauf nicht ausgelegt ist.

Üben wie drueben gilt aber das schreiben auf einen HDD welche keinerlei Caches aktiv hat als extrem langsam. Das Problem vergroessert sich wenn der IO mehr "Random" wird wie es bei Virtuellen Umgebungen und deren Konsolidierung die Regel ist.

Mein Vorschlag waere
1. Linux nativ installieren
2. SSD, wobei hier wohl die Kapazitaet das Zuenglein sein wird
3. Hardware RAID mit Cache UND BBU

Gruss
Joerg

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 13.08.2015, 15:27

@irix

Warum ist dann aber meine Systemplatte in der virtuellen Maschine so langsam die nicht im RAID-Verbund ist?

Member
Beiträge: 206
Registriert: 09.09.2010, 14:12

Beitragvon Sven_B1982 » 13.08.2015, 15:54

kaineanung hat geschrieben:@irix

Warum ist dann aber meine Systemplatte in der virtuellen Maschine so langsam die nicht im RAID-Verbund ist?

hängt doch am selben Controller? hat dementsprechend auch die selben Probleme

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 13.08.2015, 16:58

Habe ich das dann richtig verstanden daß VMWares Treiber für den RAID-Controller nicht gut läuft? Hinzu kommt natürlich die bekannten Probleme des RAID-Controllers, die sich aber in einer nativen Installation eben nicht so langsam geben wie unter VM?

Das muss es dann wohl sein denn
Nativ: ich merke keine Geschwindigkeitseinmbußen (ob nun statt 80 MB/s 'nur' 30 MB/s gelesen/geschrieben wird ist mir ja erstmal Wurst. Für meine ZWecke, steamen im Netzwerk reicht das aus)
Virtuell im VM-Ware: gleiche Hardwarekonstellation und die Geschwindigkeiten sind unter 10 MB/s und das merkt man zu deutlich.

Somit gibt es keine Lösung für mein Problem ausser ich verzichte auf eine Spiegelung der Platte (Risiko des DAtenverlustes wegen defekter Platte ist enorm) ODER ich installiere alles nativ auf die Hardware und verzichte dafür auf virtuelle Maschinen welche ich noch vorgehabt hatte hinzuzufügen?

Alternativ: Geld in die Hand nehmen und einen gescheiten Hardwarecontroller kaufen. Wobei es dennoch keien Garantie gibt das es auch wirklich daran lag. Sehe ich das alles richtig? :(

Experte
Beiträge: 1305
Registriert: 30.03.2009, 17:13

Beitragvon UrsDerBär » 14.08.2015, 10:48

Ohne jetzt alles im Detail gelesen zu haben:

3-7MB ist bei lahmen 7200er Magnetplatten bei 4kb Randomzugriff normal wenn Sie ohne ihren Cache arbeiten und das OS auf Rückbestätigung wartet.

--> Konnte ich bei der Verwendung von Windows als Storage-VM unter VmWare feststellen. Speed ist da vor allem von der Latenz abhängig. Erst mit SSD's mit tiefen konstanten Latenzen hatte ich einen guten bzw. sehr guten Speed.

Profi
Beiträge: 991
Registriert: 31.03.2008, 17:26
Wohnort: Einzugsbereich des FC Schalke 04
Kontaktdaten:

Beitragvon kastlr » 14.08.2015, 14:13

Hallo,

was hältst du davon, mal ein paar Daten direkt aus dem ESXi System zu posten?

Lass uns mal den Output von folgenden Befehlen zukommen.
  • esxcli storage core device list
  • esxcli storage core device partition list
  • esxcli storage core adapter list
  • esxcli storage vmfs extent list
  • vim-cmd vmsvc/getallvms                         ---> für den folgenden Befehl benötigst du die vmid, das ist die Zahl am Anfang der Zeile
  • vim-cmd vmsvc/get.filelayout vmid
Damit haben wir alle Informationen bezüglich deiner Plattenkonfiguration und der betroffenen VM.

Wenn du uns dann noch sagst mit welchem Test du arbeitest und nach solch einem Test folgende Logdateien einsammelst sollten wir mehr wissen.
  • /var/log/vmkernel.log
  • /var/log/vmkwarning.log
  • /var/log/vobd.log
Gruß,
Ralf

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 14.08.2015, 23:24

@kastir

Uh, das wird aber ein langer Post...

Hier die storage core device liste:

    t10.ATA_____ST1000DM0032D1CH162__________________________________Z1DCHX5E
    Display Name: Local ATA Disk (t10.ATA_____ST1000DM0032D1CH162__________________________________Z1DCHX5E)
    Has Settable Display Name: true
    Size: 953869
    Device Type: Direct-Access
    Multipath Plugin: NMP
    Devfs Path: /vmfs/devices/disks/t10.ATA_____ST1000DM0032D1CH162__________________________________Z1DCHX5E
    Vendor: ATA
    Model: ST1000DM003-1CH1
    Revision: CC47
    SCSI Level: 5
    Is Pseudo: false
    Status: on
    Is RDM Capable: false
    Is Local: true
    Is Removable: false
    Is SSD: false
    Is VVOL PE: false
    Is Offline: false
    Is Perennially Reserved: false
    Queue Full Sample Size: 0
    Queue Full Threshold: 0
    Thin Provisioning Status: unknown
    Attached Filters:
    VAAI Status: unknown
    Other UIDs: vml.01000000002020202020202020202020205a31444348583545535431303030
    Is Shared Clusterwide: false
    Is Local SAS Device: false
    Is SAS: false
    Is USB: false
    Is Boot USB Device: false
    Is Boot Device: false
    Device Max Queue Depth: 31
    No of outstanding IOs with competing worlds: 32
    Drive Type: unknown
    RAID Level: unknown
    Number of Physical Drives: unknown
    Protection Enabled: false
    PI Activated: false
    PI Type: 0
    PI Protection Mask: NO PROTECTION
    Supported Guard Types: NO GUARD SUPPORT
    DIX Enabled: false
    DIX Guard Type: NO GUARD SUPPORT
    Emulated DIX/DIF Enabled: false

    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________
    Display Name: Local ATA Disk (t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________)
    Has Settable Display Name: true
    Size: 76319
    Device Type: Direct-Access
    Multipath Plugin: NMP
    Devfs Path: /vmfs/devices/disks/t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________
    Vendor: ATA
    Model: Maxtor 6Y080M0
    Revision: YAR5
    SCSI Level: 5
    Is Pseudo: false
    Status: on
    Is RDM Capable: false
    Is Local: true
    Is Removable: false
    Is SSD: false
    Is VVOL PE: false
    Is Offline: false
    Is Perennially Reserved: false
    Queue Full Sample Size: 0
    Queue Full Threshold: 0
    Thin Provisioning Status: unknown
    Attached Filters:
    VAAI Status: unknown
    Other UIDs: vml.01000000005932304b523847432020202020202020202020204d6178746f72
    Is Shared Clusterwide: false
    Is Local SAS Device: false
    Is SAS: false
    Is USB: false
    Is Boot USB Device: false
    Is Boot Device: true
    Device Max Queue Depth: 1
    No of outstanding IOs with competing worlds: 32
    Drive Type: unknown
    RAID Level: unknown
    Number of Physical Drives: unknown
    Protection Enabled: false
    PI Activated: false
    PI Type: 0
    PI Protection Mask: NO PROTECTION
    Supported Guard Types: NO GUARD SUPPORT
    DIX Enabled: false
    DIX Guard Type: NO GUARD SUPPORT
    Emulated DIX/DIF Enabled: false

    t10.ATA_____WDC_WD10EAVS2D00D7B1__________________________WD2DWCAU44078131
    Display Name: Local ATA Disk (t10.ATA_____WDC_WD10EAVS2D00D7B1__________________________WD2DWCAU44078131)
    Has Settable Display Name: true
    Size: 953869
    Device Type: Direct-Access
    Multipath Plugin: NMP
    Devfs Path: /vmfs/devices/disks/t10.ATA_____WDC_WD10EAVS2D00D7B1__________________________WD2DWCAU44078131
    Vendor: ATA
    Model: WDC WD10EAVS-00D
    Revision: 01.0
    SCSI Level: 5
    Is Pseudo: false
    Status: on
    Is RDM Capable: false
    Is Local: true
    Is Removable: false
    Is SSD: false
    Is VVOL PE: false
    Is Offline: false
    Is Perennially Reserved: false
    Queue Full Sample Size: 0
    Queue Full Threshold: 0
    Thin Provisioning Status: unknown
    Attached Filters:
    VAAI Status: unknown
    Other UIDs: vml.0100000000202020202057442d574341553434303738313331574443205744
    Is Shared Clusterwide: false
    Is Local SAS Device: false
    Is SAS: false
    Is USB: false
    Is Boot USB Device: false
    Is Boot Device: false
    Device Max Queue Depth: 31
    No of outstanding IOs with competing worlds: 32
    Drive Type: unknown
    RAID Level: unknown
    Number of Physical Drives: unknown
    Protection Enabled: false
    PI Activated: false
    PI Type: 0
    PI Protection Mask: NO PROTECTION
    Supported Guard Types: NO GUARD SUPPORT
    DIX Enabled: false
    DIX Guard Type: NO GUARD SUPPORT
    Emulated DIX/DIF Enabled: false

Dann hier der storage core device partition:

    Device Partition Start Sector End Sector Type Size
    -------------------------------------------------------------------------- --------- ------------ ---------- ---- -------------
    t10.ATA_____ST1000DM0032D1CH162__________________________________Z1DCHX5E 0 0 1953525168 0 1000204886016
    t10.ATA_____ST1000DM0032D1CH162__________________________________Z1DCHX5E 1 2048 1953523712 fb 1000203091968
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 0 0 156301488 0 80026361856
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 1 64 8192 0 4161536
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 2 7086080 15472640 6 4293918720
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 3 15472640 156301455 fb 72104353280
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 5 8224 520192 6 262127616
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 6 520224 1032192 6 262127616
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 7 1032224 1257472 fc 115326976
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 8 1257504 1843200 6 299876352
    t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 9 1843200 7086080 fc 2684354560
    t10.ATA_____WDC_WD10EAVS2D00D7B1__________________________WD2DWCAU44078131 0 0 1953525168 0 1000204886016

Storage core adapter list:

    HBA Name Driver Link State UID Capabilities Description
    -------- ------ ---------- ------------ ------------ ----------------------------------------------------------------------------------------
    vmhba0 ahci link-n/a sata.vmhba0 (0000:00:1f.2) Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 6 port SATA AHCI Controller
    vmhba32 ahci link-n/a sata.vmhba32 (0000:00:1f.2) Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 6 port SATA AHCI Controller
    vmhba33 ahci link-n/a sata.vmhba33 (0000:00:1f.2) Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 6 port SATA AHCI Controller
    vmhba34 ahci link-n/a sata.vmhba34 (0000:00:1f.2) Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 6 port SATA AHCI Controller
    vmhba35 ahci link-n/a sata.vmhba35 (0000:00:1f.2) Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 6 port SATA AHCI Controller
    vmhba36 ahci link-n/a sata.vmhba36 (0000:00:1f.2) Intel Corporation 82801HR/HO/HH (ICH8R/DO/DH) 6 port SATA AHCI Controller

Storage vmfs extent:
    Volume Name VMFS UUID Extent Number Device Name Partition
    ----------- ----------------------------------- ------------- ------------------------------------------------------------------------- ---------
    Media 5581de01-36c4a690-5b44-3417ebbb91b1 0 t10.ATA_____ST1000DM0032D1CH162__________________________________Z1DCHX5E 1
    datastore1 5580869c-bee6e2c8-6e45-3417ebbb91b1 0 t10.ATA_____Maxtor_6Y080M0__________________________Y20KR8GC____________ 3

vim-cmd vmsvc/get.filelayout 1 (1 ist die vmid der Betreffenden VM):
    (vim.vm.FileInfo) {
    vmPathName = "[datastore1] srv-master0/srv-master0.vmx",
    snapshotDirectory = "[datastore1] srv-master0",
    suspendDirectory = "[datastore1] srv-master0",
    logDirectory = "[datastore1] srv-master0",
    ftMetadataDirectory = <unset>
    }
    (vim.vm.FileLayout) {
    configFile = (string) [
    "srv-master0.nvram",
    "srv-master0.vmsd"
    ],
    logFile = (string) [
    "vmware-9.log",
    "vmware-8.log",
    "vmware.log",
    "vmware-13.log",
    "vmware-12.log",
    "vmware-11.log",
    "vmware-10.log"
    ],
    disk = (vim.vm.FileLayout.DiskLayout) [
    (vim.vm.FileLayout.DiskLayout) {
    key = 2000,
    diskFile = (string) [
    "[datastore1] srv-master0/srv-master0.vmdk",
    "[datastore1] srv-master0/srv-master0-000001.vmdk"
    ]
    },
    (vim.vm.FileLayout.DiskLayout) {
    key = 2001,
    diskFile = (string) [
    "[Media] srv-master0/srv-master0_1.vmdk"
    ]
    }
    ],
    snapshot = (vim.vm.FileLayout.SnapshotLayout) [
    (vim.vm.FileLayout.SnapshotLayout) {
    key = 'vim.vm.Snapshot:1-snapshot-3',
    snapshotFile = (string) [
    "[datastore1] srv-master0/srv-master0-Snapshot3.vmsn",
    "[datastore1] srv-master0/srv-master0.vmdk",
    "[Media] srv-master0/srv-master0_1.vmdk"
    ]
    }
    ],
    swapFile = "[datastore1] srv-master0/srv-master0-52b37f7e.vswp"
    }


Zu den Log-Dateien:
Wenn du mir sagst wie ich die LOG-Dateien per Putty transferieren kann dann mach ich das gerne.
Ach ja, auch wie ich die LOG-Dateien zuerst leeren kann wäre hilfreich....
Bei den oberen Dingen habe ich das so gemacht das ich die Befehle per Putty auf dem VM-Host ausgeführt habe und das komplette dann in die Zwischenablage kopiert habe und dann hier gepostet hab. Das kann ich mit den Inhalten der Logdatei nicht machen...

Und ich habe die Lese-/Schreibgeschwindigkeit getestet indem ich folgendes gemacht habe (buntu-wiki: Festplattengeschwindigkeit testen. 2. Abschnitt -> dd):
https://wiki.ubuntuusers.de/Festplatten ... gkeitstest

Jenseits von Gut & Böse
Beiträge: 11513
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 15.08.2015, 00:16

Die 80GB Platte zeigt "Device Max Queue Depth: 1 " und ich glaube das dies extrem wenig ist.

Gruss
Joerg

Member
Beiträge: 31
Registriert: 10.08.2015, 23:02

Beitragvon kaineanung » 15.08.2015, 10:38

@irix

Ich habe jetzt ein wenig gegoogelt wie ich diesen Wert ändern kann.
Ich habe auch tatsächlich ein Befehl gefunden welcher mir jedoch ein wenig unlogisch erscheint.

Code: Alles auswählen

esxcli --server=Servername system module parameters set -m iscsi_vmk -p iscsivmk_LunQDepth=Wert


Aber ich soll doch für diese eine HDD diesen Wert ändern und dies macht dieser Befehl ja nicht weil ich nirgends angeben kann welche HDD es betrifft.
Würdest du mir geschwind weiterhelfen und erklären wie ich diesen Wert speziell für diese HDD ändern kann?
vSphere wäre cool, esxcli wäre aber auch ok....
Danke schon mal im Voraus bzw. auch schon für das bisherige ;)

Experte
Beiträge: 1319
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 15.08.2015, 11:52

unabhängig von allem anderen, die Maxtor 6Y080M0 DiamondMax Plus 9 ist 10! Jahre alt!
Max 60MB/'s Transferrate! Nur SATA1!
http://www.tomshardware.com/reviews/round,1132-35.html

und auch die WDC_WD10EAVS2 gibt es schon seit 2009, also wohl auch nicht mehr der Performance Tiger.
Wozu hier auch immer mit Truecrypt verschlüsselt wird erschließt sich mir nicht.

Die gegen eine aktuelle SSD getauscht würde schon einiges bringen!
http://www.idealo.de/preisvergleich/Off ... b-ocz.html
Die ist auch dagut, wo beim ESXi kein Trim "durch" geht.


Zurück zu „vSphere 6.0“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast