Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Zeit in einem W2K-Gast

Hilfe bei Problemen mit der Installation oder Benutzung des VMware GSX Server und VMware Server 1.

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 115
Registriert: 04.07.2005, 11:16

Zeit in einem W2K-Gast

Beitragvon Kevin26 » 12.01.2010, 16:57

Moin,

ich habe hier VMWare_Server 1.06 auf einem SLES 10 am laufen.
Eine W2K-Maschine drauf macht mir Probleme: Die Uhr läuft viel zu langsam.

Ich habe jetzt schon einiges durch, momentan lasse ich die Clock über die VMWare-tools jede Sekunde syncen, wird aber auch nicht besser.

Mit welchen Parametern habt ihr eine W2K-Maschine ans laufen bekommen?

Hier mal die vmx der Maschine:

Code: Alles auswählen

#!/usr/bin/vmware
config.version = "8"
virtualHW.version = "4"
memsize = "3600"
MemAllowAutoScaleDown = "FALSE"
MemTrimRate = "-1"
displayName = "b-win"
guestOS = "win2000advserv"
numvcpus = "2"
uuid.location = "56 4d 7c 1e 35 3e 47 74-04 85 93 a7 bf ad 34 95"
uuid.bios = "56 4d 7c 1e 35 3e 47 74-04 85 93 a7 bf ad 34 95"
tools.remindInstall = "FALSE"
floppy0.present = "TRUE"
floppy0.fileName = "/dev/fd0"
sound.present = "FALSE"
sound.virtualDev = "sb16"
sound.filename = "-1"
sound.autodetect = "TRUE"
usb.present = "TRUE"
ethernet0.present = "TRUE"
ethernet0.addressType = "generated"
ethernet0.connectionType = "custom"
ethernet0.startConnected = "TRUE"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "b-win.vmdk"
ide0:0.present = "TRUE"
ide0:0.autodetect = "TRUE"
ide0:0.filename = "auto detect"
ide0:0.deviceType = "atapi-cdrom"
ide0:1.present = "FALSE"
ide0:1.autodetect = "TRUE"
ide0:1.filename = "b-win2.vmdk"
ide0:1.deviceType = "disk"
scsi0.present = "TRUE"
scsi0.virtualDev = "buslogic"

scsi0:0.redo = ""
ide0:1.startConnected = "FALSE"
ethernet0.generatedAddress = "00:0c:29:ad:34:95"
sound.device = "-1"
uuid.action = "create"
ethernet0.generatedAddressOffset = "0"
sound.startConnected = "FALSE"

sound.deviceNr = "-1"
extendedConfigFile = "b-win.vmxf"

ide0:0.startConnected = "TRUE"
autostart = "poweron"
autostop = "softpoweroff"
floppy0.startConnected = "FALSE"
#tools.syncTime = "TRUE"

priority.grabbed = "normal"
priority.ungrabbed = "normal"

Ethernet1.present = "TRUE"

ethernet1.addressType = "generated"
ethernet1.generatedAddress = "00:0c:29:ad:34:9f"
ethernet1.generatedAddressOffset = "10"

#monitor.idleLoopSpinUS = "500"

#monitor.idleLoopDynamic = "FALSE"
#
# Tuning
#
prefvmx.minVmMemPct = "100"

checkpoint.vmState = ""

Ethernet0.vnet = "/dev/vmnet0"
Ethernet1.connectionType = "custom"
Ethernet1.vnet = "/dev/vmnet2"

workingDir = "."

snapshot.disabled = "TRUE"

ide0:1.redo = ""

ide1:0.present = "TRUE"
ide1:0.fileName = "wsus.vmdk"
ide1:0.redo = ""

tools.syncTime = "TRUE"
tools.syncTime.period = "1"
timeTracker.periodicStats = "TRUE"
timeTracker.statInterval = "5"


Gruß

Kevin

Benutzeravatar
Moderator
Beiträge: 14690
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 12.01.2010, 17:43

was machen denn deine anderen Gaeste ?

poste mal ein komplettes vmware.log dieses gasts bei ifile.it

King of the Hill
Beiträge: 12340
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 12.01.2010, 22:20

Die Timing-Probleme gab es meines Wissens schon immer bei Suse, hatten mich bei 9.3 fast wahnsinnig gemacht und ein Umstieg auf Windows löste alle meine Probleme. Bei mir läuft eine Suse10.2_64bit-VM mit SMP-Kernel 2.6.18.2-34-default ohne Zeitverluste, allerdings steht im Warn-Log (/var/log/warn) immer was von:
kernel: warning: many lost ticks.
kernel: Your time source seems to be instable or some driver is hogging interupts
kernel: rip__do_softirg+0x53/0xd5
Ist aber auch kein Wunder, wenn man mit Workunits von http://www.primegrid.com unter Volldampf auf beiden Kernen gesetzt wird. Die VMware-Tools sind installiert und der Zeitabgleich mit dem Host ist auch eingeschaltet.

Wenn bei dir allerdings der Host schon extreme Zeitschwankungen hat, setzt sich das natürlich auch im Gast fort. Wie ich grad bei VMware gesehen habe, sind in der KB unter Timekeeping best practices for Linux guests (1006427) einige Einstellungen zusammengetragen, die natürlich auch auf dem Host helfen.

Member
Beiträge: 115
Registriert: 04.07.2005, 11:16

Beitragvon Kevin26 » 14.01.2010, 11:12

Ist jetzt seit einiger Zeit einigermaßen Synchron,
aber wenn ich mir den Sekundenzeiger im W2k anschaue, bleibt er ab und zu für mehrere Sekunden hängen, und springt dann. Denke mal, das kommt von den VMware-Folls die da halt dann die neue Zeit setzen.

Aber ist es nicht hinzukriegen das die Uhren wirklich synchron laufen?

Gruß

Kevin

Member
Beiträge: 115
Registriert: 04.07.2005, 11:16

Beitragvon Kevin26 » 14.01.2010, 11:14

@ Dayworker: In deinem Link gehts um Linux-Guests, die tun bei mir ja. Nur der eine Windows-Rechner will nicht....

Gruß

Kevin

King of the Hill
Beiträge: 12340
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 14.01.2010, 13:00

Jep ich weiß, aber du hast einen Linux-Host und wenn du dort diese Schwankungen ("einigermaßen synchron") verhinderst...

Member
Beiträge: 115
Registriert: 04.07.2005, 11:16

Beitragvon Kevin26 » 14.01.2010, 15:12

Das "einigermaßen Synchron" bezog sich auf den W2k-Guest.

DIe Linux-Uhr passt, wird ständig durch nen NTP auf em laufenden gehalten.

Gruß

Kevin

King of the Hill
Beiträge: 12340
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 14.01.2010, 15:41

Naja. Wenn die Linux-Uhr ständig per NTP angepaßt werden muß, ist das ja wohl keine richtige Lösung und ich würde da für Abhilfe über den VMware-Link schaffen.
Ansonsten bleibt dir noch, die Zeit-Sync mit dem Host abzustellen und den Gast per NTP zu syncen. Allerdings wird die VM-Grafik letztendlich auch vom Host angesteuert, die Maus wird also vermutlich trotzdem hin-und-wieder hängenbleiben...


Zurück zu „VMserver 1 und GSX“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast