Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

VMware Server 1.0.7 Ubuntu 8.04.1 LTS Probleme

Hilfe bei Problemen mit der Installation oder Benutzung des VMware GSX Server und VMware Server 1.

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 8
Registriert: 28.09.2008, 13:08

VMware Server 1.0.7 Ubuntu 8.04.1 LTS Probleme

Beitragvon KevinsComputer » 30.11.2009, 17:17

Hallo.

Folgendes Problem.

Nachdem mir der root abgeraucht war (kein Neustart möglich) , musste ich Ubuntu neu installieren. Seitdem will VMware einfach nicht mehr funktionieren.

Ich habe hier mal den kompletten Installationsvorgang protokolliert.

Ich hoffe ihr könnt mir weiterhelfen bin echt am verzweifeln mit dem *PIEP*.

Bevor die Frage aufkommt wieso gerade diese Version.
Ich hab mit ihr vor dem Crash gute Erfahrungen gemacht. (PS: Die neue will auch nicht also egal oder ?)

Code: Alles auswählen

kevinsboard@ks358354:~$ cd Desktop/vmware-server-distrib
kevinsboard@ks358354:~/Desktop/vmware-server-distrib$ sudo ./vmware-install.pl
Creating a new installer database using the tar3 format.

Installing the content of the package.

In which directory do you want to install the binary files?
[/usr/bin]

What is the directory that contains the init directories (rc0.d/ to rc6.d/)?
[/etc]

What is the directory that contains the init scripts?
[/etc/init.d]

In which directory do you want to install the daemon files?
[/usr/sbin]

In which directory do you want to install the library files?
[/usr/lib/vmware]

In which directory do you want to install the manual files?
[/usr/share/man]

In which directory do you want to install the documentation files?
[/usr/share/doc/vmware]

The installation of VMware Server 1.0.7 build-108231 for Linux completed
successfully. You can decide to remove this software from your system at any
time by invoking the following command: "/usr/bin/vmware-uninstall.pl".

Before running VMware Server for the first time, you need to configure it by
invoking the following command: "/usr/bin/vmware-config.pl". Do you want this
program to invoke the command for you now? [yes]

Making sure services for VMware Server are stopped.

Stopping VMware services:
   Virtual machine monitor                                             done

You must read and accept the End User License Agreement to continue.
Press enter to display it.

Do you accept? (yes/no) yes

Thank you.

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the mime type icons?
[/usr/share/icons]

What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

/usr/share/applications/vmware-server.desktop: warning: value "vmware-server.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
/usr/share/applications/vmware-console-uri-handler.desktop: warning: value "vmware-server.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel.  Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.23.16/build/include]

Building the vmmon module.

Using 2.6.x kernel build system.
make: Gehe in Verzeichnis '/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.23.16/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Betrete Verzeichnis '/usr/src/linux-2.6.23.16'
  CC [M]  /tmp/vmware-config0/vmmon-only/linux/driver.o
  CC [M]  /tmp/vmware-config0/vmmon-only/linux/hostif.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/cpuid.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/hash.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/memtrack.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/phystrack.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/task.o
  CC [M]  /tmp/vmware-config0/vmmon-only/common/vmx86.o
  CC [M]  /tmp/vmware-config0/vmmon-only/vmcore/moduleloop.o
  LD [M]  /tmp/vmware-config0/vmmon-only/vmmon.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /tmp/vmware-config0/vmmon-only/vmmon.mod.o
  LD [M]  /tmp/vmware-config0/vmmon-only/vmmon.ko
make[1]: Verlasse Verzeichnis '/usr/src/linux-2.6.23.16'
cp -f vmmon.ko ./../vmmon.o
make: Verlasse Verzeichnis '/tmp/vmware-config0/vmmon-only'
The module loads perfectly in the running kernel.

Do you want networking for your virtual machines? (yes/no/help) [yes]

Configuring a bridged network for vmnet0.

Your computer has multiple ethernet network interfaces available: dummy0, eth0.
Which one do you want to bridge to vmnet0? [eth0] dummy0

The following bridged networks have been defined:

. vmnet0 is bridged to dummy0

Do you wish to configure another bridged network? (yes/no) [no]

Do you want to be able to use NAT networking in your virtual machines? (yes/no)
[yes] yes

Configuring a NAT network for vmnet8.

Do you want this program to probe for an unused private subnet? (yes/no/help)
[yes] yes

Probing for an unused private subnet (this can take some time)...

The subnet 172.16.34.0/255.255.255.0 appears to be unused.

The following NAT networks have been defined:

. vmnet8 is a NAT network on private subnet 172.16.34.0.

Do you wish to configure another NAT network? (yes/no) [no]

Do you want to be able to use host-only networking in your virtual machines?
[yes]

Configuring a host-only network for vmnet1.

Do you want this program to probe for an unused private subnet? (yes/no/help)
[yes]

Probing for an unused private subnet (this can take some time)...

The subnet 172.16.189.0/255.255.255.0 appears to be unused.

The following host-only networks have been defined:

. vmnet1 is a host-only network on private subnet 172.16.189.0.

Do you wish to configure another host-only network? (yes/no) [no]

Extracting the sources of the vmnet module.

Building the vmnet module.

Using 2.6.x kernel build system.
make: Gehe in Verzeichnis '/tmp/vmware-config0/vmnet-only'
make -C /lib/modules/2.6.23.16/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Betrete Verzeichnis '/usr/src/linux-2.6.23.16'
  CC [M]  /tmp/vmware-config0/vmnet-only/driver.o
  CC [M]  /tmp/vmware-config0/vmnet-only/hub.o
  CC [M]  /tmp/vmware-config0/vmnet-only/userif.o
  CC [M]  /tmp/vmware-config0/vmnet-only/netif.o
  CC [M]  /tmp/vmware-config0/vmnet-only/bridge.o
  CC [M]  /tmp/vmware-config0/vmnet-only/procfs.o
  CC [M]  /tmp/vmware-config0/vmnet-only/smac_compat.o
  SHIPPED /tmp/vmware-config0/vmnet-only/smac_linux.x386.o
  LD [M]  /tmp/vmware-config0/vmnet-only/vmnet.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /tmp/vmware-config0/vmnet-only/vmnet.mod.o
  LD [M]  /tmp/vmware-config0/vmnet-only/vmnet.ko
make[1]: Verlasse Verzeichnis '/usr/src/linux-2.6.23.16'
cp -f vmnet.ko ./../vmnet.o
make: Verlasse Verzeichnis '/tmp/vmware-config0/vmnet-only'
The module loads perfectly in the running kernel.

Please specify a port for remote console connections to use [902]

 * Stopping internet superserver xinetd                                  [ OK ]
 * Starting internet superserver xinetd                                  [ OK ]
Configuring the VMware VmPerl Scripting API.

Building the VMware VmPerl Scripting API.

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

Installing the VMware VmPerl Scripting API.

The installation of the VMware VmPerl Scripting API succeeded.

Do you want this program to set up permissions for your registered virtual
machines?  This will be done by setting new permissions on all files found in
the "/etc/vmware/vm-list" file. [no]

Generating SSL Server Certificate

In which directory do you want to keep your virtual machine files?
[/var/lib/vmware/Virtual Machines]

Please enter your 20-character serial number.

Type XXXXX-XXXXX-XXXXX-XXXXX or 'Enter' to cancel: XXXXX-XXXXX-XXXXX-XXXXX

Starting VMware services:
   Virtual machine monitor                                            failed
   Virtual ethernet                                                   failed
   Bridged networking on /dev/vmnet0                                   done
   Host-only networking on /dev/vmnet1 (background)                    done
   Host-only networking on /dev/vmnet8 (background)                    done
   NAT service on /dev/vmnet8                                          done

The configuration of VMware Server 1.0.7 build-108231 for Linux for this
running kernel completed successfully.

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 01.12.2009, 08:17

Making sure services for VMware Server are stopped.

Stopping VMware services:
Virtual machine monitor done
Die Einträge für den VMserver waren wohl noch im System vorhanden. Deshalb kommt auch die folgende Mitteilung:
/usr/share/applications/vmware-server.desktop: warning: value "vmware-server.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
/usr/share/applications/vmware-console-uri-handler.desktop: warning: value "vmware-server.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path

Eine mögliche Lösung des Problems teilt dir der VMserver ja auch mit:
The installation of VMware Server 1.0.7 build-108231 for Linux completed
successfully. You can decide to remove this software from your system at any
time by invoking the following command: "/usr/bin/vmware-uninstall.pl".

Also solltest du erstmal den VMserver1.07 komplett deinstallieren und bei der Gelegenheit auch gleich auf die für dich aktuellste Server-Version 1.10 upgraden, da einige Sicherheitsprobleme beseitigt wurden. Den VMserver2.02 kann ich dir trotz der Version 2 eher nicht empfehlen, nicht nur ich empfinde ihn eher als Downgrade mit inkonsistenter Administrierung und wenn der VMserver1 bei dir problemlos läuft, solltest du solange wie möglich auch dabei bleiben. ;)

Member
Beiträge: 8
Registriert: 28.09.2008, 13:08

Beitragvon KevinsComputer » 01.12.2009, 14:52

Hab ich schon probiert geht nicht....

Member
Beiträge: 8
Registriert: 28.09.2008, 13:08

Beitragvon KevinsComputer » 01.12.2009, 19:28

*push*
Wieso geht der Mist net...

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 01.12.2009, 20:54

*pull*

Hast du den VMware-Download genommen oder etwas Distri-spezifisches? Welche VMserver1-Version hast du probiert zu installieren?
Was hast du schon probiert? Was geht nicht? Woran scheiterts? Wo ist die Fehlermeldung dazu?

Member
Beiträge: 8
Registriert: 28.09.2008, 13:08

Beitragvon KevinsComputer » 01.12.2009, 21:12

Ich hab von der VMware Webseite die 1.0.10 er als .tar.gz gedownloadet.
Die Fehlermeldung ist wie gesagt die obige.

Wenn ich via VMware Console Connecte (was funktioniert) und versuche dann einen Guest zu starten erhalte ich die Meldung das VMware für diesen Kernel nicht korrekt konfiguriert sei.

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 01.12.2009, 21:31

Haut da vielleicht noch SELinux oder Appamor dazwischen und verhindert die Ausführung?
Funktioniert es nach dem erneuten Aufruf des Config-Scriptes?

Member
Beiträge: 8
Registriert: 28.09.2008, 13:08

Beitragvon KevinsComputer » 01.12.2009, 23:00

Von SELinux und Apparmor hab ich noch nie gehört.

Wenn ich das ganze starte bekomme ich wieder genau die selbe Ausgabe:

Starting VMware services:
Virtual machine monitor failed
Virtual ethernet failed
Bridged networking on /dev/vmnet0 done
Host-only networking on /dev/vmnet1 (background) done
Host-only networking on /dev/vmnet8 (background) done
NAT service on /dev/vmnet8 done

The configuration of VMware Server 1.0.10 build-203137 for Linux for this
running kernel completed successfully.

Member
Beiträge: 8
Registriert: 28.09.2008, 13:08

Beitragvon KevinsComputer » 02.12.2009, 22:42

Hab mal nen anderen Kernel (niedrigere Version) genommen) und siehe da es funkt.

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 03.12.2009, 07:58

Hmm. Jetzt wo ich darüber nachdenke, wird mir das auch klar. Die VMserver-Versionen unterstützen nur die zum Release bereits länger verfügbaren, getesteten Betriebssysteme und ein neues VMserver-Build beseitigt nur Fehler, neue Host- oder Gast-Betriebssysteme wurden nur im Einzelfall nachgepflegt. Der VMserver1 ist ja schon etwas älter, demzufolge ist er nur mit ältere Kernel-Versionen vollständig kompatibel oder er braucht vielleicht auch nur etwas Nachhilfe über die Any-Any-Patches.

Welche Kernel-Version hast du denn jetzt im Einsatz?

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 05.12.2009, 14:35

Ich hab die Suchworte "ubuntu 9.04 vmware server 2" in Google probiert. Einzig https://help.ubuntu.com/community/VMware/Server und http://www.insecure.ws/2009/12/04/vmwar ... nel-2-6-32 scheinen wirklich funktional zu sein. Ich habe aber keine Ahnung wo das eigentliche Problem mit dem VMware-Installer liegt. Es scheint aber meist eine Mischung aus fehlenden Libs und falschen Verlinkungen zu sein. Ein Wort noch zur Ubuntu-Community, der dort verlinkte Patch läßt sich wohl leider nur runterladen, wenn man angemeldet ist.

Für 2.6.27-x.y.z und Server1.09 mit Ubuntu-9.04 findet sich unter http://stefan.waidele.info/2009/05/25/v ... jackalope/ passendes.


Zurück zu „VMserver 1 und GSX“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast