Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Hohe Co-Stop Werte ohne Anlass

Moderatoren: Dayworker, continuum, Tschoergez, irix

Experte
Beiträge: 1956
Registriert: 23.02.2012, 12:26

Hohe Co-Stop Werte ohne Anlass

Beitragvon ~thc » 02.12.2016, 10:05

Moin.

Ich beobachte auf einem Free-ESXi mit zwei physischen CPUs (Hardware komplett auf der HCL) ein merkwürdiges Phänomen. Nachdem zu zwei Server-VMs mit jeweils zwei vCPUs ein dritter dazu kam, zeigte der Neuzugang manchmal eine stark verzögerte Antwortzeit. Der Anmeldevorgang oder der Start von Applikationen (per RDP) waren zum Teil grotesk langsam. Die "alten" Server zeigten keine Auffälligkeiten.

Hier das Chart für die betroffene Server-VM:
VM.PNG

Ihr seht drei Anmeldevorgänge (19:28 Uhr, 19:40 Uhr und 20:15 Uhr) mit Applikations-Starts. Die CPU-Last beträgt nur wenige Hundert MHz. Die erste Anmeldung war sehr schleppend, die beiden folgenden nicht.

Hier das Chart für den ESXi (blau: Last, rot: Ready, gelb: Co-Stop):
ESX.PNG

Während die Last und der Ready-Wert niedrig sind, erreicht Co-Stop über 6000 Millisekunden! Ab 20:00 Uhr findet eine Datensicherung (auf den beiden anderen VMs) statt, die die Grundlast signifikant erhöht. Trotzdem ist der Co-Stop vergleichsweise niedrig.

Die beiden Xeons (E5630 mit Hyperthreading) haben jeweils 4 pCores. Die drei VMs je 2 vCPUs.

Es sieht für mich so aus, als ob der Scheduler von ESXi manchmal versucht, die 6 vCPUs auf einem Sockel unterzubringen und dann ewig lange warten muss, bis auf diesem mal 2 pCores zusammen frei werden.

King of the Hill
Beiträge: 12359
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: Hohe Co-Stop Werte ohne Anlass

Beitragvon Dayworker » 03.12.2016, 14:12

Ob es damit zusammenhängt, kann ich nicht sagen, aber in welchem Energiezustand laufen HW und ESXi?

Experte
Beiträge: 1956
Registriert: 23.02.2012, 12:26

Re: Hohe Co-Stop Werte ohne Anlass

Beitragvon ~thc » 08.12.2016, 15:12

Über den Energiezustand der Hardware (es ist ein Intel Server) kann ich keine Aussagen machen.

Auf der Ebene des ESXi tritt es sowohl im "High Performance"- als auch "Balanced"-Modus auf.

Ich habe auf einem anderen 5.0er zum Testen mal einen 2012 R2 mit 2 vCPUs installiert. Das Ergebnis war eine Katastrophe. Den Stamm-VMs (unter anderem auch zwei Windows 8.1 VMs mit einer vCPU) auf dem Host wurde zeitweilig die Luft abgedreht und die Co-Stop-Werte gingen durch die Decke.

Die "Lösung" ist für mich, bis auf weiteres 2012 R2 Server VMs nur eine vCPU zu geben. Dann läuft alles ruhig und unauffällig.

Experte
Beiträge: 1956
Registriert: 23.02.2012, 12:26

Re: Hohe Co-Stop Werte ohne Anlass

Beitragvon ~thc » 08.12.2016, 18:05

~thc hat geschrieben:Über den Energiezustand der Hardware (es ist ein Intel Server) kann ich keine Aussagen machen.

Auf der Ebene des ESXi tritt es sowohl im "High Performance"- als auch "Balanced"-Modus auf.

Ich habe auf einem anderen 5.0er zum Testen mal einen 2012 R2 mit 2 vCPUs installiert. Das Ergebnis war eine Katastrophe. Den Stamm-VMs (unter anderem auch zwei Windows 8.1 VMs mit einer vCPU) auf dem Host wurde zeitweilig die Luft abgedreht und die Co-Stop-Werte gingen durch die Decke.

Die "Lösung" ist für mich, bis auf weiteres 2012 R2 Server VMs nur eine vCPU zu geben. Dann läuft alles ruhig und unauffällig.


EDIT: Auf den ESXi laufen 2K8 R2 Server mit 2 vCPUs ohne Probleme.

Experte
Beiträge: 1956
Registriert: 23.02.2012, 12:26

Re: Hohe Co-Stop Werte ohne Anlass

Beitragvon ~thc » 11.04.2017, 09:28

Ursache war das Einlesen des vRAMs aus der ESXi-Memory-Swap-Datei der VM (Memory Overcommitment).


Zurück zu „vSphere 5.5 / ESXi 5.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste