Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Neues Speicherleck in VMware-Tools?

Moderatoren: Dayworker, continuum, Tschoergez, irix

King of the Hill
Beiträge: 12355
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Neues Speicherleck in VMware-Tools?

Beitragvon Dayworker » 15.11.2015, 21:12

Ich habe da in einem übriggebliebenen Win2k3-R2 ein mit zunehmender Laufzeit immer grösser werdendes Problem mit dem Userland-Process "vmtoolsd" unter anderem in der Tools-Version 9.4.10.37835 meines 5.5u2. Dieser äussert sich darin, daß seit dem Start fortlaufend immer mehr vRAM in Beschlag genommen wird. Merkwürdig ist jedoch, daß dieses Problem bei einem uralten, aus Sentimentalitätsgründen noch laufenden Win2k mit derselben Tools-Version nicht auftritt.

Zum Testen habe ich die Tools sowohl aus der "latest" in Version 8.6.16 (3054402) als auch von 6.0u1 mit Version 9.10.5 (2981885) ausprobiert. Beide ändern jedoch nichts am Problem. Pro Stunde VM-Laufzeit verschlimmert sich die Belegung um ~ 20MB bis der vRAM erschöpft ist und die VM dann irgendwann anfängt ihren virtuellen Arbeitsspeicher vollzumüllen.

Win2k ist dabei noch mit der vHW-Version 4 und Win2k3-R2 mit der 7 unterwegs. Da ein Downgrade auf die 4 jedoch nichts brachte, erwarte ich auch keine Verbesserung beim Upgrade auf eine höhere vHW-Version. Beide VMs sollen nach Möglichkeit in genau der momentanen vHW-Version verbleiben, in der sie konvertiert oder aufgesetzt wurden.

Interessant unter Win2k ist die Anwendungsbelegung für beide "vmtoolsd"-Prozesse. Während der Dienst mit 8,960KB auskommt, sind es im Userland nur 8,192KB und das ganze auch stabil seit August 2015. Unter Win2k3-R2 sieht es etwas anders aus. Als Dienst werden dort 12,768KB und als Userland nach knapp 20min Laufzeit bereits 13,920KB ansteigend belegt.

King of the Hill
Beiträge: 12355
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 15.11.2015, 21:29

Wie erwartet bringt ein testweises Upgrade auf die vHW-Version 10 auch nichts.

Member
Beiträge: 44
Registriert: 05.12.2006, 07:43
Wohnort: Saarland

Beitragvon rziwin » 16.11.2015, 11:17

Aktuelle VMware Tools sind:

- ESXi 5.5 Update 3 => Version 9.4.15 - Build 2827462
- ESXi 6.0 Update 1 => Version 9.10.5 - Build 2981885

Seit September gibt es darüber hinaus auch die VMware Tools 10.0.0. Diese sind kompatibel zu ESXi 5.0 und höher.


Leider sind die VMware Tools 10 buggy. Bei einigen VMs stürzen die VMware Tools während der Erstellung von Snapshots ab. Betroffen sind Windows 2008 R2, 2012 und 2012 R2. Nach Deinstallation und Installation einer alten 9.x Version funktioniert es wieder. Leider sind dafür zwei Reboot und eine Neukonfiguration der vmxnet3 erforderlich => einfach mal so wie das Update geht das nicht.

Experte
Beiträge: 1319
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 16.11.2015, 12:06

Also meine W2k03R2 VM hat genau für die Tools genau die Version 9.4.15 - Build 2827462. Und solche Probleme konnte ich nicht feststellen.
EDIT : Wobei ich dir nicht ganz folgen kann wo du die Werte her hast.
damit meine ich Daywalker

Member
Beiträge: 44
Registriert: 05.12.2006, 07:43
Wohnort: Saarland

Beitragvon rziwin » 16.11.2015, 12:15

Supi hat geschrieben:Wobei ich dir nicht ganz folgen kann wo du die Werte her hast.


Direkt von VMware - siehe die hinterlegten Links bei Klick auf die Versionsangabe.

Member
Beiträge: 206
Registriert: 09.09.2010, 14:12

Beitragvon Sven_B1982 » 16.11.2015, 13:04

ich hab leider keinen 2k3 R2 im einsatz sondern nur die normale 2k3 Versionen, kann das da aber nicht feststellen. Bei mir haben die vmtoolsd.exe zwischen 8400kb bis 12468kb und das teilweise seit mehreren Monaten, bei unseren 2k8 R2s sind es teilweise sogar nur 3244kb beim user bei den 2k12 R2 sogar einer mit 2122KB.

@rziwin ich denke supi meinte Dayworker, die werte kommen aus dem Windows Taskmanger nehm ich mal an, da hab ich sie zumindest her.

King of the Hill
Beiträge: 12355
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.11.2015, 16:49

Jep, alle Speicherwerte stammen vom Taskmanager bzw Sysinternals Process-Explorer.
Momentan fahre ich mit der Tools von "ESXi 6.0 Update 1 => Version 9.10.5 - Build 2981885". Seit gestern Abend 22 Uhr sind dort inzwischen 262,416KB belegt und während ich hier schreibe steigt es noch weiter. Das OS ansich wurde bis zum letzten Tag durchgepatcht.


Zurück zu „vSphere 5.5 / ESXi 5.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast