Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Snapshot nach Stromausfall wiederhergestellt

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 10
Registriert: 27.11.2014, 17:18

Snapshot nach Stromausfall wiederhergestellt

Beitragvon Guy Inkognito » 11.08.2015, 10:29

Hallo zusammen,

ich habe ein Problem, welches sich wohl nicht mehr lösen lässt, aber vielleicht hat ja jemand eine Idee, was passiert sein könnte.
Gegeben ist ein ESXi 5.0.0 Server in einem 5.5er vCenter. Als Gast einen MS Windows 2008 R2 Server, auf dem ein MS SQL 2008 (mit Datenbanken u.a. für Jira und Sharepoint) Server läuft. Gesichert wird diese VM Samstagmorgen um 01:00 Uhr via Backup Exec 2012.
Letzten Sonntag gab es einen Stromausfall im Serverraum, ich habe es zufällig bemerkt und habe alles wieder hochgefahren, die VMs des betreffenden ESXi-Hosts starten automatisch. Gestern Abend erreicht mich dann die Nachricht, dass User Ihre Daten (Jira, Sharepoint) der letzten Woche (03.8.-07-08.)vermissen. Als ich dann im Log des SQL-Servers schaute, bemerkte ich eine Lücke zwischen dem 01.08. 03:24, dem Ende des vorletzen Backups, bis 09.08., als ich den Server wieder gestartet habe. Diese eine Woche ist vollständig verschwunden, als der Server am Sonntag gestartet wurde, wurde offensichtlich der Backup-Snapshot vom 01.08. gestartet. Dieser Snapshot existiert noch, im Backupserver existiert ein Backup-Satz vom 01.08. beides widerspricht sich, denn der Snapshot hätte ja nach einem erfolgreichen Backup gelöscht werden müssen. Ein Backup vom 08.08. existiert nicht, es gibt keine Fehlermeldung des Jobs, was auch noch nie passiert ist.
Die Logs der VM selber weisen auch diese Lücke auf. Ich war in der betreffenden Woche mehrfach auf der betreffenden VM, mir ist nichts ungewöhnliches aufgefallen.
Den Datenverlust von einer Woche muss ich wohl hinnehmen, was mich viel mehr umtreibt ist die Frage: Was ist passiert und was kann ich tun, damit das nie wieder vorkommt? Kann doch nicht angehen, dass sich ein Snapshot "von alleine" zurücksetzt.

viele Grüße,
Christian

Experte
Beiträge: 1443
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 11.08.2015, 10:53

Ich persoenlich wuerde damit anfangen, mir die vmware*.log der VM im Datastore-Verzeichnis der VM zu Gemuete zu fuehren. Davon wird bei jedem Start der VM ein neues begonnen, und darin vermerkt, mit welchen (Konfigurations-)Dateien die VM jeweils gestartet, und im weiteren Verlauf betrieben wird (z.B. wenn Snapshots angelegt werden, und dazu weitere vmdk-Dateien verwendet werden).

Was genau "passiert" ist, bedarf dann der Interpretation. Es wird ganz sicher kein Eintrag existieren a la "Hier habe ich die falsche Datei verwendet".

Ich vermute mal ins Blaue hinein, dass beim Stromausfall ein (seit 1.8.) aktiver Snapshot existierte, der bei diesem Stromausfall kaputtging, und somit die darin enthaltenen Daten verloren sind. Aber das ist, wie erwaehnt, nur eine blasse Vermutung.


Zurück zu „vSphere 5.5 / ESXi 5.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste