Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

USB HD an ESXi 5.5

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

USB HD an ESXi 5.5

Beitragvon zh699 » 23.02.2015, 16:38

Guten Tag Community

Ich habe folgendes Problem.

Ich habe 2 4TB Toshiba USB HD gekauft und die werden einfach nicht vom ESXi Host erkannt. USB Controller ist installiert.

Wenn ich Sie lokal am meinem PC anschliesse und danach über USB Verbinden gehe wird Sie erkannt.

Andere USB Geräte direkt am Host werden auch erkannt

Kann mir jemand helfen :( ?

Jenseits von Gut & Böse
Beiträge: 11465
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 23.02.2015, 16:49

Ich sehe folgende Problematik
- USB 3.0?
- Fehlender 4k bzw. 512e Block Support unter vSphere 5.5

Gruss
Joerg

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 24.02.2015, 09:01

Ja die sind USB 3.0 und möchte die auf eine SBS 2011 mounten

Ich sehe Sie sind 512 Bytes per Sector

Gibt es keine Lösung?

Gruss Chris

Experte
Beiträge: 1301
Registriert: 30.03.2009, 17:13

Beitragvon UrsDerBär » 24.02.2015, 09:52

Eine - einigermassen schnelle - Lösung ohne Gefrickel wäre die VM mit einem USB-to-LAN Converter anzuschliessen. Könntest es erst noch in einem anderen Brandabschnitt platzieren. Nehme an es ist für Backup-Zwecke gedacht.

Silex hat da was ordentliches im Programm. Dedizierte LAN-Verbindung ist vorteilhaft.

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 24.02.2015, 10:49

Du kannst die Platte an einem 2.0er-Anschluß betreiben - sie ist dann aber deutlich langsamer als 2.0.

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 24.02.2015, 10:51

Die Festplatte ist bereits über 2.0 Anschluss verbunden aber wird immer noch nicht erkannt

Gruss Chris

Jenseits von Gut & Böse
Beiträge: 11465
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 24.02.2015, 10:52

USB support in ESXi/ESX 4.1 and ESXi 5.x
http://kb.vmware.com/kb/1022290

Lesen, verstehen und gucken. Es wird auf 5.5u3 verwiesen um USB3.0 Geraete an VMs durchzureichen vom Host aus.

Gruss
Joerg

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 24.02.2015, 13:49

Gemeint ist nicht 5.5u3, sondern "5.5 Patch 3" - der erste Patch nach dem Update02 (ESXi550-201410001).

Jenseits von Gut & Böse
Beiträge: 11465
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 24.02.2015, 13:57

~thc hat geschrieben:Gemeint ist nicht 5.5u3, sondern "5.5 Patch 3" - der erste Patch nach dem Update02 (ESXi550-201410001).


Ah... hatte mich irgendwie auch verwundert weil u2 ja von Ende Oktober/November ist und ab da an noch 18 Patches gekommen sind.

Der obige KB gibt nicht genau an ob das Modul generell von Hand geladen werden muss oder wann es Bedingung ist. Aber es kann ja mal nicht schaden.

Gruss
Joerg

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 24.02.2015, 16:56

-> siehe meinen Beitrag dazu

King of the Hill
Beiträge: 12359
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 24.02.2015, 16:57

~thc hat geschrieben:-> siehe meinen Beitrag dazu
Angepinnt. :D

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 14:29

Danke für die Antworten

Ich kann den Patch nicht installieren

Fehlermeldung (auch mit update oder install)

~ # esxcli software vib install -d /vmfs/volumes/datastore1/ESXi550-201410001.zi
p
Installation Result
Message: Host is not changed.
Reboot Required: false
VIBs Installed:
VIBs Removed:
VIBs Skipped: VMware_bootbank_ata-pata-amd_0.3.10-3vmw.550.0.0.1331820, VMware_bootbank_ata-pata-atiixp_0.4.6-4vmw.550.0.0.1331820, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.550.0.0.1331820, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.550.0.0.1331820, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.550.0.0.1331820, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.550.0.0.1331820, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.550.0.0.1331820, VMware_bootbank_ata-pata-via_0.3.3-2vmw.550.0.0.1331820, VMware_bootbank_block-cciss_3.6.14-10vmw.550.0.0.1331820, VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.0.0.1331820, VMware_bootbank_elxnet_10.0.100.0v-1vmw.550.0.0.1331820, VMware_bootbank_esx-base_5.5.0-2.39.2143827, VMware_bootbank_esx-dvfilter-generic-fastpath_5.5.0-0.0.1331820, VMware_bootbank_esx-tboot_5.5.0-2.33.2068190, VMware_bootbank_esx-xlibs_5.5.0-0.0.1331820, VMware_bootbank_esx-xserver_5.5.0-0.0.1331820, VMware_bootbank_ima-qla4xxx_2.01.31-1vmw.550.0.0.1331820, VMware_bootbank_ipmi-ipmi-devintf_39.1-4vmw.550.0.0.1331820, VMware_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.550.0.0.1331820, VMware_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.550.0.0.1331820, VMware_bootbank_lpfc_10.0.100.1-1vmw.550.0.0.1331820, VMware_bootbank_lsi-mr3_0.255.03.01-2vmw.550.1.16.1746018, VMware_bootbank_lsi-msgpt3_00.255.03.03-1vmw.550.1.15.1623387, VMware_bootbank_misc-cnic-register_1.72.1.v50.1i-1vmw.550.0.0.1331820, VMware_bootbank_misc-drivers_5.5.0-2.39.2143827, VMware_bootbank_mtip32xx-native_3.3.4-1vmw.550.1.15.1623387, VMware_bootbank_net-be2net_4.6.100.0v-1vmw.550.0.0.1331820, VMware_bootbank_net-bnx2_2.2.3d.v55.2-1vmw.550.0.0.1331820, VMware_bootbank_net-bnx2x_1.72.56.v55.2-1vmw.550.0.0.1331820, VMware_bootbank_net-cnic_1.72.52.v55.1-1vmw.550.0.0.1331820, VMware_bootbank_net-e1000_8.0.3.1-3vmw.550.0.0.1331820, VMware_bootbank_net-e1000e_1.1.2-4vmw.550.1.15.1623387, VMware_bootbank_net-enic_1.4.2.15a-1vmw.550.0.0.1331820, VMware_bootbank_net-forcedeth_0.61-2vmw.550.0.0.1331820, VMware_bootbank_net-igb_5.0.5.1.1-1vmw.550.1.15.1623387, VMware_bootbank_net-ixgbe_3.7.13.7.14iov-11vmw.550.0.0.1331820, VMware_bootbank_net-mlx4-core_1.9.7.0-1vmw.550.0.0.1331820, VMware_bootbank_net-mlx4-en_1.9.7.0-1vmw.550.0.0.1331820, VMware_bootbank_net-nx-nic_5.0.621-1vmw.550.0.0.1331820, VMware_bootbank_net-tg3_3.123c.v55.5-1vmw.550.2.33.2068190, VMware_bootbank_net-vmxnet3_1.1.3.0-3vmw.550.2.39.2143827, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.550.0.0.1331820, VMware_bootbank_qlnativefc_1.0.12.0-1vmw.550.0.0.1331820, VMware_bootbank_rste_2.0.2.0088-4vmw.550.1.15.1623387, VMware_bootbank_sata-ahci_3.0-21vmw.550.2.39.2143827, VMware_bootbank_sata-ata-piix_2.12-10vmw.550.2.33.2068190, VMware_bootbank_sata-sata-nv_3.5-4vmw.550.0.0.1331820, VMware_bootbank_sata-sata-promise_2.12-3vmw.550.0.0.1331820, VMware_bootbank_sata-sata-sil24_1.1-1vmw.550.0.0.1331820, VMware_bootbank_sata-sata-sil_2.3-4vmw.550.0.0.1331820, VMware_bootbank_sata-sata-svw_2.3-3vmw.550.0.0.1331820, VMware_bootbank_scsi-aacraid_1.1.5.1-9vmw.550.0.0.1331820, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.550.0.0.1331820, VMware_bootbank_scsi-aic79xx_3.1-5vmw.550.0.0.1331820, VMware_bootbank_scsi-bnx2fc_1.72.53.v55.1-1vmw.550.0.0.1331820, VMware_bootbank_scsi-bnx2i_2.72.11.v55.4-1vmw.550.0.0.1331820, VMware_bootbank_scsi-fnic_1.5.0.4-1vmw.550.0.0.1331820, VMware_bootbank_scsi-hpsa_5.5.0-44vmw.550.0.0.1331820, VMware_bootbank_scsi-ips_7.12.05-4vmw.550.0.0.1331820, VMware_bootbank_scsi-lpfc820_8.2.3.1-129vmw.550.0.0.1331820, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.550.0.0.1331820, VMware_bootbank_scsi-megaraid-sas_5.34-9vmw.550.2.33.2068190, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.550.0.0.1331820, VMware_bootbank_scsi-mpt2sas_14.00.00.00-3vmw.550.1.15.1623387, VMware_bootbank_scsi-mptsas_4.23.01.00-9vmw.550.0.0.1331820, VMware_bootbank_scsi-mptspi_4.23.01.00-9vmw.550.0.0.1331820, VMware_bootbank_scsi-qla2xxx_902.k1.1-9vmw.550.0.0.1331820, VMware_bootbank_scsi-qla4xxx_5.01.03.2-6vmw.550.0.0.1331820, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.550.0.0.1331820, VMware_bootbank_xhci-xhci_1.0-2vmw.550.2.39.2143827, VMware_locker_tools-light_5.5.0-2.39.2143827

Jenseits von Gut & Böse
Beiträge: 11465
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 25.02.2015, 14:43

Welche Version hast du denn? Steht im vSphere Client oben wenn man den Host ausgewaehlt hat oder wenn man schon auf der CMD ist

Code: Alles auswählen

~ # vmware -v
VMware ESXi 5.5.0 build-2456374


Gruss
Joerg

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 14:49

ESXi, 5.5.0, 2143827

Gruss Chris

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 25.02.2015, 14:50

Steht doch unter esx-base in der "Skipped"-Liste: 2143827 (=ESXi550-201410001).

Dann kann das ja nicht gehen. :roll:

Außerdem steht in der "Skipped"-Liste, dass xhci schon installiert ist...

@zh699: Du brauchst nichts zu installieren.

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 14:52

Wie kann es denn sein wenn ich es noch nicht eingespielt habe?

Aber trozdem werden Sie nicht erkannt

Gruss Chris

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 25.02.2015, 14:56

Hast du meinen Artikel gelesen? Hast du das xhci-Kernel-Modul aktiviert? hast du mit "lspci" und "lsusb" geprüft, ob dein Controller und deine Devices erkannt werden?

Jenseits von Gut & Böse
Beiträge: 11465
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 25.02.2015, 14:56

Hast du das Modul geladen?

Gruss
Joerg

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 15:07

Modul ist geladen und folgendes kommt für lspci und lsusb

Toshiba hört sich schon gut an :grin:
~ # lsusb
Bus 01 Device 0a: ID 0480:d011 Toshiba America Info. Systems, Inc.
Bus 01 Device 06: ID 05ac:0250 Apple, Inc. Aluminium Keyboard (ISO)
Bus 01 Device 05: ID 125f:c82a A-DATA Technology Co., Ltd.
Bus 01 Device 03: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 01 Device 02: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 01 Device 01: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 04 Device 01: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 03 Device 01: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 02 Device 02: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 02 Device 01: ID 1d6b:0002 Linux Foundation 2.0 root hub
~ # lspci
0000:00:00.0 Bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller
0000:00:02.0 Display controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller
0000:00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Ch ipset Family MEI Controller #1
0000:00:19.0 Network controller: Intel Corporation 82579V Gigabit Network Connec tion
0000:00:1a.0 Serial bus controller: Intel Corporation 6 Series/C200 Series Chips et Family USB Enhanced Host Controller #2
0000:00:1b.0 Multimedia controller: Intel Corporation 6 Series/C200 Series Chips et Family High Definition Audio Controller
0000:00:1c.0 Bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI E xpress Root Port 1 [PCIe RP[0000:00:1c.0]]
0000:00:1c.1 Bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI E xpress Root Port 2 [PCIe RP[0000:00:1c.1]]
0000:00:1c.3 Bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI E xpress Root Port 4 [PCIe RP[0000:00:1c.3]]
0000:00:1d.0 Serial bus controller: Intel Corporation 6 Series/C200 Series Chips et Family USB Enhanced Host Controller #1
0000:00:1f.0 Bridge: Intel Corporation H67 Express Chipset Family LPC Controller
0000:00:1f.2 Mass storage controller: Intel Corporation Cougar Point 6 port SATA AHCI Controller [vmhba0]
0000:00:1f.3 Serial bus controller: Intel Corporation 6 Series/C200 Series Chips et Family SMBus Controller
0000:01:00.0 Bridge: Integrated Technology Express, Inc.
0000:02:02.0 Network controller: Elsa AG QuickStep 1000
0000:03:00.0 Network controller: Intel Corporation 82574L Gigabit Network Connec tion [vmnic0]
0000:04:00.0 Serial bus controller: NEC Corporation uPD720200 USB 3.0 Host Contr oller
~ #

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 25.02.2015, 15:09

Geht doch. :D

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 15:11

Hab noch vergessen zu sagen, dass die Festplatte trotzdem nicht erkannt werden

Gruss Chris :evil:

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 25.02.2015, 15:13

In der VM? Hast du der VM auch einen xHCI-Controller zugewiesen? Hat das OS der VM nativen xHCI/USB 3.0 Support?

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 15:21

xHCI ist zugewiesen und es steht beim zuweisen vom xHCI Controller: Dieser Controller wird von diesem Gastbetriebssystem nicht unterstützt

Habe aber auch eine WinServer2012 Testmaschine und dort wird die Festplatte auch nicht erkannt

Gruss Chris

Experte
Beiträge: 1955
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 25.02.2015, 15:31

Kannst du der 2012er VM die Platte zuweisen, also sieht der Host sie und kann sie weiterreichen?

Member
Beiträge: 17
Registriert: 23.02.2015, 16:27

Beitragvon zh699 » 25.02.2015, 15:32

Leider nicht.

Brauche es aber sowieso auf der SBS2011


Zurück zu „vSphere 5.5 / ESXi 5.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste