Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

[gelöst]Ping einer VM auf einem Nested ESXi

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 96
Registriert: 16.03.2010, 13:02

[gelöst]Ping einer VM auf einem Nested ESXi

Beitragvon djt83 » 27.05.2014, 13:43

Hallo zusammen

Soeben habe ich die Trial Version vSphere 5.5 runtergeladen.
Die ESXi Server habe ich als VMs installiert. Einen Cluster konnte ich erstellen.
Nun habe ich eine VM installiert. Die VM auf dem nested ESXi bekommt eine IP Adresse.
Jedoch kann ich die VM nicht pingen, und auch aus der VM kann ich das Gateway nicht pingen.

Am dem Swich habe ich Promiscuous Mode auf Accept gestellt.

Muss ich noch andere Einstellungen vornehmen?

Guru
Beiträge: 2615
Registriert: 27.12.2004, 22:17

Re: Ping einer VM auf einem Nested ESXi

Beitragvon rprengel » 27.05.2014, 14:45

djt83 hat geschrieben:Hallo zusammen

Soeben habe ich die Trial Version vSphere 5.5 runtergeladen.
Die ESXi Server habe ich als VMs installiert. Einen Cluster konnte ich erstellen.
Nun habe ich eine VM installiert. Die VM auf dem nested ESXi bekommt eine IP Adresse.
Jedoch kann ich die VM nicht pingen, und auch aus der VM kann ich das Gateway nicht pingen.

Am dem Swich habe ich Promiscuous Mode auf Accept gestellt.

Muss ich noch andere Einstellungen vornehmen?


Alle Systeme im gleichen Netzwerksegment?

Gruss

Jenseits von Gut & Böse
Beiträge: 11465
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 27.05.2014, 14:49

Die VM bezieht eine IP vom DHCP sagst du ? Das sich ein OS >WinXP nicht anpingen laesst liegt an der FW. Wird manchmal in der Hitze des Gefechts vergessen.

Gruss
Joerg

Guru
Beiträge: 2615
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 27.05.2014, 15:28

irix hat geschrieben:Die VM bezieht eine IP vom DHCP sagst du ? Das sich ein OS >WinXP nicht anpingen laesst liegt an der FW. Wird manchmal in der Hitze des Gefechts vergessen.

Gruss
Joerg

Ping raus geht ja auch nicht und der müsste normalerweise gehen.
Gruss

Member
Beiträge: 360
Registriert: 13.07.2011, 15:33

Beitragvon MarcelMertens » 27.05.2014, 15:35

Du mußt auch forged transmits aktivieren.
Denn es geht je eine andere MAC Adresse raus als die des virtuellen ESXi hosts

Member
Beiträge: 96
Registriert: 16.03.2010, 13:02

Beitragvon djt83 » 27.05.2014, 17:08

@ rprengel: Ja alle Server sind im selben Netzwerksegment (so einfach wie möglich zum Testen)

@ irix: Ja die VM bekommt eine IP vom DHCP (Habe mal ein XP und ein Server 2008 R2 installiert, bei beiden habe ich die Firewall deaktiviert = geht immer noch nicht

@ rprengel: unklar geschrieben, sorry. Ping raus aus der VM auf bspw. Gateway geht auch nicht.

@ MarcelMertens: forged transmits habe ich aktiviert, auch kein Erfolg

Ich habe es nun mit einem e1000 und einen Flexible Netzwerkadapter getestet. Es macht kein Unterschied??

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 27.05.2014, 18:57

Läuft der nested ESXi unter ESXi oder was anderem ? Falls der unter Workstation oder Player läuft - da kann ggf ein Virenscanner dazwischenfunken. Avira hat sowas definitiv gemacht (war da dann irgendwo anhakbar sich doch aus VMware Workstation rauszuhalten)

VMware hat übrigens VMware Tools für nested ESXi rausgebracht (unsupported aber das isses ja sowieso)

Member
Beiträge: 96
Registriert: 16.03.2010, 13:02

Beitragvon djt83 » 27.05.2014, 19:57

Der nested ESXi läuft unter ESXi.
Virenscanner ist nirgends installiert.

Soll ich mal die VMware Tools für Nested ESXI installieren?

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 27.05.2014, 20:18

Die VMware Tools sind hier nur 'nice to have' das sollte auch ohne gehen.

*grübel* mir fällt nix passendes ein... googeln wir mal nach den üblichen Verdächtigen...

Wenn William Lam sagt das geht so dann geht das so...
http://www.virtuallyghetto.com/2012/08/ ... other.html

Duncan Epping weiß auch was er tut...
http://www.yellow-bricks.com/2012/06/12 ... ested-lab/

Wenn er nicht grad gegen HyperV pöbelt...
http://www.vcritical.com/2011/07/vmware ... ze-itself/

Die VMware Tools für ESXi gibts hier - haben aber wohl nix mit Problem zu tun:
https://labs.vmware.com/flings/vmware-t ... ested-esxi

Member
Beiträge: 475
Registriert: 08.08.2008, 10:45

Beitragvon pirx » 27.05.2014, 20:46

Hängt die vESXi VM an einm vSwitch mit 2 aktiven pnics? Schon mal probiert eine pnic zu deaktivieren?

Benutzeravatar
Moderator
Beiträge: 14690
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.05.2014, 22:01

Auf welchem vswitch hast du promiscous mode erlaubt ?
Das muss auf dem äusseren ESXi erfolgen ...
https://communities.vmware.com/message/2382700#2382700
ähnlicher Fall

Die Referenzaddresse :
https://communities.vmware.com/docs/DOC-8970
sowie
https://communities.vmware.com/communit ... ces/nested

Member
Beiträge: 96
Registriert: 16.03.2010, 13:02

Beitragvon djt83 » 28.05.2014, 06:55

continuum hat geschrieben:Auf welchem vswitch hast du promiscous mode erlaubt ?
Das muss auf dem äusseren ESXi erfolgen ...
https://communities.vmware.com/message/2382700#2382700
ähnlicher Fall

Die Referenzaddresse :
https://communities.vmware.com/docs/DOC-8970
sowie
https://communities.vmware.com/communit ... ces/nested


Bin ich eine Pflaume :oops:

Danke. Genau das war es, der promiscous mode muss auf dem physischen ESXi eingestellt werden. Ich habe es immer auf den vESXi Servern versuch :roll:

Vielen Dank für die Hilfe


Zurück zu „vSphere 5.5 / ESXi 5.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast