Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

esxi 5.5 GPU gpu passthrough

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 31
Registriert: 12.12.2013, 23:05

Beitragvon Vivian » 06.01.2014, 15:29

Ja, das ist eine Art Fernwartungtool, allerdings speziel für 3d Anwendungen entwickelt. (spaßeshalber habe ich über das tool ein fps spiel gespielt ... kein lag.)

Ein vmware treiber habe ich schon versucht zu deaktivieren und zu deinstallieren. Allerdings ist er nach dem neustart sofort wieder da.
Gibt es irgend eine Einstellung, womit ich die automatische Neuinstallation des Treibers verhindern kann?

King of the Hill
Beiträge: 12359
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 06.01.2014, 16:13

Sobald du mehrere GPUs in einem Rechner (VM) hast, kannst du eigentlich auch die Reihenfolge Primäre und Sekundäre Graka ändern.
Falls das so nicht geht, könntest du die VMware-Graka auch deaktivieren und die VM dann versuchsweise nur noch per Suspend/Resume pausieren/starten. Sobald eine OS-Update natürlich einen Reboot erfordert, fängt das Spiel von vorne an.


Wie Urs schon sagte, ist das Ganze nur eins: Murks.

Experte
Beiträge: 1301
Registriert: 30.03.2009, 17:13

Beitragvon UrsDerBär » 06.01.2014, 16:37

Dann muss es mit deaktivieren im Windows-Geräte-Manager versuchen oder einem Script, welches die notwendigen Registry-Einstellungen beim Start hart setzt. Sofern es damit getan ist.

Die Reihenfolge der GPU wird nicht viel nützen, der Kram wird durch die Treiber überschrieben, wenn keine Bildschirme angeschlossen sind.
Ich bin da bei einer physischen Maschine schon fast verzweifelt. Da haben wir die Workstation ins Rack verfrachtet und per PCoIP darauf verbunden.
Funktioniert alles tadellos.
Wenn nun aber nach einem Windows-Update sich jemand zuerst mit Teamviewer auf die Maschine einloggt, dann verwirft es alle Einstellungen und übernimmt die des verbindenden PC's.

Dient den Jungs dieses Betriebes als Schnittstelle um nicht immer ins Büro springen zu müssen wenn nur kleine Änderungen an einem gerade laufenden Programm gemacht werden müssen. Jetzt muss man immer dran denken, als erstes mit PCoIP zu verbinden, sonst bekommt man keine Verbindung mehr. Alles schwarz. Hilft nur noch ein erneuter Neustart. Habe schon stunden damit verbracht das angenehmer zu machen, klappt alles nicht.

Wenigstens sind die Graka-Hersteller heute gezwungen, einigermassen stabile Treiber zu produzieren, früher wäre Windows abgestürzt und man hätte über Microsoft geflucht. Dabei war der Graka-Hersteller schuld.

Member
Beiträge: 31
Registriert: 12.12.2013, 23:05

Beitragvon Vivian » 06.01.2014, 22:48

Habe jetzt zum test Windows Server 2012 r2 mit RemoteFX HyperV insalliert. Und als Gast Windows 8.
In den einstellungen die ATI Karte für RemoteFX aktiviert.

Hier sind die ergebnisse
http://www.3dmark.com/3dm11/7779626 ( http://www.3dmark.com/3dm11/7779848 )

Was aber seltsam ist, das die Karte irgendwie geschared wird, ähnlich dem, was die nvidia grid karte auch macht.

In VM wird die Karte mit nur 1GB angezeig. Aber, die Karte funktioniert auf dem host, und auch in der VM gleichzeitig.

Probiere morgen das gleiche mit mehreren Gästen

Edit Sagt:
Ok, habs durchgelesen was RemoteFX macht. ...


Zurück zu „vSphere 5.5 / ESXi 5.5“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast