Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Partition wiederherstellen

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Partition wiederherstellen

Beitragvon Omega » 16.02.2014, 17:51

Folgendes Problem. Nach dem Einbau neuer Festplatten und dem erzeugen eines neuen Raids auf die neuen Platten, hat der verbaute LSI Controller das alte Raid wohl zurückgesetzt und die Partitionstabelle überschrieben, so dass das Raid völlig leer derher kommt. vSpehre sieht mein altes Raid und möchte auf dem alten Raid eine neue Partition erzeugen. An dem Punkt habe ich abgebrochen. Wenn ich das jetzt richtig sehe, muss doch eigentlich nur die Partitionstabelle wieder restauriert werden, dann sollte ich doch wieder auf die VMs die auf der Partition liegen wieder zugreifen können. Ich könnte auch alles neu installieren, ich hoffe aber durch eine Restaurierung der Partitionstabelle deutlich schneller voran zu kommen.

Jetzt die Frage an die wissenden hier: Wie hoch sind meine Chancen? Wie geht das, bzw. wer macht das. Um es klar zu sagen, es darf auch Geld kosten. Macht VMWare so was? Wie erzeuge ich ohne Support Vertrag ein Ticket? Fragen über Fragen. Schon mal vorab Danke für die Tipps!

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.02.2014, 18:47

Nach dem Einbau neuer Festplatten und dem erzeugen eines neuen Raids auf die neuen Platten, hat der verbaute LSI Controller das alte Raid wohl zurückgesetzt und die Partitionstabelle überschrieben, so dass das Raid völlig leer derher kommt.
Was bedeutet das genau, wie war der Zustand vor und nach der Erweiterung?
Sprich welche Raidlevel mit Raidteilnehmeranzahlen hattest du vorher und jetzt?

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Beitragvon Omega » 16.02.2014, 19:01

Dayworker hat geschrieben:Was bedeutet das genau, wie war der Zustand vor und nach der Erweiterung?


Vorher ein Raid1 mit meinen zwei "alten" Platten. Dann habe ich zwei neue Platten eingebaut und die beiden ebenfalls zu einen "neuen" Raid1 verbunden. Stand jetzt, zwei Raid1 mit je zwei Platten, die "alten" Platten (also mein schon vorhandenes Raid) wollte ich doch überhaupt nicht anfassen :( Einfach ein Raid1 hinzufügen, warum der Controller mir das alte aber zerschiesst ...

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.02.2014, 19:18

Je Raid-Level unterstützen nicht alle Raid-Controller auch mehrere Volumes bzw können diese anlegen.
Welchen Raid-Controller setzt du ein?

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Beitragvon Omega » 16.02.2014, 19:30

Der Raid Kontroller kann es sicher, der kann noch viel mehr ;) Der steckt in einer TX200 von Fujitsu: FSC D2516 / LSI Megaraid SAS8708

Jetzt sehe ich ja auch die zwei Volumes, nur bei sind frisch, ein frisches ist ja OK, aber ich will mein altes Volume wieder haben.

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.02.2014, 20:21

Ist das dieselbe Maschine, bei der du im Jahre 2010 die Passthrough-Probleme mit dem USB-Stick hattest?
Wenn ich bei LSI nachsehe, werden die 8708EM2/ELP-Controller, basierend auf dem SAS1078-ROC, unter "Legacy Raid Controller" geführt. Da du keine weiteren Daten rausrückst, stellen sich die Fragen nach der Aktualität von Firmware und MSM.

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Beitragvon Omega » 16.02.2014, 20:46

Dayworker hat geschrieben:Ist das dieselbe Maschine, bei der du im Jahre 2010 die Passthrough-Probleme mit dem USB-Stick hattest?

Nein.
Dayworker hat geschrieben:IWenn ich bei LSI nachsehe, werden die 8708EM2/ELP-Controller, basierend auf dem SAS1078-ROC, unter "Legacy Raid Controller" geführt. Da du keine weiteren Daten rausrückst, stellen sich die Fragen nach der Aktualität von Firmware und MSM.


Das Problem bei den Controllern ist, FTS/FSC labelt die Dinger um. Ich muss mich da einfach auf Fujitsu verlassen. Ich kann ja einfach nur sagen, es ist ein D2516 Firmwarestand 2010. Ich aktualisiere Firmware nur dann, wenn ich wirklich muss. Never touch a running system. Was für Infos kann/soll ich noch geben?

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 16.02.2014, 21:21

Das Problem mit so alten Firmware-Ständen ist, daß dort genau solche Probleme vorhanden sein können. Das ein $vendor einen Controller umlabelt, ist nichts wirklich neues und meistens kannst du auch eine Original-Firmware flashen. Mein H200-Controller basiert auf dem LSI-Chip 2008-IR und wurde unter anderem auf dem LSI SAS9211-8i verbaut.

Ob der Controller überhaupt zwei Raidgruppen vernünftig verwalten kann, finde ich leider nirgendwo. Für meinen Einsteiger-Controller würde mich diese Frage aber auch brennend interessieren.



PS: Lustig finde ich die Preise für die SAS8708EM2/ELP-Controller. Während die beispielsweise bei Geizhals um 500 Euro angeboten werden, vertreibt LSI diese in seinem Store https://store.lsi.com/index.cfm/Clearance/ für 125 Dollar...

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Beitragvon Omega » 16.02.2014, 21:33

Ich kann aber doch auf beide Raidgruppen zugreifen. Per partUtil kann ich die Raidgruppen sauer auslesen, nur sagt mit PartUtil das auf meiner "alten" Raidgruppe das keine Partitionstabelle existiert.

Profi
Beiträge: 991
Registriert: 31.03.2008, 17:26
Wohnort: Einzugsbereich des FC Schalke 04
Kontaktdaten:

Beitragvon kastlr » 16.02.2014, 21:39

Hallo,

versuch dein Glück mal mit folgendem VMware Artikel.
Recreating a missing VMFS datastore partition in VMware vSphere 5.0/5.1/5.5

Viel Erfolg,
Ralf

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Beitragvon Omega » 17.02.2014, 07:18

kastlr hat geschrieben:Hallo,

versuch dein Glück mal mit folgendem VMware Artikel.
Recreating a missing VMFS datastore partition in VMware vSphere 5.0/5.1/5.5

Viel Erfolg,
Ralf


Vielen Dank für den Link, leider scheitere ich schon am ersten Step, weil eben eben wohl keine gültige Partitiontabelle sieht.
Output:
partedUtil getptbl /vmfs/devices/disks/naa.6003005700a5b01019af3632259e9c92
unknown
36404 255 63 584843264

Sieht verdammt nach Neuinstallation aus :(

Member
Beiträge: 359
Registriert: 28.11.2011, 09:46

Beitragvon weigeltchen » 17.02.2014, 07:45

Mich würde mal interessieren, wie Du die neue Raidgruppe erstellt hast. im Normalfall zerschießt kein Raidcontroller von sich aus eine bestehende Konfiguration. Irgendeine Warnung kam/kommt mit Sicherheit.

Member
Beiträge: 10
Registriert: 19.10.2010, 10:00
Wohnort: Dinslaken

Beitragvon Omega » 17.02.2014, 11:17

Ja, ich bin auch überrascht!

Add Configuration, die beiden neuen Platten ausgewählt, eine Group erstellt, Raid1 als Konfiguration und fertigstellen. Das war es. Nach dem Reboot zeigte er mir zwei Virtualdisk an, damit war ich ja auch einverstanden.

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 17.02.2014, 11:35

Welche MSM-Version läuft bei dir? Meine ist die:

Bild

Hattest du vielleicht die neue Raid-Gruppe initialisiert?

Experte
Beiträge: 1375
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 17.02.2014, 14:15

Mit an Sicherheit grenzender Wahrscheinlichkeit wird da ueberhaupt kein MSM installiert sein. Vermutlich nicht einmal Fujitsu's ServerView RAIDManager.

Ich tippe mal, dass die RAID-Konfiguration im WebBIOS des Controllers beim Boot vorgenommen wurde.

Was ich persoenlich jetzt nicht verstehe, ist, warum denn kastlr's Goldener Tipp auf den KB nicht weiter befolgt wurde.

Das Problem ist doch genau das, was im KB-Artikel beschrieben steht unter "the second output shows the partition as missing". Selbstverstaendlich kommen bei Dir andere Werte fuer die Plattenphysik. Die muss man halt an die eigenen Gegebenheiten anpassen. Und an der fehlenden Ausgabe von "gpt" (oder "msdos") wuerde ich da jetzt nichts festmachen. Ob's GPT oder MBR ist (bzw. wird) kann man einer "nackten" LUN naemlich nicht ansehen.

"The first output" bezieht sich auf den Fall, dass die Partition noch da ist, aber der Datastore darauf nicht mehr erkannt wird.

Welche Ausgabe bringt denn das Skript aus dem KB-Artikel? Damit wuerde zumindest mal gesucht, ob ueberhaupt verwertbare Informationen auf der LUN gefunden werden koennen...

VMware bietet auch sog. Per-Incident-Support an. Weitere Infos sollten unter den Support Opptions gefunden werden koennen.

Profi
Beiträge: 991
Registriert: 31.03.2008, 17:26
Wohnort: Einzugsbereich des FC Schalke 04
Kontaktdaten:

Beitragvon kastlr » 17.02.2014, 16:05

Hallo, zusammen,

sorry das ich mich erst jetzt melde, aber ich hatte keine Mails vom System erhalten, das der Thread aktualisiert worden ist.

Mit folgendem Befehl solltest du die Partitionstabelle wieder herstellen können.
partedUtil setptbl "/vmfs/devices/disks/naa.6003005700a5b01019af3632259e9c92" gpt "1 2048 584830259 AA31E02A400F11DB9590000C2911D1B8 0"

Aber das erfolgt natürlich auf eigenes Risiko!


Hier einige Links zu diesem Thema:
Using the partedUtil command line utility on ESXi and ESX
Using partedUtil to recover an esxi5.x partition table

Viel Erfolg,
Ralf

King of the Hill
Beiträge: 12302
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 17.02.2014, 18:36

JustMe hat geschrieben:Mit an Sicherheit grenzender Wahrscheinlichkeit wird da ueberhaupt kein MSM installiert sein. Vermutlich nicht einmal Fujitsu's ServerView RAIDManager.
Schade eigentlich, denn über den MSM kann man seinen Controller auch übers Netzwerk abfragen. Voraussetzung dafür sind allerdings installierte CIM-Provider, aber das steht ja auch in der MSM-Onlinehilfe.

Benutzeravatar
Moderator
Beiträge: 14677
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 17.02.2014, 20:36

Der Befehl
hexdump -C /dev/disks/diskname | grep "0d d0 01 c0 05"
zeigt den Anfang der original VMFS 5 -partition an.

Der Befehl
hexdump -C /dev/disks/diskname | grep "0d d0 01 c0 03"
zeigt den Anfang der original VMFS 3 -partition an.


00200000 0d d0 01 c0 05 00 00 00 15 00 00 00 01 1a 00 00 |................|
bedeutet das die VMFS 5 Partition bei offset 2048 anfing.


00110000 0d d0 01 c0 03 00 00 00 11 00 00 00 01 1a 00 00 |................|
bedeutet dass die VMFS Partition bei offset 128 anfing

@ Irix
so eine Schlappe wie neulich passiert mir nicht nochmal 8)

Experte
Beiträge: 1375
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 18.02.2014, 09:46

@Dayworker, just FYI:
SV-RM funktioniert auch "nur" ueber's Netzwerk. Und setzt ebenfalls den LSI CIM-Provider voraus. Nennen wir den SV-RM einfach mal "den MSM von Fujitsu".

Member
Beiträge: 2
Registriert: 22.03.2017, 03:56

Re: Partition wiederherstellen

Beitragvon Lilabaue » 22.01.2018, 08:12

Probier dieses Tools aus, um die Partition noch zu retten.

Edit Moderator: Link entfernt


Zurück zu „vSphere 5 / ESXi 5 und 5.1“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast