Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 47
Registriert: 02.04.2012, 14:12

CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Beitragvon Dros » 24.09.2018, 10:53

Hallo liebe Kollegen,

ich habe seit einiger Zeit ein merkwürdiges Phänomenen mit einer unserer ESX Sessions. Das ist ein Win2008 Server zur Administration der TK-Anlage. Der lief eigentlich jahrelang ohne Probleme, aber seit ein paar Monaten hat er das Problem, dass die CPU-Last im Gast auf 100% ansteigt und der Gast dann so gut wie nicht mehr nutzbar ist. Eigentlich macht der Server aber gar nichts, da laufen im Hintergrund keine Dienste die viel verbrauchen würden.

Wenn ich einen Snapshot anlege (schon wenn ich damit anfange) geht die CPU Last wieder runter auf 1-5% was normal ist und man kann das System benutzen. Das hält dann ein paar Wochen und dann ist die CPU-Last wieder oben. Auf dem System wird aber nichts installiert oder geupdated.

Wie kann das sein, hat da jemand eine Erklärung für? Nicht dass sich da schleichend irgendwas vom ESX verabschiedet und ich die Symptome nicht deuten konnte. Alle anderen Sessions (auch mit Win) laufen ohne Probleme.

Danke

Experte
Beiträge: 1443
Registriert: 04.10.2011, 14:06

Re: CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Beitragvon JustMe » 24.09.2018, 12:08

Welche Informationen fehlen denn noch, die die Vermutung ueberhaupt erst einmal nahelegen wuerden, dass es sich um ein ESXi-Problem handeln wuerde? Noch dazu, dass sich dort "irgendwas verabschieden wuerde"?

Wenn das Problem erst nach wochenlanger Laufzeit der VM (die fuer die Telefonanlagen-Administration da ist) auftritt, wuerde ich persoenlich pragmatisch erst einmal einen woechentlichen Reboot des Gast-OS einstellen, oder vielleicht sogar die VM nur nach Bedarf starten.

Member
Beiträge: 47
Registriert: 02.04.2012, 14:12

Re: CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Beitragvon Dros » 24.09.2018, 13:17

Also ein Reboot bringt gar nichts und die Session ist danach genauso langsam wie vorher, das haben wir ja schon versucht.

Ich rate einfach mal, weil mir der Zusammenhang zwischen Snapshot und CPU-Last vom Gast nicht klar ist. Vielleicht wird ein Filesystem verwendet, was beschädigt ist und nach einem Snapshot wird wieder auf einem anderen Bereich gespeichert? Deswegen frage ich ja hier, weil ich mir keinen Reim machen kann.

Experte
Beiträge: 1951
Registriert: 23.02.2012, 12:26

Re: CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Beitragvon ~thc » 24.09.2018, 13:24

Erste Anlaufstelle der Analyse - in der VM: Taskmanager, Ressourcen-Monitor, Process Explorer.

Dort bitte schauen, ob es interne VM-Prozesse gibt, die Amok laufen.

Experte
Beiträge: 1443
Registriert: 04.10.2011, 14:06

Re: CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Beitragvon JustMe » 24.09.2018, 13:55

Genau.
Damit kann man schon einmal recht gut vergleichen, welche Prozesse VOR und NACH dem Snapshot denn welche CPU-Ressourcen "verbrauchen".

Dass ein Reboot der VM (echter Reboot, nicht einfach nur pausieren/fortsetzen) bei einem solchen Problem im Gegensatz zu einem Snapshot nicht hilft, ist allerdings schon aussergewoehnlich.
Wird die VM denn wieder "langsamer", sobald der Snapshot wieder aufgeloest/geloescht ist?

Member
Beiträge: 47
Registriert: 02.04.2012, 14:12

Re: CPU Last 100% beim Win2008 Gast, nach Snapshot alles ok

Beitragvon Dros » 02.10.2018, 12:59

Also inzwischen hatten auch neue Snapshots die Lage nicht mehr verbessert, die CPU Leistung war immer bei 100%. Jetzt habe ich mal alle Snapshots gelöscht und das System reagiert wieder normal.Ich vermute tatsächlich einen Zusammenhang, über die Leistungsanzeige über VMware war aber nichts heraus zubekommen, außer, dass eben viel Leistung gefordert wurde.


Zurück zu „vSphere 5 / ESXi 5 und 5.1“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast