Die Foren-SW läuft schon geraume Zeit ohne erkennbare Probleme. Sollte etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

vRanger sichert eine Virtuelle Maschine nicht

Backupsoftware und sonstiges ...

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

vRanger sichert eine Virtuelle Maschine nicht

Beitragvon mali » 25.11.2011, 10:12

Hallo NG,

ich habe ein 4.1er VMwarecluster mit 2 x ESX 4.1 und 12 VMs laufen.

vRanger ist Version 5.2.3.23095

Ich habe eine Job angelegt der alle VMs sichern soll. Es wird alles gesichert bis auf den vcenter-Server. VCenter läuft als VM. vRanger läuft nicht als VM sonder auf einem extra Blech unter 2008r2.

Wenn ich jetzt aber den Center-Server von Hand sichere funktioniert alles einwandfrei. Im Job oder als extra Job bricht die Sicherung immer mit: An internal error occurred Exekution.
Error Message Failed to create vRanger snapshot: Check the Status of your VM, making sure the files are intact and that the VM is usable.

Aber auf dem vCenter steht in Aufgaben und Ereignisse für die betreffende VM Snapshot der VM erstellen. 8 Minuten später: Host nicht verbunden, 4 Sekunden später: Host ist verbunden. Dann hat aber die Sicherung schon abgebrochen.

Wo könnte da der Fehler liegen? Es ist zwar kein Problem die VM per Hand zu sichern, aber eigentlich sollte es ja funktionieren.

Vielen Dank

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 25.11.2011, 10:19

Was sagt denn das Log vom vRanger und der betreffenden Sicherung?

Das Sicherungen nicht klappen ist garnicht so unueblich (Leider) und haben viel mit VSS bzw. Timeout Geschichten zu tun.

Frage: Was fuer ein Guest OS hat die VM?

Was ich bedenklich finde ist deine Aussage das der Host verschwindet bzw. sich unerreichbar zeigt. Das konnte ich bei einer Sicherung noch nie beobachten und ich habe den vRanger nun schon lange und oft im Einsatz.

Gruss
Joerg

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 25.11.2011, 10:59

Hallo Jörg,

vielen dank für Deine Antwort. Das was ich nicht verstehe! Automatisches bricht ab, wenn ich aber den Job manuell starte (Job markieren und dann RUN) macht er das einwandfrei. Die VM ist der vCenter und der läuft unter 2008r2.
Was ist da der Unterschied?
Ich hab das log mal angefügt:
[2011-11-24 04:00:18.709]: Task for virtual machine vcenter01-564db577-4e0a-37c4-5d23-8a8e891a4800 was queued.
[2011-11-24 05:18:44.253]: SourceVm:vcenter | Uuid xxxx-xxxx | Vc:vcenter.xxxxx.xxxx, Host:esx01.xxxxx.xxxxx [ESX 4.1.0]
[2011-11-24 05:18:44.253]: Beginning backup task for vcenter
[2011-11-24 05:18:44.269]: Starting task validation.
[2011-11-24 05:18:44.269]: Connection to esx01.xxxx.xxxx was properly validated.
[2011-11-24 05:18:44.269]: esx01.xxxxx.xxxxx is properly licensed.
[2011-11-24 05:18:44.269]: Test connection to repository xxxxx starting...
[2011-11-24 05:18:44.831]: Test connection to repository xxxxx successful!
[2011-11-24 05:18:44.831]: Ending task validation... success!
[2011-11-24 05:18:44.831]: Beginning initialization of backup information.
[2011-11-24 05:18:44.831]: Retrieving the tasks parent information.
[2011-11-24 05:18:45.314]: Retrieving save points for any full backups associated with this job.
[2011-11-24 05:18:45.330]: Finished initialization of backup information successfully.
[2011-11-24 05:18:45.330]: A full backup will be run for this task
[2011-11-24 05:18:45.455]: Gathering credentials for vcenter completed.
[2011-11-24 05:18:45.673]: Checking for VMotion completed.
[2011-11-24 05:18:45.938]: Gathering data for vcenter from API completed.
[2011-11-24 05:18:47.186]: Gathering data for esx01.xxxx.xxxxx from API completed.
[2011-11-24 05:18:47.654]: Checking free space on xxxx completed.
[2011-11-24 05:18:51.008]: Creating a snapshot for vRanger completed.
[2011-11-24 05:18:51.024]: An internal error occurred during execution, please contact Vizioncore support if the error persists.
Error Message: Failed to create vRanger snapshot: Check the status of your VM, making sure the files are intact and that the VM is usable.

Auf dem vCenter im Aufgaben und Ereignisse der VM:vcenter steht dann das er die VM neu konfiguriert und im Status Fehler beim Kommunizieren mit dem Remotehost. Was will er da konfigurieren? Wenn ich die VM manuell starte kommt das nicht!

Gruss
Jürgen

Benutzeravatar
Moderator
Beiträge: 14742
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 25.11.2011, 13:39

Vielleicht musst du bei der VM nur mal ordentlich alte snapshots, vmsd, vmsn usw aufraeumen
Poste mal eine Dateiliste der VM - vielleicht faellt uns ja was auf

die aktuelle vmx und die vmsd waeren auch hilfreich

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 25.11.2011, 13:45

Also eigentlich meinte ich das Logfile aus "C:\Program Files (x86)\Quest Software\vRanger\Service\Logs\User\Tasks\Backup" fuer die entsprechende VM.

Die Meldung mit Snapshots kann und hat unzaehlige Gruende.

Gruss
Joerg

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 25.11.2011, 17:03

irix hat geschrieben:Also eigentlich meinte ich das Logfile aus "C:\Program Files .......
Gruss
Joerg


Also eigentlich ist es ja von da. Nur habe ich das am Anfang weggelassen.
Das vollständige Logfile schaut so aus:


[2011-11-24 04:00:18.709]: vRanger Backup & Replication - v5.2.3.23095
[2011-11-24 04:00:18.709]: Selected Options: Check destination for free space. | Compress backed up files. | Update notes with the latest backup results. | Enable Active Block Mapping (ABM). | Perform network backup on LAN-free Failure. | Enable Cataloging. | Selected SpaceSavingTech: None | Included Disks: [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64]
[2011-11-24 04:00:18.709]: Task for virtual machine vcenter01-564db577-4e0a-37c4-5d23-8a8e891a4800 was queued.
[2011-11-24 05:18:44.253]: SourceVm:vcenter01 | Uuid:564db577-4e0a-37c4-5d23-8a8e891a4800 | Vc:vcenter01.xxx.xxx, Host:esx01.xxx.xxx [ESX 4.1.0]
[2011-11-24 05:18:44.253]: Beginning backup task for vcenter01
[2011-11-24 05:18:44.269]: Starting task validation.
[2011-11-24 05:18:44.269]: Connection to esx01.bigi.local was properly validated.
[2011-11-24 05:18:44.269]: esx01.xxx.xxx is properly licensed.
[2011-11-24 05:18:44.269]: Test connection to repository xxxx starting...
[2011-11-24 05:18:44.831]: Test connection to repository xxxx successful!
[2011-11-24 05:18:44.831]: Ending task validation... success!
[2011-11-24 05:18:44.831]: Beginning initialization of backup information.
[2011-11-24 05:18:44.831]: Retrieving the tasks parent information.
[2011-11-24 05:18:45.314]: Retrieving save points for any full backups associated with this job.
[2011-11-24 05:18:45.330]: Finished initialization of backup information successfully.
[2011-11-24 05:18:45.330]: A full backup will be run for this task
[2011-11-24 05:18:45.455]: Gathering credentials for vcenter01 completed.
[2011-11-24 05:18:45.673]: Checking for VMotion completed.
[2011-11-24 05:18:45.938]: Gathering data for vcenter01 from API completed.
[2011-11-24 05:18:47.186]: Gathering data for esx01.xxx.xxx from API completed.
[2011-11-24 05:18:47.654]: Checking free space on xxx completed.
[2011-11-24 05:18:51.008]: Creating a snapshot for vRanger completed.
[2011-11-24 05:18:51.024]: An internal error occurred during execution, please contact Vizioncore support if the error persists. Error Message: Failed to create vRanger snapshot: Check the status of your VM, making sure the files are intact and that the VM is usable.


Das Logfile wenn ich es manuell starte lautet:


[2011-11-25 10:33:16.321]: vRanger Backup & Replication - v5.2.3.23095
[2011-11-25 10:33:16.321]: Selected Options: Check destination for free space. | Compress backed up files. | Update notes with the latest backup results. | Enable Active Block Mapping (ABM). | Perform network backup on LAN-free Failure. | Enable Cataloging. | Selected SpaceSavingTech: None | Included Disks: [31, 11, 32, 50, 21, 28, 57, 53, 46, 19, 55, 61, 17, 47, 27, 2, 25, 29, 64, 38, 7, 51, 60, 12, 26, 54, 18, 24, 58, 3, 37, 9, 43, 10, 63, 35, 39, 14, 41, 30, 44, 56, 49, 4, 59, 13, 15, 62, 20, 36, 16, 8, 22, 23, 5, 42, 1, 52, 33, 34, 40, 48, 45, 6]
[2011-11-25 10:33:16.321]: Task for virtual machine vcenter01-564db577-4e0a-37c4-5d23-8a8e891a4800 was queued.
[2011-11-25 10:33:19.550]: SourceVm:vcenter01 | Uuid:564db577-4e0a-37c4-5d23-8a8e891a4800 | Vc:vcenter01.xxx.xxx, Host:esx01.xxx.xxx [ESX 4.1.0]
[2011-11-25 10:33:19.550]: Beginning backup task for vcenter01
[2011-11-25 10:33:19.565]: Starting task validation.
[2011-11-25 10:33:19.565]: Connection to esx01.xxx.xxx was properly validated.
[2011-11-25 10:33:19.565]: esx01.bigi.local is properly licensed.
[2011-11-25 10:33:19.565]: Test connection to repository xxx.xxx starting...
[2011-11-25 10:33:26.492]: Test connection to repository xxx.xxx successful!
[2011-11-25 10:33:26.492]: Ending task validation... success!
[2011-11-25 10:33:26.492]: Beginning initialization of backup information.
[2011-11-25 10:33:26.492]: Retrieving the tasks parent information.
[2011-11-25 10:33:27.163]: Retrieving save points for any full backups associated with this job.
[2011-11-25 10:33:27.194]: Finished initialization of backup information successfully.
[2011-11-25 10:33:27.194]: A full backup will be run for this task
[2011-11-25 10:33:27.350]: Gathering credentials for vcenter01 completed.
[2011-11-25 10:33:27.584]: Checking for VMotion completed.
[2011-11-25 10:33:27.849]: Gathering data for vcenter01 from API completed.
[2011-11-25 10:33:29.409]: Gathering data for esx01.xxx.xxx from API completed.
[2011-11-25 10:33:29.893]: Checking free space on xxx.xxx completed.
[2011-11-25 10:35:17.937]: Removing snapshot for vRanger completed.
[2011-11-25 10:35:19.529]: Gathering data for esx01.xxx.xxx from API completed.
[2011-11-25 10:35:20.121]: Gathering data for vcenter01 from API completed.
[2011-11-25 10:35:23.663]: Creating a snapshot for vRanger completed.
[2011-11-25 10:35:23.678]: Beginning Cataloging of volume F: [LHC1_VM01] vcenter01/vcenter01.vmdk
[2011-11-25 10:35:25.051]: Gathering data for vcenter01 from API completed.
[2011-11-25 10:35:25.051]: Backup task will be attempted in COS mode.
[2011-11-25 10:36:09.558]: Catalog data for F: [LHC1_VM01] vcenter01/vcenter01.vmdk volume 1 failed to save for the following reason(s): Failed to mount disk container
[2011-11-25 10:36:09.558]: Beginning Cataloging of volume F: [LHC1_VM01] vcenter01/vcenter01_1.vmdk
[2011-11-25 10:36:18.293]: Catalog data for F: [LHC1_VM01] vcenter01/vcenter01_1.vmdk volume 1 was queued to save successfully.
[2011-11-25 10:36:23.067]: The active map filter failed on phys:/vmfs/volumes/4bd072fd-4e8b717a-36d5-78e7d1e89958/vcenter01/vcenter01-flat.vmdk.
[2011-11-25 10:36:24.206]: The active map filter failed on phys:/vmfs/volumes/4bd072fd-4e8b717a-36d5-78e7d1e89958/vcenter01/vcenter01_1-flat.vmdk.
[2011-11-25 10:59:01.598]: Backing up VM phys:/vmfs/volumes/4bd072fd-4e8b717a-36d5-78e7d1e89958/vcenter01/vcenter01-flat.vmdk completed.
[2011-11-25 11:00:54.523]: Backing up VM phys:/vmfs/volumes/4bd072fd-4e8b717a-36d5-78e7d1e89958/vcenter01/vcenter01_1-flat.vmdk completed.
[2011-11-25 11:00:54.554]: Checking and enforcing retention policy completed.
[2011-11-25 11:01:03.945]: Removing snapshot for vRanger completed.
[2011-11-25 11:01:04.850]: Commiting savepoint data to xxx.xxx completed.
[2011-11-25 11:01:07.627]: Verifying the content of the repository completed.
[2011-11-25 11:01:08.485]: Updating VM notes completed.
[2011-11-25 11:01:08.875]: Setting VM event completed.
[2011-11-25 11:01:10.092]: Removing snapshot for vRanger completed.
[2011-11-25 11:01:10.123]: Catalog data for disk [LHC1_VM01] vcenter01/vcenter01_1.vmdk volume 1 has been queued to activate.


Dateiliste der VM

http://www.ebgate.info/vcenter.png

Die aktuellen vmx und vmsd sind hier:
http://www.ebgate.info/vcenter01.vmsd
http://www.ebgate.info/vcenter01.vmx

Danke

Gruß
Jürgen

Benutzeravatar
Moderator
Beiträge: 14742
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 25.11.2011, 20:43

scsi0:1.mode = "persistent"

hmmm ... was soll das ?

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 25.11.2011, 21:44

continuum hat geschrieben:scsi0:1.mode = "persistent"

hmmm ... was soll das ?


Keine Ahnung, hab das nicht reingeschrieben.

Weiß auch nicht woher das kommt. Von wo wird das konfiguriert?

Gruß

Benutzeravatar
Moderator
Beiträge: 14742
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 25.11.2011, 21:58

das steht in der vmx und verbietet snapshots

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 28.11.2011, 09:29

continuum hat geschrieben:das steht in der vmx und verbietet snapshots


Hallo,

und wie kann ich das rauskonfigurieren? Oder kann ich das einfach in der VMX-Datei rauslöschen.

Danke Grüß
Jürgen

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 28.11.2011, 09:56

mali hat geschrieben:
continuum hat geschrieben:das steht in der vmx und verbietet snapshots


Hallo,

und wie kann ich das rauskonfigurieren? Oder kann ich das einfach in der VMX-Datei rauslöschen.

Danke Grüß
Jürgen


Geht auch mit der GUI wenn du auf die vDisk klickst sind doch da Rechts die Optionen ueber Independent und so. Aber das Wiederspricht deiner Aussage das du es ja mit einem Single Job gesichert bekommst und auch der Macht einen Snapshot zuerst.

Gruss
Joerg

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 28.11.2011, 10:05

Ja, mit einem Single Job funktioniert es einwandfrei. Also einfach den Job aus der Jobliste anklicken und dann auf RUN funktioniert ohne Probleme. Da bekomme ich im Center auch keine Meldungen wie Maschine neu konfigurieren oder so.

Gruß
Jürgen

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 28.11.2011, 10:08

Evtl. hast du andere Settings in den Jobs. Das mit dem Reconfigure kann/hat was mit

- Updates Notification
- Hot-Add

zutun.

Gruss
Joerg

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 28.11.2011, 10:24

Nicht das ich wüsste, oder was ich wissentlich konfiguriert habe. Der einzige Unterschied zu den anderen VMs ist nur dass es das vCenter ist.

Im Automatisiertem Job verliert er sogar die Verbindung mit dem Host.

Ich hatte anfangs den Job mit im Hauptjob laufen. Jetzt habe ich den Job alleine gestellt Problem ist gleich geblieben. Ich könnte das vCenter auf einen anderen Cluster-Note verschieben und schauen ob der Fehler mitwandert.

Gruß
Jürgen

Member
Beiträge: 12
Registriert: 25.11.2011, 09:46

Beitragvon mali » 29.12.2011, 19:41

Hallo,

hab das Problem so halb gelöst. Ich habe die VM auf einen anderen Host umgezogen und schon hat es funktioniert.
Habe jetzt auch die 5.3 am laufen. Wenn ich die VM wieder auf den anderen Host schiebe habe ich wieder gleiches Problem. Den Clusternote habe ich auch schonmal neu installiert, hat aber auch nichts gebracht.

Gruß
Jürgen

Guten Rutsch

Experte
Beiträge: 1333
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 30.01.2012, 10:14

Ich hänge mich mal hier dran:

Grundsätzlich hat die Version 5.3 vom Vranger wohl nen Bug, da bekomme ich plötzlich meldungen ala Index out of range.?!

Daher teste ich aktuell 5.2.3

Für application-consistent quiescing will der Vranger, dass man disk.EnableUUID auf false setzt.
Ab Vsphere 4.1 (haben wir) meint Vmware ja, damit kann man Win2k08 VM's application-consistent sichern, wenn mann disk.EnableUUID auf "true" setzt. Das klappt auch zumindest mit DataRecovery 2.0.
Nur der Vranger mosert dann über diese Einstellung (disk.EnableUUID "true) rum.

Ebenso braucht er bei einer Oracle VM gerne noch die VzShadow.exe + den Backupscrpt eintrag "freeze.bat", der leider nur versteckt dokumentiert ist.

Jedoch stellt sich mir die Frage, wieso bekommt DataRecovery einen Snapshot mit der Einstellung auf True hin, während der Vranger sich beim Backup an der Einstellung verschluckt bzw die Anforderung des Snapshots so komisch sendet, dass dieser nicht klappt?!

Gruß
Stefan

Profi
Beiträge: 535
Registriert: 04.01.2006, 12:06
Wohnort: Hamm

Beitragvon ostekl1 » 31.01.2012, 10:30

... ich hatte ja auf einen Bugfix zu 5.3 gehofft und eben mal auf der Quest Seite nachgesehen.
Dort wird jetzt eine 5.3 mit Datum vom 26.01. angeboten. Haben die wohle einen "heimlichen Bugfix" eingebaut?

Experte
Beiträge: 1333
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 31.01.2012, 10:54

Also auch mit dem Update vom 26.01. funktioniert es nicht besser bzw der Vranger meldet bei Backups "Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt". Ähnlich wie es der irix im Quest Forum geschrieben hat.

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 31.01.2012, 13:31

Ich muss mal gucken ob ich diesen Fehler nun noch habe.

Vom support kam aber eine erfreuliche Meldung das im Q2 eine Appliance kommen soll welche das Backup dann "pro" ESXi macht. Somit hat man wieder den Skallierungsfaktor von Frueher!

Gruss
Joerg

Experte
Beiträge: 1333
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 03.02.2012, 21:31

Vranger 5.3.1 verfügbar.

Experte
Beiträge: 1333
Registriert: 25.04.2009, 11:17
Wohnort: Thüringen

Beitragvon Supi » 04.02.2012, 18:19

Leider klappt es bei mir mit 5.3.1 auch wieder nicht nicht.
Ein SAN Backup, der zuvor mit 5.2.3 klappte, meldet nach Update auch 5.3.1:

"Der Index lag außerhalb des Bereichs. Er muss nicht negativ und kleiner als die Auflistung sein.
Parametername: index"
Das gleiche Problem hatte ich schon nach update auf Version 5.3. Muss ich wohl mal doch Quest kontaktieren.

Profi
Beiträge: 535
Registriert: 04.01.2006, 12:06
Wohnort: Hamm

Beitragvon ostekl1 » 06.02.2012, 10:15

Hat ggf. schon jemand getestet?

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 06.02.2012, 10:19

Ich hab auf 2 Instanzen aktualisiert. Allerdings laufen tagsueber nur Replikationen und das mit dem Backup sage ich dir dann morgen.

Gruss
Joerg

Benutzeravatar
Guru
Beiträge: 3129
Registriert: 22.02.2008, 20:01
Wohnort: Hessen

Beitragvon PeterDA » 08.02.2012, 08:54

Hallo Joerg,
kannst du mittlerweile was zum Backup von vRanger 5.3.1 sagen?

Gruß Peter

King of the Hill
Beiträge: 12103
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 11.02.2012, 09:50

Ja kann ich. Funktioniert soweit und meinen "Keine Objektinstanz" bin ich losgeworden in dem ich das Template zurueck in eine VM konvertiert habe.

Nun verbleibt noch mein "Database roled back" Fehler, welchen ich aber schon laenger mit mir rum Trage.

Gruss
Joerg


Zurück zu „3rd Party Zubehör und Produkte“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast