Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

ESXi Kickstart Installation funktioniert nicht.

ESX(i)-taugliche Hardware, HCL .....

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 5
Registriert: 04.08.2016, 11:46

ESXi Kickstart Installation funktioniert nicht.

Beitragvon dani196 » 04.08.2016, 13:41

Mit einer Kickstart-Datei soll ESXi6.0 auf einem HP ProLiant DL380 Gen9 installiert werden.

Das System wird dabei auf einen USB-Stick, der im Server steckt eingerichtet.
Das System läuft soweit, bis die Installation beginnt und dann kommt die Meldung, dass die Partition nicht initialisiert ist. Liegt das jetzt am Server, am USB-Stick oder am Kickstartfile?

Der Versuch mit SSH auf den Stick zuzugreifen und eine Partition zu erstellen war auch nicht erfolgreich, da nicht darauf zugegriffen werden kann.

Das Merkwürdige ist, dass die Installation auf dem USB-Stick manuell funktioniert. Wenn ich es mit einem anderen USB-Stick getestet habe, gelingt sogar die Kickstart-Installation. Das Skript ist also höchstwahrscheinlich nicht das Problem. :?

Guru
Beiträge: 2790
Registriert: 27.12.2004, 22:17

Re: ESXi Kickstart Installation funktioniert nicht.

Beitragvon rprengel » 04.08.2016, 13:51

dani196 hat geschrieben:Mit einer Kickstart-Datei soll ESXi6.0 auf einem HP ProLiant DL380 Gen9 installiert werden.

Das System wird dabei auf einen USB-Stick, der im Server steckt eingerichtet.
Das System läuft soweit, bis die Installation beginnt und dann kommt die Meldung, dass die Partition nicht initialisiert ist. Liegt das jetzt am Server, am USB-Stick oder am Kickstartfile?

Der Versuch mit SSH auf den Stick zuzugreifen und eine Partition zu erstellen war auch nicht erfolgreich, da nicht darauf zugegriffen werden kann.

Das Merkwürdige ist, dass die Installation auf dem USB-Stick manuell funktioniert. Wenn ich es mit einem anderen USB-Stick getestet habe, gelingt sogar die Kickstart-Installation. Das Skript ist also höchstwahrscheinlich nicht das Problem. :?


Hallo,
dann vergleich doch mal in einem Linux-System ob die Sticks sich gleich verhalten.
Passiert das auch wenn der Stick komplett leer, also z.B. mit dd komplett platt gemacht wurde?
Gruss

Member
Beiträge: 5
Registriert: 04.08.2016, 11:46

Beitragvon dani196 » 05.08.2016, 10:40

Also wenn ich den USB-Stick, mit dem die Kickstartinstallation funktioniert hat einstecke, dann werden mir drei Partitionen angezeigt. Sieht so aus als wäre das ESXi.

Auf dem anderen USB-Stick mit dem die Kickstartinstallation nicht funkionert hat, zeigt es mit nur ein paar Textdokumente an. Die Partition hat dann den Namen VFS, falls das was hilft...

Gruß und Danke schon mal

Guru
Beiträge: 2790
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 05.08.2016, 11:26

dani196 hat geschrieben:Also wenn ich den USB-Stick, mit dem die Kickstartinstallation funktioniert hat einstecke, dann werden mir drei Partitionen angezeigt. Sieht so aus als wäre das ESXi.

Auf dem anderen USB-Stick mit dem die Kickstartinstallation nicht funkionert hat, zeigt es mit nur ein paar Textdokumente an. Die Partition hat dann den Namen VFS, falls das was hilft...

Gruß und Danke schon mal


Mach den Stick mal richtig platt.

Gruss

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 05.08.2016, 11:46

Funktioniert denn ein neuerliches Deployment auf den eingerichteten Stick?
Ist das derselbe Typ wie der, der nicht funktioniert? Falls nicht: Was unterscheidet die beiden?

Ach ja:
Um das Kickstart-File beurteilen zu koennen waere es hilfreich, dieses hier zu posten ;-).

Member
Beiträge: 5
Registriert: 04.08.2016, 11:46

Beitragvon dani196 » 11.08.2016, 07:32

Hier ist mal das Kickstartskript:

#accepted the EXSi license agreement
vmaccepteula

#clear the partition on the set drive
clearpart --alldrives --overwritevmfs

#install ESXi on the target path
installorupgrade --drive=mpx.vmhba32:C0:T0:L0 --overwritevmfs

#the german keyboartype is determined
keyboard German

#set the password
rootpw hallo

#network settings
network --bootproto=static --device=vmnic0 --ip=192.168.0.50 --gateway=192.168.0.11 --nameserver=192.168.0.11 --netmask=255.255.0.0 --addvmportgroup=0

#licence number
vmserialnum --esx=H5021-0U245-J8180-0C82P-8RA60

reboot

Member
Beiträge: 5
Registriert: 04.08.2016, 11:46

Beitragvon dani196 » 11.08.2016, 07:53

JustMe hat geschrieben:Funktioniert denn ein neuerliches Deployment auf den eingerichteten Stick?
Ist das derselbe Typ wie der, der nicht funktioniert? Falls nicht: Was unterscheidet die beiden?

Ach ja:
Um das Kickstart-File beurteilen zu koennen waere es hilfreich, dieses hier zu posten ;-).


Der USB Stick, mit dem es Funktioniert ist ein einfacher Stick(Werbegeschenk) :lol: , der USB Stick, mit dem es nicht funkioniert, ist ein HP Dual 8 GB microSD-Enterprise-Midline-USB-Kit(741279-B21).

Guru
Beiträge: 2790
Registriert: 27.12.2004, 22:17

Beitragvon rprengel » 11.08.2016, 08:01

dani196 hat geschrieben:
JustMe hat geschrieben:Funktioniert denn ein neuerliches Deployment auf den eingerichteten Stick?
Ist das derselbe Typ wie der, der nicht funktioniert? Falls nicht: Was unterscheidet die beiden?

Ach ja:
Um das Kickstart-File beurteilen zu koennen waere es hilfreich, dieses hier zu posten ;-).


Der USB Stick, mit dem es Funktioniert ist ein einfacher Stick(Werbegeschenk) :lol: , der USB Stick, mit dem es nicht funkioniert, ist ein HP Dual 8 GB microSD-Enterprise-Midline-USB-Kit(741279-B21).


Hallo,
es gibt da einige Unterschiede im Thema USB-Sticks.
z.B.
http://www.borncity.com/blog/2015/12/29 ... angezeigt/
Lange Rede kurzer Sinn:
Besorg dir einen Stick der es tut und fertig.

Gruss

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Beitragvon JustMe » 11.08.2016, 10:08

OK, gegen das Skript habe ich erst einmal keine Einwaende :-)

Und leider auch keinen HP(E) Server zum Pruefen, ob eine solche "Dual Micro SD" tatsaechlich wie ein USB-Stick unter mpx:vmhba32 im ESXi auftaucht.

SD-Karten haben ja manchmal auch einen Schreibschutz-Schalter (SW/HW)...

Member
Beiträge: 5
Registriert: 04.08.2016, 11:46

Beitragvon dani196 » 11.08.2016, 11:19

JustMe hat geschrieben:OK, gegen das Skript habe ich erst einmal keine Einwaende :-)

Und leider auch keinen HP(E) Server zum Pruefen, ob eine solche "Dual Micro SD" tatsaechlich wie ein USB-Stick unter mpx:vmhba32 im ESXi auftaucht.

SD-Karten haben ja manchmal auch einen Schreibschutz-Schalter (SW/HW)...


Also die SD-Karte hat keinen Schalter ;-) sonst würde denke ich das manuelle Instalieren auch nicht funktionieren...

Die Dual Micro SD taucht als mpx:vmhba32 auf, aber darauf zugreifen kann man nicht!


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast