Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Jumbo Frames, MTU=9000

ESX(i)-taugliche Hardware, HCL .....

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 41
Registriert: 20.04.2009, 00:04

Jumbo Frames, MTU=9000

Beitragvon transporter » 31.01.2012, 10:24

hallo zusammen,

ich habe auf unserem nfs die mtu der e1000 karten auf 9000 gesetzt. parallel dazu habe ich noch bge karten mit mtu=1500 auf dem nfs, d.h. ich könnte hin und her schalten. vswitch und vmkernel zum nfs sind auch auf 9000 (eigene e1000).

jetzt meine frage: womit kann ich das sinnvoll testen, ob das unterschiedlich schnell ist, oder ob wirklich mtu=9000 ankommt??

Member
Beiträge: 184
Registriert: 02.06.2010, 18:07

Beitragvon djbreezer » 31.01.2012, 11:31


Member
Beiträge: 41
Registriert: 20.04.2009, 00:04

Beitragvon transporter » 31.01.2012, 15:05

also wenn ich so eine anzeige bekomme, heisst das mit den jumbo frames ist alles ok?

~ # vmkping -s 9000 10.0.07.11
PING 10.0.07.11 (10.0.7.11): 9000 data bytes
9008 bytes from 10.0.7.11: icmp_seq=0 ttl=255 time=0.952 ms
9008 bytes from 10.0.7.11: icmp_seq=1 ttl=255 time=0.952 ms
9008 bytes from 10.0.7.11: icmp_seq=2 ttl=255 time=0.983 ms

--- 10.0.07.11 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.952/0.962/0.983 ms
~ #

Member
Beiträge: 184
Registriert: 02.06.2010, 18:07

Beitragvon djbreezer » 31.01.2012, 18:19

transporter hat geschrieben:also wenn ich so eine anzeige bekomme, heisst das mit den jumbo frames ist alles ok?

~ # vmkping -s 9000 10.0.07.11
PING 10.0.07.11 (10.0.7.11): 9000 data bytes
9008 bytes from 10.0.7.11: icmp_seq=0 ttl=255 time=0.952 ms
9008 bytes from 10.0.7.11: icmp_seq=1 ttl=255 time=0.952 ms
9008 bytes from 10.0.7.11: icmp_seq=2 ttl=255 time=0.983 ms

--- 10.0.07.11 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.952/0.962/0.983 ms
~ #


Ajo... der Packete gehen durch.

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 31.01.2012, 18:32

Hmmm da war noch was... die sollen nicht nur durchgehen sondern auch unfragmentiert durchgehen...

Probier mal

vmkping -s 9000 -d 10.0.07.11

Member
Beiträge: 41
Registriert: 20.04.2009, 00:04

Beitragvon transporter » 01.02.2012, 08:21

danke, mit dem -d kommt was anderes raus:

Code: Alles auswählen

~ # vmkping -s 8972 -d 10.0.7.11
PING 10.0.7.11 (10.0.7.11): 8972 data bytes
8980 bytes from 10.0.7.11: icmp_seq=0 ttl=255 time=0.944 ms
8980 bytes from 10.0.7.11: icmp_seq=1 ttl=255 time=0.838 ms
8980 bytes from 10.0.7.11: icmp_seq=2 ttl=255 time=0.957 ms

--- 10.0.7.11 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.838/0.913/0.957 ms
~ # vmkping -s 8973 -d 10.0.7.11
PING 10.0.7.11 (10.0.7.11): 8973 data bytes
sendto() failed (Message too long)
sendto() failed (Message too long)
sendto() failed (Message too long)

--- 10.0.7.11 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
~ #


ist das dann so richtig mit den 8972/8980 bei mtu=9000?

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 02.02.2012, 17:21

Laut dem verlinkten Artikel weiter oben sollten 9000 bytes große Jumbos durchgehen wenn 8784 bytes große vmkpings durchgehen... das sollte also passen. 8972 ist ja größer als 8784.


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast