Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Welcher SATA-RAID Controller für ESXi 4.1 / 5

ESX(i)-taugliche Hardware, HCL .....

Moderatoren: irix, continuum, Dayworker

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Welcher SATA-RAID Controller für ESXi 4.1 / 5

Beitragvon twj64 » 06.11.2011, 12:40

Hallo zusammen,

ich versuche auf einem Supermicro Board X7DBE mit 2 x 2GHz Xeon E5404 und 16 GB RAM ein RAID zum Laufen zu bringen.
Der interne Controller erkennt die 6 SATA-Platten nicht als RAID, sondern nur als einzelne Platten.
Der Versuch mit einem 3WARE 9550-SX 8LP Controller scheiter auch, da dieser nur als 2. Controller nach diversen Patches läuft.
Die Installation auf einen 2GB oder 4 GB USB sStick scheitert auch, da dort der Platz für das Storage nicht ausreicht und das 3WARE-Raid gemäß diversen Hinweisen im Netz erst nach der Installation für einen Datastore erkannt werden soll.

Somit denke ich über die Anschaffung eines 8Port-SATA-Controllers nach, auf dem dann auch das OS untergebracht werden kann.
Welche Controller könnt ihr mir empfehlen? :?: :?:


Für Hinweise danke ich euch vorab und wünsche allen noch einen schönen Sonntag.

King of the Hill
Beiträge: 12187
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 06.11.2011, 12:51

1. Installiert den ESXi auf den Stick und dann fuege spaeter den Driver fuer deinen RAID Controller hinzu. Genau so wie es in der Doku steht. Wo ist denn da das Problem?
2. Du koenntest die Treiber versuchen in das Installationsimage zufrickeln so das der Controller gleich bei der Installation supportet wird.
3. In der Tat einen anderen Kontroller kaufen.

Gruss
Joerg

Experte
Beiträge: 1188
Registriert: 08.11.2005, 13:08
Wohnort: bei Berlin

Beitragvon e-e-e » 06.11.2011, 12:54


Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Beitragvon twj64 » 06.11.2011, 12:59

irix hat geschrieben:1. Installiert den ESXi auf den Stick und dann fuege spaeter den Driver fuer deinen RAID Controller hinzu. Genau so wie es in der Doku steht. Wo ist denn da das Problem?
2. Du koenntest die Treiber versuchen in das Installationsimage zufrickeln so das der Controller gleich bei der Installation supportet wird.
3. In der Tat einen anderen Kontroller kaufen.

Gruss
Joerg


Hallo Joerg,

genau darauf (neu kaufen) bezog sich ja meine Frage? Was würdet Ihr für einen Controller empfehlen?

Ich habe versucht die INstallation auf einer 16 GB SD-Karte durchzuführen, die mittels USB-Adapter am System hängt. Leider gibt es immer eine Fehlermeldung, dass die Formatierung nicht durchgeführt werden kann, einen 16 GB Stick habe ich aber auch nicht. :(

King of the Hill
Beiträge: 12187
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 06.11.2011, 13:06

Probiere mal einen normalen USB Stick. Mehr als 2 GB brauchen es auch nicht sein.

Gruss
Joerg

Member
Beiträge: 41
Registriert: 20.04.2009, 00:04

Beitragvon transporter » 06.11.2011, 14:22

versuch mal das tool:

http://v-front.blogspot.com/p/esxi-customizer.html

damit kannst du treiber ins image einbauen. selber habe ich das aber nur mit esxi5 gemacht.

der vorschlag von e-e-e mit dem napp-it ist aber auch nicht schlecht, wenn du den onboard-ICH als passthrough verwenden kannst.

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Welcher SATA-RAID Controller für ESXi 4.1 / 5

Beitragvon twj64 » 06.11.2011, 15:49

Hallo,

danke für die Hinweise, aber im Netz habe ich nur die Hinweise gefunden, dass der 3WARE 9550-SX nur als 2. Controller für ein Datastorage einsetzbar ist.

Es soll aber möglichst alles auf einem RAID-Array untergebracht werden, von daher würde mich ja interessieren, welche Controller die Fachgemeinde ;) für diesen Zweck empfehlen würde :?:

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Beitragvon twj64 » 06.11.2011, 15:56

irix hat geschrieben:Probiere mal einen normalen USB Stick. Mehr als 2 GB brauchen es auch nicht sein.

Gruss
Joerg


Hallo Jörg,

versuche gerade ESX4.1 auf einen 4 GB USB Stick zu installieren.
Bei der Installation wird mir als Setup-Type das Standard Setup oder das Advanced Setup angeboten.
Beim Standard Setup kommt die Meldung, dass mind. 10 GB für die Installation notwendig seien,gleiches gilt für das Advanced Setup.
Ich verwende ESX 4.1U1 - gibt es evtl. ein anderes Setup?

By the way, bei der Installation ist der Treiber für den 9550 schon geladen worden, benötigt aber bekanntermaßen ja noch den Patch zum späteren Zeitpunkt.

Benutzeravatar
Member
Beiträge: 80
Registriert: 23.09.2007, 14:10

Beitragvon XP-Fan » 06.11.2011, 16:00

Hi,

du sprichst einmal von ESXi und einmal von ESX. Was willst du nun installieren ?

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Beitragvon twj64 » 06.11.2011, 16:03

XP-Fan hat geschrieben:Hi,

du sprichst einmal von ESXi und einmal von ESX. Was willst du nun installieren ?


Planmäßig den ESXi, aber solange die Lizenz noch nicht eingespielt ist, ist der doch für max. 30 Tage immer ein ESX :?: oder bin ich da auf dem falschen Dampfer?

BBisher habe ich immer geglaubt, dass das Installationsmedium das selbe ist?!

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 06.11.2011, 16:22

ESX und ESXi haben unterschiedliche Installationsmedien.

Ihr Funktionsumfang hängt jeweils von der installierten Lizenz ab.

Beide laufen ohne Lizenz 60 Tage mit allen Features von Enterprise Plus.

Für ESXi gibt es eine kostenlose Lizenz mit reduziertem Funktionsumfang.

Bei vSphere 5 gibt es keinen ESX mehr sondern nur noch den ESXi.

Experte
Beiträge: 1188
Registriert: 08.11.2005, 13:08
Wohnort: bei Berlin

Beitragvon e-e-e » 06.11.2011, 16:24

twj64 hat geschrieben:
XP-Fan hat geschrieben:Hi,

du sprichst einmal von ESXi und einmal von ESX. Was willst du nun installieren ?


Planmäßig den ESXi, aber solange die Lizenz noch nicht eingespielt ist, ist der doch für max. 30 Tage immer ein ESX :?: oder bin ich da auf dem falschen Dampfer?!


... aber sowas von total!
Das sind zwei unterschiedliche Produkte, die bis jetzt parallel liefen und der ESX wird nun eingestellt. Du hast z.Zt. anscheinend den kostenfreien (puren) vSphere Hypervisor (ESXi 4/5), den du durch eine kostenpflichtige Lizenz aufrüsten kannst (immer noch ESXi 4/5).

Du kannst den ESXi auf einen USB-Stick ab 1 GB Größe installieren und dann die HDDs als Datastores für die VMs verwenden.

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Beitragvon twj64 » 06.11.2011, 16:25

mbreidenbach hat geschrieben:ESX und ESXi haben unterschiedliche Installationsmedien.

Ihr Funktionsumfang hängt jeweils von der installierten Lizenz ab.

Beide laufen ohne Lizenz 60 Tage mit allen Features von Enterprise Plus.

Für ESXi gibt es eine kostenlose Lizenz mit reduziertem Funktionsumfang.

Bei vSphere 5 gibt es keinen ESX mehr sondern nur noch den ESXi.


Ja, das meinte ich ja mit meiner obigen Aussage. Der Funktionsumfang ist doch von der Lizenz-Nr. abhängig.

Experte
Beiträge: 1004
Registriert: 30.10.2004, 12:41

Beitragvon mbreidenbach » 06.11.2011, 19:11

Schon aber ESX und ESXi sind zwei unterschiedliche Produkte mit völlig anderem internen Aufbau. Es ist nicht möglich nur durch eine andere Lizenz aus einem ESX einen ESXi oder umgekehrt zu machen. Bei vSphere 4 erfordert das Neuinstallation. ESXi 5 kann als Update von ESX 4 installiert werden (wobei der ESX 4 von der Platte entfernt und auf dem freigewordenen Platz der ESXi 5 installiert wird).

Ein ESX mit beispielsweise Standard Lizenz kann das Gleiche wie ein ESXi mit Standard Lizenz (wenn man mal von den architekturbedingten Unterschieden absieht)

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Beitragvon twj64 » 06.11.2011, 19:38

Hallo Jungs (und evtl. Mädels????),

einstweilen danke für die Infos - hatte tatsächlich das falsche Image für die Installation verwendet.
Versuche jetzt die Installation mit dem richtigen Image und werde euch auf dem laufenden halten.
Bin aber trotzdem weiter für Empfehlungen für einen SATA-Raid-Controller mit 8Ports dankbar. :oops:

Schönen Sonntag Abend noch

Benutzeravatar
Member
Beiträge: 80
Registriert: 15.05.2007, 15:41
Wohnort: Sprockitown

Feedback

Beitragvon twj64 » 12.11.2011, 12:48

Hallo zusammen,

ich wollte mich nochmals für die Hilfe bedanken und ein kurzes Feedback geben. :oops:

Problem 1: Booten vom USB-Stick ging nicht: Gelöst durch neues BIOS 2.1c vom Support von Supermicro. 8)

Problem 2: Habe tatsächlich ein falsches Installationsmedium (ESX) benutzt. Lösung: richtiges Image heruntergeladen, Installation funzt. 8)

Problem 3: SATA-Controller - Habe mir einen PERC 5/i 8-Port SAS/SATA Raidcontroller von Dell für kleines Geld gekauft und siehe da - dIe Installation läuft auf Anhieb.

Somit rennt der Server nun wie er soll.


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste