Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Teilweise langsames iSCSI

ESX(i)-taugliche Hardware, HCL .....

Moderatoren: irix, continuum, Dayworker

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Teilweise langsames iSCSI

Beitragvon JWPCNet » 25.05.2010, 19:54

Hallo,

ich habe das Problem, das beim Backup mehrerer VMs von 2 ESX 4 Hosts auf ein iSCSI Target die Verbindung sehr langsam ist. Als Backupsoftware nutze ich VM Explorer von Trilead. Zuerst war das iSCSI Target (Buffalo TeraStation III) direkt als Datastore im ESX angebunden. Da liegt die Datenübertragungsrate bei nur 5-10 MB/s. Nun habe ich das iSCSI Target an dem Server angebunden, wo auch der VM Explorer läuft. Da Backup startet mit über 50 MB/s und kopiert ca 1,8GB, dann fällt die Rate auf 0,5MB/s. Die VMDK hat 10GB, zum Ende startet er dann noch einmal durch und kopiert die letzten 1,5GB wieder mit hoher Geschwindigkeit.
Es ist kein Problem von VMware oder VM Explorer, da auch das Kopieren unter Windows mit Total Commander den selben Performanceverlauf zeigt.
Dann hab ich das iSCSI Target an einen anderen Server gehängt, selber Verlauf. Virenscanner auch deinstalliert.
Kopiere ich über LAN Daten zwischen den Servern, läuft es mit konstanter Geschwindigkeit.

Kann mir jemand einen Tip geben, wo es bei der Anbindung eines iSCSI Targets unter Windows 2003 zu derartigen Performanceproblemen kommen kann?

Guru
Beiträge: 2082
Registriert: 21.10.2006, 08:24

Beitragvon bla!zilla » 25.05.2010, 20:27

Das kann viele Gründe haben.

- Netzwerk (z.B. keine Unterstützung für Jumbo Frames, Netzwerkkarten etc.)
- Storagesystem selber
- zu wenig Disks

Wie sieht deine Umgebung genau aus?

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Beitragvon JWPCNet » 25.05.2010, 20:38

danke für die schnelle Antwort. Jumboframes sind nicht aktiv, soweit ich das beurteilen kann. Am iSCSI Target ist Framegrösse auf 1.518 Byte.

Umgebung ist:
2x ESX 4.0 U1
1x Buffalo TeraStation III iSCSI (4 Platten RAID5, 1x 1,3TB Targets)
1x Windows Server 2003, IBM Server, vCenter Server

Welche Informationen können noch hilfreich sein ?

Guru
Beiträge: 2082
Registriert: 21.10.2006, 08:24

Beitragvon bla!zilla » 25.05.2010, 21:59

Uhhh, also ich glaube die TeraStation wird nicht gerade eine Rakete sein. Hast du mal mit einem NFS Datastore experimentiert? Ich glaube eher, dass die TeraStation einfach nicht mehr schafft.

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Beitragvon JWPCNet » 25.05.2010, 22:10

Na 50 MB/s ist ja schon sehr gut, aber nach 1,8GB sinkt die Rate auf 0,5 MB/s. Das ist das was ich nicht nachvollziehen kann.

Guru
Beiträge: 2082
Registriert: 21.10.2006, 08:24

Beitragvon bla!zilla » 27.05.2010, 09:50

Das klingt für mich nach Cache-Effekten.

Benutzeravatar
Guru
Beiträge: 3129
Registriert: 22.02.2008, 20:01
Wohnort: Hessen

Beitragvon PeterDA » 27.05.2010, 11:28

Hi,
würde wie bla!zilla auch auf ein Caching Problem tippen. Es ist allerdings die Frage auf welcher Seite die Bremse gezogen wird auf Host- oder Storageseite.


Gruß Peter

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Beitragvon JWPCNet » 27.05.2010, 12:04

Hallo, danke für die Antworten. Ich habe eben mal meine 10GB VMDK von dem IBM Server auf einen identischen Server kopiert. Das geht ohne Probleme und läuft laut Totalcommander mit 35-60MB/s. An Buffalo habe ich eine Supportmail geschrieben mit der Bitte, mir mitzuteilen, wie viel RAM das Gerät hat. Meine Server haben 4GB. Da der Transfer untereinander funktioniert, denke ich das es eher an der Buffalo TeraStation liegt.

Interessant ist auch, das der Taskmanager beim kopieren auf das iSCSI Target durchgehend eine Last von ca 10% auf der LAN Schnittstelle hat, auch wenn die Transferrate von 30-50MB/s auf 0,5MB/s fällt.

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 27.05.2010, 15:48

Ich würd mal sagen, daß die Terastation der Übeltäter ist. Nur 50MB/s für ein Raid5 sind in meinen Augen nur ein lahmer Gaul.
Witzigerweise wird die Terastation III iSCSI TS-IXLR5 / TS-RIXLR5 beschrieben mit TeraStation III iSCSI is a high-availability and high performance RAID enabled iSCSI storage system providing four hot swap hard drives with exceptional performance and redundancy for a SAN. TeraStation III iSCSI is Buffalo’s fastest iSCSI file server and is available in pedestal or 1U rack mount form factors.

Bist du dir sicher, daß das Teil überhaupt von VMware zertifiziert wurde? Normalerweise steht sowas auch immer auf der Webseite oder in den Produkt-PDFs.

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Beitragvon JWPCNet » 27.05.2010, 15:58

Na als iSCSI Target läuft es unter dem ESX, allerdings läuft dann das Backup über VM Explorer mit nur ca 10MB/s. Der Download einer VM auf den Windows Server ausserhalb des ESX Hostes läuft mit 30-50MB/s. Also habe ich das iSCSI an den Windows 2003 Server angeschlossen und dort einen NFS Server installiert. Über diesen kann dann der ESX zur Not mit dem Umweg über den Windows NFS Server auf das iSCSI.

Das iSCSI ist nur als Backup Storeage gedacht und um evtl. eine VM von dort zu starten, mit dem Bewusstsein dass es nur mangelnde Performance bietet.

An einer Win XP Workstation läuft das Buffalo iSCSI Target ohne Probleme, allerdings nur mit 15MB/s. Aber ich möchte es an dem Server betreiben, wo auch der VM Explorer läuft.

Netzwerkmässig ist alles mit Gigabit ausgestattet, also Transferraten von 20-30MB/s sollten möglich sein. Das würde mir schon reichen, dieser Fall auf 0,5MB/s allerdings nicht.

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 27.05.2010, 16:10

Mal so nebenbei, ist die von mir beschriebene überhaupt eure?
Ich frag nur deshalb, weil ich grad eine Beschreibung dazu gefunden hatte und in der stand was von internen Sata150-Anschlüssen. Dazu steht, daß die neben Raid 0, 1, 5, 10 auch 92MB/s an Datenrate schafft und für den Entry- bis Middle-Businessbereich konzipiert wurde.
Wenn du natürlich die Terastation noch über 2 Umsetzpunkte einbindest, kommt logischerweise hinten nichts groß raus und bei 20-30MB/s Datenrate könntest du die ja fast noch per USB2 einbinden...

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Beitragvon JWPCNet » 27.05.2010, 16:22

Es ist eien TeraStation III iSCSI Rackmount TS-RIXLR5, sie hat nur SATA Platten. Soll in erster Linie auch nur als Backup dienen. Wenn man aber nur mit 10MB/s sichern kann, dann wird es schwer über Nacht mehrere Server zu sichern. Der VMX ist da halt etwas eingeschränkt, oder VMware begrenzt da irgendwo. Da aber der Download ESX Host --> Windows Server mit 30-50MB/s läuft und der Transfer ESX Host --> im ESX Host angeschlossenes iSCSI Datastore nur mit 10MB/s läuft, suche ich nach einer Alternative, die ich mit dem NFS gefunden habe, weil da Windows und der ESX zugreiffen können.

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 27.05.2010, 16:48

Wenn du sowieso ein extra Gerät dafür nehmen willst, könntest du auch ein NFS unter Linux mit ZFS aufbauen. Das wäre von der Performance in jedem Fall schneller und auch von den laufenden Kosten (Energie, ggf. Rackplatz) vergleichbar.

Benutzeravatar
Member
Beiträge: 55
Registriert: 22.05.2008, 15:08
Kontaktdaten:

Beitragvon JWPCNet » 28.05.2010, 16:11

Nun hab ich mal etwas weiter getestet:
1. von einem virtuellen Win2003 Server SP2, selber Problem
2. von einem virtuellen Win2008 R2 x64 Server, alles gut, 30-30MB/s, 10GB in 4 Minuten kopiert

Ich denke das Problem ist die Kombination... 2003 wird auch langsam alt.

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 28.05.2010, 20:01

In der Virtualisierung sind ältere Gast-OS aber meist besser, da diese sich noch mit weniger Ressourcen zufrieden geben.
Ich würds an deiner Stelle wirklich mal mit einem Linux mit ZFS versuchen. Inwieweit Solaris als Entwickler des ZFS dich da mit seinen Distri's Solaris bzw OpenSolaris vorwärts bringt, mußt du dir selbst beantworten. Aber andere Distributionen haben das ZFS ja inzwischen auch integriert. ;)


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast