Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Snapshot: File not found: xyz.vmdk

ESX(i)-taugliche Hardware, HCL .....

Moderatoren: irix, Dayworker

Member
Beiträge: 5
Registriert: 18.02.2013, 13:27

Snapshot: File not found: xyz.vmdk

Beitragvon AlexBierig » 16.12.2022, 03:09

Hallo
ich muss das Thema von 2015 nochmals aufgreifen, da ich keine Lösung daraus ableiten konnte.
Ich verwende Snapshots, um bei Installationen oder Neukonfigurationen einer VMWare Fehler zu korrigieren können (durch zurücksetzen)
Das eigentlich Backup ist dann einfach eine Ordnerkopie auf eine Platte (dauert halt etwas bei 200-300GB Grösse)

Ich habe einen Server 2016 unter VMWare 16 erstellt. Dieser Server soll der neue DC im virtuellen Netz werden. Der Umzug von Server 2008r2 hat auch geklappt.
Nachdem Umzu habe ich einenSnapshot (Nr 2) erstellt und den gesamten Ordner der VM weg kopiert. Weitere Snapshot liesen sich nicht mehr erstellen, da angeblich ein File (nicht vermeldet welches) fehle
Daher habe ich die fehlerhafte VM weggeworfen und den Ordner mit dem Snapshot 2 zurückgeholt.
Jedoch vermeldet VMWare beim Start
vmdk7notfound.png
vmdk7notfound.png (8.07 KiB) 192 mal betrachtet

das File ist vorhanden, man kann es auswählen und öffnen
browsevmdk.png

Dann läuft die VM an. Ab und zu crasht sie aber beim Start und öffnet den Bootmanager. Es genügt diesen einfach per ESC in der VM anzuschucken und das System läuft.
Es lassen sich dafür Snapshots erstellen. Das Erstellen braucht sehr lange.

Ich habe das Logfile als Zip angehängt.

Grüsse
Alex. Bierig
vmware.log.zip
(23.76 KiB) 17-mal heruntergeladen

Experte
Beiträge: 1813
Registriert: 04.10.2011, 14:06

Re: Snapshot: File not found: xyz.vmdk

Beitragvon JustMe » 16.12.2022, 09:18

Na super...
viele Snapshots, und dann auch noch eine ge-"slice"-te vmdk...
Deine "newmailer-000007.vmdk" (also der siebte oder so Snapshot davon) besteht nicht nur aus dieser einen kleinen Beschreibungsdatei, sondern aus allen den *-00007-s??.vmdk, und evtl. fehlt davon eine (oder ist irgendwie gesperrt, z.B. vom Virenscanner), was dann die Fehlermeldung triggert.

Wie ~thc im anderen Thread bereits anmerkte: Keine gute Idee, nicht anzuraten, und schon gar nicht Best Practice.

Eher zu empfehlen waere, die VM vor einem Test oder einer Installation OHNE Snapshot im ausgeschalteten Zustand wegzukopieren, dann die Aenderungen "live" vorzunehmen, und wenn das gut funktioniert, nach einiger Zeit die kopierten Dateien einfach loeschen. Wenn's nicht funktioniert, dann eben die "aktuellen" Dateien loeschen, und die kopierten wieder in den VM-Ordner bringen.


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste