Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Erstellen von VMFS auf Dot Hill SAN nicht möglich

ESX(i)-taugliche Hardware, HCL .....

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 4
Registriert: 27.02.2019, 16:53

Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon control » 28.02.2019, 15:15

Hallo,

ich habe das Problem, dass es mir nicht möglich ist den Datenspeicher eines Dot Hill SAN einem ESXi 6.5 Server zur Verfügung zu stellen.
Die momentane Konstellation sieht wie folgt aus:

1x TERRA SAN 3720 (Hardware von Dot Hill) und 9 SAS Festplatten:
    - 2x RAID Controller mit jeweils 2 Fibre Channel Ports
    - 2x RAID 10 aus jeweils 4 Festplatten (+1 global Hotspare)
    - RAIDar Storage Management Utitlity

1x TERRA SERVER 7230 G1 E5-2603:
    - 2x CPU Intel XEON E5-2609/4x 2.4 GHz/6.4GT/s/10 MB
    - 1x QLOGIC HBA QLE2562-CK 2K Fibre 8Gbit PCIe x4 OEM
    (beide mit der aktueller, laut VMware von ESXi 6.5 unterstützten, BIOS Version R02.06.007)
    - ESXi 6.5.0 (Build 4887370)

Auf dem SAN ist die neueste, über die Treiberdatenbank des Herstellers bezogene, Firmware TS252P006 installiert.
Dort habe ich wie beschrieben 2 RAID 10 und darin wiederum ein Volume erstellt.
Auf dem HBA habe ich die aktuelle Firmware Version 8.08.01 installiert.
Der ESXi Server ist direkt per Fibre Channel mit dem SAN verbunden.
Die erstellten Volumes auf dem SAN werden per Default allen FC-Ports mit Read/Write-Berechtigung zugewiesen.

Die Volumes des SAN werden korrekt im ESXi angezeigt.
Versuche ich ein VMFS Datastore auf einem der beiden Volumes zu erstellen arbeitet das ESXi eine Zeit lang bis folgende Meldung kommt:
Erstellung von VMFS-DAtenspeicher [Datenspeichername] fehlgeschlagen - Die Hostkonfiguration kann nicht geändert werden.


Testweise habe ich auch schon ESXi 5.5 auf dem Blech installiert. Bei dem gibt es im vSphere Client eine ähnliche Meldung die wie folgt lautet:
Aufruf von "HostDatastoreSystem.CreateVmfsDatastore" für Objekt "ha-datastoresystem" auf ESXi "[IP-Adresse]" ist fehlgeschlagen.


Es ist dabei egal ob ich den Server mit einem einzelnen oder mit 2 Fibre Channel an das SAN anschließe.

Kennt sich jemand hier vielleicht mit Dot Hill Systemen (speziell 3000 Serie mit RAIDar Storage Management) aus und könnte helfen?

Jenseits von Gut & Böse
Beiträge: 11641
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon irix » 28.02.2019, 15:44

Entsprechend von https://www.vmware.com/resources/compat ... 4&vcl=true gucken das die Treiber und auch FW der HBAs denen auf der Liste entsprechen.

Sofern Zoning und ACL wirklich passen..... beim Rescan auf dem ESX bzw. deinem Versuch einen Datastore anzulegen mal die passenden Zeilen aus dem vmkernel.log hier posten.

Edit: Wenn man einen DotHill vSphere Best Practice Guide befragt kann man sehen das eine Custom Claim Rule angelegt werden sollte. Ob das natuerlich fuer dein Storage Modell ist muesste man pruefen. Was sagt denn das Systemhaus zum Thema?


Gruss
Joerg

Member
Beiträge: 4
Registriert: 27.02.2019, 16:53

Re: Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon control » 01.03.2019, 15:53

irix hat geschrieben:Entsprechend von https://www.vmware.com/resources/compat ... 4&vcl=true gucken das die Treiber und auch FW der HBAs denen auf der Liste entsprechen.

Sofern Zoning und ACL wirklich passen..... beim Rescan auf dem ESX bzw. deinem Versuch einen Datastore anzulegen mal die passenden Zeilen aus dem vmkernel.log hier posten.


Installiert ist jetzt die im Compatibility Guide für ESXi 6.5 angebene Treiberversion qlnativefc 1.1.7.0-1. Server habe ich danach neu gestartet.
Der Fehler tritt weiterhin auf. Hier einmal die Einträge im vmkernel Log beim Versuch nach der Treiberinstallation.

Code: Alles auswählen

2019-03-01T15:42:00.427Z cpu1:66097)NMP: nmp_ThrottleLogForDevice:3617: Cmd 0x2a (0x439d00781500, 67833) to dev "naa.600c0ff00011eb1b1d5b405c01000000" on path "vmhba2:C0:T0:L0" Failed: H:0x2 D:0x0 P:0x0 Invalid sense data: 0x0 0x0 0x0. Act:EVAL
2019-03-01T15:42:00.427Z cpu1:66097)WARNING: NMP: nmp_DeviceRequestFastDeviceProbe:237: NMP device "naa.600c0ff00011eb1b1d5b405c01000000" state in doubt; requested fast path state update...
2019-03-01T15:42:00.427Z cpu1:66097)ScsiDeviceIO: 2927: Cmd(0x439d00781500) 0x2a, CmdSN 0x3 from world 67833 to dev "naa.600c0ff00011eb1b1d5b405c01000000" failed H:0x2 D:0x0 P:0x0 Invalid sense data: 0x0 0x0 0x0.
2019-03-01T15:42:20.246Z cpu1:66097)NMP: nmp_ThrottleLogForDevice:3617: Cmd 0x2a (0x439d00781500, 67833) to dev "naa.600c0ff00011eb1b1d5b405c01000000" on path "vmhba2:C0:T0:L0" Failed: H:0x8 D:0x0 P:0x0 Invalid sense data: 0x0 0x0 0x0. Act:EVAL
2019-03-01T15:42:20.246Z cpu1:66097)WARNING: NMP: nmp_DeviceRequestFastDeviceProbe:237: NMP device "naa.600c0ff00011eb1b1d5b405c01000000" state in doubt; requested fast path state update...
2019-03-01T15:42:20.246Z cpu1:66097)ScsiDeviceIO: 2962: Cmd(0x439d00781500) 0x2a, CmdSN 0x3 from world 67833 to dev "naa.600c0ff00011eb1b1d5b405c01000000" failed H:0x8 D:0x0 P:0x0 Invalid sense data: 0x0 0x0 0x0.
2019-03-01T15:42:20.446Z cpu4:67833)BC: 2466: Failed to write (uncached) object 'naa.600c0ff00011eb1b1d5b405c01000000': Timeout


irix hat geschrieben:Edit: Wenn man einen DotHill vSphere Best Practice Guide befragt kann man sehen das eine Custom Claim Rule angelegt werden sollte. Ob das natuerlich fuer dein Storage Modell ist muesste man pruefen. Was sagt denn das Systemhaus zum Thema?


Gruss
Joerg

Ich habe ganz ehrlich keine Ahnung was eine Custom Claim Rule ist.
Ist das etwas seitens SAN oder ESXi? Bin ich hier schon auf dem richtig Pfad? https://pubs.vmware.com/vsphere-50/inde ... e.8.4.html

Member
Beiträge: 2
Registriert: 06.10.2016, 14:32

Re: Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon gurka » 02.03.2019, 23:41

imho wurde dieses dot hill/seagate san auch von hpe unter der bezeichnung msa p2000 g3 vertrieben (die firmware-bezeichnung ts252 ist sogar ident) , allerdings ist das p2000 g3 nur bis esxi 5.5 supported, das duerfte ja laut vmware hcl hier aber nicht das problem sein.
ich habe auch kunden die alte p2000 g3 fc (allerdings nicht direct-attached) mit 6.5 als spielwiese betreiben und das funktioniert ansich gut.

auf jeden fall ist https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c03473698 zu beachten, das steht auch so auf seite 131 im "AssuredSAN 3000 Series CLI Reference Guide" bei wortmann.

also "set advanced-settings missing-lun-response illegal" auf der cli von einem der management-controller (steht alles im guide) und host neu starten.

lg und viel glueck

Member
Beiträge: 4
Registriert: 27.02.2019, 16:53

Re: Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon control » 05.03.2019, 10:59

gurka hat geschrieben:imho wurde dieses dot hill/seagate san auch von hpe unter der bezeichnung msa p2000 g3 vertrieben (die firmware-bezeichnung ts252 ist sogar ident) , allerdings ist das p2000 g3 nur bis esxi 5.5 supported, das duerfte ja laut vmware hcl hier aber nicht das problem sein.
ich habe auch kunden die alte p2000 g3 fc (allerdings nicht direct-attached) mit 6.5 als spielwiese betreiben und das funktioniert ansich gut.

Zwischenzeitlich habe ich den Server mit ESXi 5.5 betankt. Damit ging es aber auch nicht (siehe meinen ersten Post).

gurka hat geschrieben:auf jeden fall ist https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c03473698 zu beachten, das steht auch so auf seite 131 im "AssuredSAN 3000 Series CLI Reference Guide" bei wortmann.

also "set advanced-settings missing-lun-response illegal" auf der cli von einem der management-controller (steht alles im guide) und host neu starten.

lg und viel glueck

"missing-lun-response illegal" habe ich schon seit längerem (mit ESXi 5.5 auch schon) eingestellt. Gab leider keine Besserung :(

Jenseits von Gut & Böse
Beiträge: 11641
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon irix » 05.03.2019, 11:58

Ich bezog mich auf den vSphere Bestpractice Guide von DotHill welcher eigentlich den Eindruck machte durchaus halbwegs aktuell zusein bzw. auch fuer dein Storage, allerdings konnte ich das "AssuredSAN " nicht zuordnen.

In dem Guide steht drin was zu tun ist und eine ClaimRule ist eine Anweisung fuer den ESXi um
- Nicht vorhandene Konfigurationsregeln nachzupflegen
- Die Defaultkonfig des Hosts auf dein Storage anzpassen damit es ueberhaupt mal funktioniert

Ansonsten muesste man mal mehr Logs sehen bzw. die passenden Sense Codes um einen Ansatz zu haben. Der ein oder andere Hersteller mag ja die Auslagerung des Dateilocking ueber VAAI doch nicht so gerne. Ein "Could not write" koennte ja auch so ausgelegt werden.

Ich wiederhole aber erstmal meine Frage.... warum fragst du nicht den Verkaeufer/Hersteller? Wenn man schon Support bezahlt sollte man den auch mal einfordern :)

Gruss
Joerg

Member
Beiträge: 4
Registriert: 27.02.2019, 16:53

Re: Erstellen von VMFS auf Dot Hill SAN nicht möglich

Beitragvon control » 18.03.2019, 12:21

irix hat geschrieben:Ich bezog mich auf den vSphere Bestpractice Guide von DotHill welcher eigentlich den Eindruck machte durchaus halbwegs aktuell zusein bzw. auch fuer dein Storage, allerdings konnte ich das "AssuredSAN " nicht zuordnen.

In dem Guide steht drin was zu tun ist und eine ClaimRule ist eine Anweisung fuer den ESXi um
- Nicht vorhandene Konfigurationsregeln nachzupflegen
- Die Defaultkonfig des Hosts auf dein Storage anzpassen damit es ueberhaupt mal funktioniert

Claim Rule habe ich jetzt erstellt (für den genutzten Port). Weiterhin der selbe Fehler.

irix hat geschrieben:Ansonsten muesste man mal mehr Logs sehen bzw. die passenden Sense Codes um einen Ansatz zu haben. Der ein oder andere Hersteller mag ja die Auslagerung des Dateilocking ueber VAAI doch nicht so gerne. Ein "Could not write" koennte ja auch so ausgelegt werden.

Ja DotHill und VMware sagen auch, dass bei der neuesten SAN-Firmware kein VAAI benutzt werden sollte.
Daher habe ich überprüft ob das VAAI Plugin installiert ist (ist es nicht) und alle damit verbundenen Optionen nach VMware Anleitung deaktiviert.

An Sense Codes bekomme ich beim Versuch ein VMFS zu erstellen:
H0x2 ("BUS_BUSY This status is returned when the HBA driver is unable to issue a command to the device. This status can occur due to dropped FCP frames in the environment.")

Und im Anschluss:
H0x8 ("RESET This status is returned when the HBA driver has aborted the I/O. It can also occur if the HBA does a reset of the target.")

D0x0 und P0x0

irix hat geschrieben:Ich wiederhole aber erstmal meine Frage.... warum fragst du nicht den Verkaeufer/Hersteller? Wenn man schon Support bezahlt sollte man den auch mal einfordern :)

Gruss
Joerg

Der Hersteller (und Verkäufer) Wortmann konnte uns nicht weiterhelfen. Der Experte von Wortmann schien sich leider aber auch nicht so gut damit auszukennen und das Problem dabei ist, dass es sich um Geräte von 2012 handelt. So wirklich Support gibt es dafür also auch nicht...


Zurück zu „Hardware“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast