Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.

Performanceprobleme

Moderatoren: Dayworker, continuum, Tschoergez, irix

Member
Beiträge: 11
Registriert: 03.04.2008, 16:46

Performanceprobleme

Beitragvon daniel2000 » 23.10.2012, 14:23

Hallo,
wir haben zurzeit auf einem
HP Proliant ML330 G6, 4x2,127 GhZ, 8 GB-Ram
ESXi 4.1.0, 348481 am Laufen.

Die VM's liegen auf einem HP Storage P2000

Auf dem Server laufen gleichzeitig 3 VM's
- Windows 2008 Server 64 bit (4GB Ram, 2 vCPU)
- XP Prof. 32bit (3GB Ram, 2 vCPU)
- Linux (256 MB Ram, 1vCPU)

Auf dem 2008 Server läuft unter einen Microsoft SQL-Datenbank.

Wird jetzt z.B. der XP Rechner neu gestartet, ist die Performance vom 2008er Server so schlecht, das die Clients die Datenbankverbindung verlieren. Ebenso ist es, wenn z.B. neue Software auf einem der Rechner installiert wird.
Also quasi immer dann, wenn einer der Rechner mal arbeiten muss, werden die anderen extrem ausgebremst.

Im vSphereClient und "Virtuelle Maschinen" kann man sehen, das die Auslastung des Arbeitsspeichers immer im grünen Bereich ist, ebenso die CPU-Auslastung.


Wo kann der Fehler liegen?


Gruß Daniel

Profi
Beiträge: 751
Registriert: 18.03.2005, 14:05
Wohnort: Ludwigshafen

Beitragvon Martin » 23.10.2012, 14:52

Mit dem RAM Overhead wird wahrscheinlich der Speicher für's ESX selbst etwas knapp. Kannst Du der 2008 oder XP VM mal testweise 1GB weniger geben?

Experte
Beiträge: 1860
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 23.10.2012, 15:17

Ich vermute eher die Storage-I/O-Vorgänge. Werden im Ereignisprotokoll des ESX in den fraglichen Zeiträumen große Storage-Latenzen gemeldet?

Member
Beiträge: 11
Registriert: 03.04.2008, 16:46

Beitragvon daniel2000 » 23.10.2012, 15:57

RAM teste ich morgen, kann es im laufenden Betrieb jetzt nicht herunterfahren.

Die Storage I/O's liegen im Durchschnitt bei 24ms

Max-Werte von 200ms.

Im Storage sind 5 x 2 TB SAS Platten verbaut. Raid 10 (verfügbar 4TB). Auf den 4TB sind dann Volumes mit je 2TB angelegt worden. (Datastore1 und Datastore2)

King of the Hill
Beiträge: 12253
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 23.10.2012, 20:36

~thc hat geschrieben:Ich vermute eher die Storage-I/O-Vorgänge. Werden im Ereignisprotokoll des ESX in den fraglichen Zeiträumen große Storage-Latenzen gemeldet?
Davon gehe ich ganz fest aus, ansonsten würde die CPU- und RAM-Auslastung nicht mit Grün bewertet sein.

Ein Raid10 aus nur 4 Platten erfüllt gerade mal die Mindestanforderungen an dieses Raid-Level, performant wird das bei so wenigen Spindeln also nie werden. Empfehlenswert ist daher die Aufrüstung auf mindestens die doppelte Spindelzahl oder die Migration auf ein anderes Raidlevel.
Bei 4 Platten plus Spare ist Raid5 schon okay. Datensicherheitstechnisch wäre ein Raid6 noch besser, allerdings bricht damit die Schreibrate noch weiter ein und das ist bei der Vollvirtualisierung ala VMware der Knackpunkt.

Member
Beiträge: 11
Registriert: 03.04.2008, 16:46

Beitragvon daniel2000 » 24.10.2012, 08:48

Das ändern des Arbeitsspeichers bei der XP-Maschine hat auch nicht geholfen.

Wenn in das Storage nun weitere 4 2 TB Platten eingebaut werden, steigert es die Perfomance erheblich?

Member
Beiträge: 490
Registriert: 26.05.2008, 15:52

Beitragvon deathrow » 24.10.2012, 10:05

5 x 2 TB SAS Platten


Sind das wirklich SAS mit 10/15k oder nearline SAS mit SATA innenleben und 7200rpm?

Jenseits von Gut & Böse
Beiträge: 11267
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Beitragvon irix » 24.10.2012, 11:01

deathrow hat geschrieben:
5 x 2 TB SAS Platten


Sind das wirklich SAS mit 10/15k oder nearline SAS mit SATA innenleben und 7200rpm?


Das sind Nearline SAS da es keine 2TB SAS mit >= 10k gibt.

Bei den traditionellen gehts im Moment bis 600GB 15K 3.5 oder aber 900GB 10K 2.5.

Gruss
Joerg

Member
Beiträge: 11
Registriert: 03.04.2008, 16:46

Beitragvon daniel2000 » 24.10.2012, 11:21

Auf den Platten steht SAS 2TB, 7.2K

King of the Hill
Beiträge: 12253
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 24.10.2012, 11:42

daniel2000 hat geschrieben:Auf den Platten steht SAS 2TB, 7.2K
Mit SATA@7200 sind nur zwischen 75 und 100 IOPS möglich. Mehr als diese IO-Leistung dürftest du auch mit NL-SAS nicht erreichen.
Es macht performancetechnisch schon viel Sinn, einfach kleinere Platten und dafür mehr Spindeln zu verbauen. ;)

Profi
Beiträge: 751
Registriert: 18.03.2005, 14:05
Wohnort: Ludwigshafen

Beitragvon Martin » 24.10.2012, 20:13

(irgendwie hatte ich vor meiner Antwort oben die Zeile "Speicher und CPU im grünen Bereich" übersehen :oops: )

King of the Hill
Beiträge: 12253
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 24.10.2012, 20:57

Martin hat geschrieben:(irgendwie hatte ich vor meiner Antwort oben die Zeile "Speicher und CPU im grünen Bereich" übersehen :oops: )
Macht nichts. ;)
Ich denke trotzdem, daß es eine Kombination von zuwenig pRAM im Host und nicht ausreichender IO-Leistung ist. Wenn dem Host der Speicher knapp wird, ergreift er vorher noch ein paar Möglichkeiten zur Linderung und lagert ggf dann doch vRAM aus. Durch das Swappen wird das gesamte System ausgebremst und die eh schon grenzwertige IO-Leistung zusätzlich beschnitten. Nicht vergessen sollte man auch, daß bei VM-Start auch eine VMEM-Datei in Grösse des vRAM auf die Platte geschrieben wird und im Falle der XP-VM sind das mal ebend 3GiByte.


Zurück zu „ESXi 4“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast