Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

vmware-view sagt "CredSSP: Initialize failed, do you ha

Deskopvirtualisierung und Anwendungsmanagement mit VMware Horizon.

Moderatoren: irix, Dayworker

Member
Beiträge: 1
Registriert: 14.01.2014, 09:35

vmware-view sagt "CredSSP: Initialize failed, do you ha

Beitragvon michaelbn » 14.01.2014, 23:03

Hallo Formums-Teilnehmer,
ich hoffe auf eure Hilfe:Seit der Umstellung von opensuse 12.3 auf 13.1 geht vmware-view nicht mehr; installiert ist VMware-open-view-client in Version 4.5.0-297975.

Die Log-Datei sagt mir am Ende:

Jan 10 09:02:12.942: vmware-view| Relative or system path
/usr/bin/vmware-view-usb does not exist.
Jan 10 09:02:12.942: vmware-view| /usr/bin/vmware-view-usb wurde nicht
gefunden; USB-Umleitung wird deaktiviert.
Jan 10 09:02:12.942: vmware-view| Connecting to desktop
CN=Win7,OU=Applications,DC=vdi,DC=vmware,DC=int:
RDP://username@127.0.0.1:53106
Jan 10 09:02:12.943: vmware-view| Starting child: rdesktop '-z' '-K'
'-g' '1680x1050' '-X' 'Zahlen' '-u' 'username' '-d' 'domainname' '-p'
'-' '-a' '24' '-r' 'sound:local' '127.0.0.1:53106'
Jan 10 09:02:12.947: vmware-view| rdesktop(3830): Autoselected keyboard
map de
Jan 10 09:02:13.179: vmware-view| rdesktop(3830): ERROR: CredSSP:
Initialize failed, do you have correct kerberos tgt initialized ?
Jan 10 09:02:13.180: vmware-view| rdesktop(3830): ERROR: 127.0.0.1:
unable to connect
Jan 10 09:02:13.181: vmware-view| rdesktop(3830) died.
Jan 10 09:02:13.182: vmware-view| rdesktop(3830) exited with status: 76
Jan 10 09:02:13.182: vmware-view| Cancelling 0 broker XML requests.
Jan 10 09:02:21.690: vmware-view| User cancelled.
Jan 10 09:02:21.690: vmware-view| Busy: Desktops werden geladen...
Jan 10 09:02:21.690: vmware-view| Number of monitors on this screen is 1.
Jan 10 09:02:21.691: vmware-view| Current window manager supports
_NET_WM_FULLSCREEN_MONITORS message.

Meine (unfachmännische) Vermutung ist, dass es an
ERROR: CredSSP: Initialize failed, do you have correct kerberos tgt
initialized ? liegt.
Ich habe daraufhin nachgeschaut und habe krb5, krb5-32bit, sowie yast2-kerberos-client installiert gefunden.
Fehlt da was?
DuckDuckgo gibt mir nur wenige Einträge zurück, die mir aber wenig sagen.

Kann mir jemand einen Tipp geben? Vielen Dank!

Gruß,
Michael

Member
Beiträge: 3
Registriert: 19.02.2015, 20:03

Beitragvon rossi242 » 19.02.2015, 20:18

Hallo,
ich habe genau das gleiche Problem. Vorher mit opensus 12.3 ging alles, nach dem Update auf 13.2 kriege ich auch den o.g. Kerberos Fehler. Mein Admin hat mir daraufhin einen experimentellen Windows 8.1 Desktop freigegeben und dieser funktioniert dank PCoIP wunderbar. Naja - bis auf das Windows 8.1 das ist natürlich nicht wunderbar.
Der Windows 7 Desktop ist leider nur per RDP erreichbar und da kommt es zu besagtem Problem.
Ich habe diese Kerberos-Pakete installiert:

rpm -qa|grep krb
krb5-server-1.12.2-6.1.x86_64
krb5-1.12.2-6.1.x86_64
krb5-plugin-kdb-ldap-1.12.2-6.1.x86_64
krb5-appl-clients-1.0.3-10.1.2.x86_64
krb5-32bit-1.12.2-6.1.x86_64
krb5-client-1.12.2-6.1.x86_64
krb5-appl-servers-1.0.3-10.1.2.x86_64
libndr-krb5pac0-4.1.12-2.1.x86_64
pam_krb5-2.4.4-5.1.3.x86_64
krb5-plugin-preauth-otp-1.12.2-6.1.x86_64
sssd-krb5-common-1.12.2-3.4.1.x86_64
libndr-krb5pac0-32bit-4.1.12-2.1.x86_64
pam_krb5-32bit-2.4.4-5.1.3.x86_64
krb5-auth-dialog-3.12.0-2.1.11.x86_64
krb5-plugin-preauth-pkinit-1.12.2-6.1.x86_64
krb5-auth-dialog-lang-3.12.0-2.1.11.noarch
sssd-krb5-1.12.2-3.4.1.x86_64

Guru
Beiträge: 2645
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 20.02.2015, 08:09

Die Authentifizierung per krb/CredSSP funktioniert nicht und der Fallback auf SSL/TLS funktioniert nicht (möglicherweise ein Bug in rdesktop). Workaround: Benutzername und Passwort beim Aufruf von rdesktop weglassen.

Member
Beiträge: 3
Registriert: 19.02.2015, 20:03

Beitragvon rossi242 » 20.02.2015, 11:02

Wie mache ich das? Im horizon client verbinde ich mich im ersten Schritt mit dem VMWare Server per https - da muss ich Bneutzername und PW angeben. Danach kriege ich die möglichen Desktopverbindungen angezeigt. Hier habe ich aber keinerlei Option das PW wegzulassen und der horizon client schickt automatisch meine vorher eingegebenen credentials mit.

Guru
Beiträge: 2645
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 20.02.2015, 11:34

Ja, so etwas hatte ich schon befürchtet.

Das Problem ist scheinbar der neue "rdesktop", der den nicht sauber konfigurierten kerberos-Server nicht mehr großzügig übersieht.

A - Schau im Log des View Clients nach der Kommandozeile für rdesktop und versuche, diese manuell auszuführen, um mehr über den Fehler zu erfahren

B - Vielleicht lässt sich der Kerberos-Server so konfigurieren, dass rdesktop zufrieden ist.

C - Versuche, einen PCoIP-Client unter openSUSE 13 zum laufen zu bringen

D - Versuche einen anderen View-Client

Member
Beiträge: 3
Registriert: 19.02.2015, 20:03

Beitragvon rossi242 » 25.02.2015, 15:34

~thc hat geschrieben:Das Problem ist scheinbar der neue "rdesktop", der den nicht sauber konfigurierten kerberos-Server nicht mehr großzügig übersieht.

D - Versuche einen anderen View-Client


Das war ein guter Hinweis. Ich hab einfach das 12.3 OSS Repo hinzugefügt und die Version 1.7.1-5.1.1-x86_64 aus diesem Repo installiert und damit funktioniert alles wie gewohnt - auch mit em neuen Horizon Client.

Danke!


Zurück zu „View / Horizon View“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast