Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

View Connection Server - SSL-Zertifikat

Deskopvirtualisierung und Anwendungsmanagement mit VMware Horizon.

Moderatoren: irix, Dayworker

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

View Connection Server - SSL-Zertifikat

Beitragvon cotec » 23.10.2012, 11:50

Hallo,

ich habe gerade einen fertiginstallierten View-Server übergeben bekommen und soll mich um die noch anstehenden Probleme kümmern.
z.B. bekomme ich schon nach dem einloggen im View-Administrator folgende Fehlermeldung:
Bild

Nun, das selbstsignierte Zertifikat habe ich via IE -> Zertifikat in Datei kopieren -> und certmgr-Import bereits installiert und befindet sich nun unter "Vertrauenswürdige Stammzertifizierungsstellen" und "Eigene Zertifikate".
Ich habe in dem Netz keinen Zertifikatsserver, weshalb für mich nur die Option bleibt selbstdignierte zu nutzen.

Warum sollte das Zertifikat nicht von den Clients genutzt werden dürfen?
Der Klick auf den Button "Weitere Optionen" linkt mich auf => http://pubs.vmware.com/view-51/index.js ... 080B4.html

was mir aber nicht sehr weiterhilft. Auch so finden sich etliche Seiten im Netz die den Zertifikatsimport zeigen, allerdings immer in Verbindung mit der Nutzung eines Zertifikatsservers. :(
Ist der denn zwingend erforderlich? need help...

Gruß,
~cotec


edit: eine Seite die es gut beschreibt, allerdings wieder mit Zertikatsserver: http://fojta.wordpress.com/2012/05/27/v ... placement/ :roll:

Guru
Beiträge: 2636
Registriert: 23.02.2012, 12:26

Re: View Connection Server - SSL-Zertifikat

Beitragvon ~thc » 23.10.2012, 12:36

cotec hat geschrieben:Nun, das selbstsignierte Zertifikat habe ich via IE -> Zertifikat in Datei kopieren -> und certmgr-Import bereits installiert und befindet sich nun unter "Vertrauenswürdige Stammzertifizierungsstellen" und "Eigene Zertifikate".
Ich habe in dem Netz keinen Zertifikatsserver, weshalb für mich nur die Option bleibt selbstdignierte zu nutzen.


Der Teufel steckt im (Windows-)Detail: Importiere das Zertifikat im certmgr.msc als Administrator.

[Wenn ich Recht habe, dann vertraust du (als angemeldeter Benutzer) zwar dem Zertifikat, aber nicht das Konto, unter dem der meckernde Dienst läuft.]

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

Re: View Connection Server - SSL-Zertifikat

Beitragvon cotec » 23.10.2012, 13:03

~thc hat geschrieben:Der Teufel steckt im (Windows-)Detail: Importiere das Zertifikat im certmgr.msc als Administrator.

[Wenn ich Recht habe, dann vertraust du (als angemeldeter Benutzer) zwar dem Zertifikat, aber nicht das Konto, unter dem der meckernde Dienst läuft.]


Hab mir eine Verknüpfung auf dem Desktop erstellt, mit Administratorrechten geöffnet, Zertifikat gelöscht, erneut importiert. View-Dienste neugestartet, Problem besteht weiterhin... :(

Member
Beiträge: 176
Registriert: 13.09.2010, 17:22

Beitragvon soehl » 23.10.2012, 14:16

Das Problem besteht darin, das der Nutzer (Standard ist SYSTEM) unter dem die View Dienste laufen nicht dem Zertifikat "vertraut".
Ich bin leider unterwegs, so das ich dir nur grob skizzieren kann wie es geht:

- mmc starten
- Datei -> Snap-In hinzufügen / entfernen
- Snap-In Zertifikate hinzufügen für Computerkonto des lokalen Computers
- Zertifikat importieren.

Guru
Beiträge: 2636
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 23.10.2012, 14:56

yup. soehl hat Recht - und die mmc als Administrator starten.

Benutzeravatar
Member
Beiträge: 131
Registriert: 12.01.2012, 08:18

Beitragvon cotec » 25.10.2012, 10:36

okay, in welche Gruppen genau muss das Zertifikat denn importiert werden?
Eigentlich reicht doch "Vertrauenswürdige Stammzertifizierungsstellen" oder?

Guru
Beiträge: 2636
Registriert: 23.02.2012, 12:26

Beitragvon ~thc » 25.10.2012, 12:02

Ja.

Member
Beiträge: 127
Registriert: 22.07.2010, 20:17
Wohnort: Bonn

Beitragvon blackwindow » 07.02.2013, 14:23

das Importieren des Zertifikats für View voraussetzt IIS (Ohne Webserver, den Haken rausnehmen) da muss man das Zertifikat hinzufügen. Normalerweise bekommt man eine ausführliche Anleitung, wenn man ein CA bestellt.
Der Rest steht hier
http://pubs.vmware.com/view-50/index.js ... DB4FE.html

okay, in welche Gruppen genau muss das Zertifikat denn importiert werden?
Eigentlich reicht doch "Vertrauenswürdige Stammzertifizierungsstellen" oder?


Automatisch auswählen, CA landet dahin wo er sein muss! Zumindest hat bei uns A1 funktioniert.

Und nicht vergessenm IIS Dienste neuzustarten!

Member
Beiträge: 176
Registriert: 13.09.2010, 17:22

Beitragvon soehl » 07.02.2013, 15:40

IIS und View?! Da scheinst du etwas zu verwechseln, auf dem Connection Server wird kein IIS benötigt.

Member
Beiträge: 127
Registriert: 22.07.2010, 20:17
Wohnort: Bonn

Beitragvon blackwindow » 07.02.2013, 18:41

natürlich nicht auf dem Connection Server.. es kann ein anderer Server sein, weil CA Manager für die Importireung des Zertifikats in diesem Fall nicht ausreichend ist

Member
Beiträge: 176
Registriert: 13.09.2010, 17:22

Beitragvon soehl » 07.02.2013, 19:45

Da komme ich ehrlich gesagt nicht hinterher. 8)

Benutzeravatar
Guru
Beiträge: 3135
Registriert: 22.02.2008, 20:01
Wohnort: Hessen

Beitragvon PeterDA » 08.02.2013, 11:35

Hi,
ich häng mich mal hier rein:

Also was du machen musst ist zum einen im View Administrator das Zertifikat als vertrauenswürdig einzustufen. Hierzu in der Seite des Screenshots auf "Zusätzliche Optionen" Klicken dort kannst du dass dann machen. Danach sollte dieser Fehler auch weg sein.

Dann hast du das Problem, dass die View Clients das Zertifikat nicht kennen was bei View 5.1 dazu führen kann, dass du keine Verbindung aufbauen kannst. Hier einfach das Zertifikat auf den Clients bekannt machen. Hier gibts je nach Clients x Möglichkeiten. Für Win empfiehlt es sich das Zertifikat einfach in die GPOs zu packen.

Gruß Peter


Zurück zu „View / Horizon View“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast