Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

Probleme mit View Composer nach vCenter Absturz

Deskopvirtualisierung und Anwendungsmanagement mit VMware Horizon.

Moderatoren: irix, Dayworker

Member
Beiträge: 485
Registriert: 13.01.2005, 13:29
Wohnort: CH

Probleme mit View Composer nach vCenter Absturz

Beitragvon riddley » 14.10.2010, 17:15

Hallo Zusammen

Ich bins wiedermal, bei mein "Lieblingskunde" wohnt leider Murphy und dort geschieht mit View ein Fehler nach dem anderen :(

Folgendes:

- letzte Nacht ist der vCenter Service irgendwie abgestürtzt und liess sich nicht mehr starten.
- da niemand arbeiten konnte, entschied ich mich, das Backup vom vCenter Server mittels Data Recovery zurück zu spielen
- vCenter läuft wieder und die Leute können arbeiten, ABER
- Wenn ich im View Administrator bei meinem Desktop Pool auf "Edit" klicke kommt folgende Fehlermeldung: "Invalid value for parameter dgId passed to View Composer function"

Infos zur Umbegung:
View Composer 2.5, View 4.5, View Agent 4.5, vCenter 4.1.

Hat dies eveentuel bereits jemand gehabt oder eine Idee an was es hier liegen könnte?

Danke & Gruss
Stefan

Member
Beiträge: 176
Registriert: 13.09.2010, 17:22

Beitragvon soehl » 14.10.2010, 21:44

Du bist aber echt hart dran mit der Umgebung. :shock:

Ich vermute das eine Inkonsistenz zwischen dem ADAM des Brokers, der DB vom Composer und des vCenters vorliegt. Also der Klassiker schlechthin bei View.
Eigentlich macht der Connection Server jede Nacht um 24 Uhr ein Backup des ADAMs, hast du vielleicht ein Backup der vCenter- und der Composer-DB aus in etwa der gleich Zeit?


Hast du eine Event-DB angelegt?! Vielleicht steht da noch etwas mehr drin, ein weiterer guter Anhaltspunkt ist das SVI-Log vom Composer auf dem vCenter und natürlich das Anwendungslogs in der Ereignisnazeige auf dem Connection Server.
Da müsste ja eigentlich alles voller Fehler sein.

Member
Beiträge: 485
Registriert: 13.01.2005, 13:29
Wohnort: CH

Beitragvon riddley » 15.10.2010, 09:10

Dort arbeitet leider wirklich Murphy, dort will View einfach nicht laufen :(

Die Composer und die vCenter DB liegen beide auf dem vCenter SQL Server, somit sollten die DBs den gleichen Stand haben wenn ich den Restore zurück hole (was ich gemacht habe).

Könnte es etwas nützen, wenn ich das vCenter und den View Connection Server vom VDR Backup zurück hole, damit diese wieder den etwa gleichen Stand haben? Ich habe nur das vCenter zurück geholt und der Connection Server nicht, der lief ja noch.

Event DB habe ich leider noch nicht eingerichtet, das wäre mein nächster Task gewesen (wie gesagt, Murphy :-) )

Member
Beiträge: 176
Registriert: 13.09.2010, 17:22

Beitragvon soehl » 15.10.2010, 10:39

Ja wenn dann alle Server den (fast) gleichen Zeitstand haben besteht die Chance, das du die Umgebung wieder zum Laufen bekommst.
Wie schon gesagt, ein Adam-Backup von 0Uhr findest du unter %ALLUSERSPROFILE%\Application Data\ bzw. Anwendungsdaten\VMware\VDM\backups
vielleicht geht das schneller als den ganzen Connectiosnerver zurückzuspielen.


Zurück zu „View / Horizon View“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste