Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

[Solved] vCenter nicht kompatibel mit Composer

Deskopvirtualisierung und Anwendungsmanagement mit VMware Horizon.

Moderatoren: irix, Dayworker

Member
Beiträge: 319
Registriert: 26.04.2009, 15:59
Wohnort: Laatzen

[Solved] vCenter nicht kompatibel mit Composer

Beitragvon PatrickW » 04.12.2009, 09:20

Moin,

ich habe gerade auf einem vSphere 4 U1 vCenter den View Composer installiert.

Im Anschluss habe ich versucht das vCenter dem View Connection Server hinzuzufügen. Klicke ich dort den Button auf "Check for View Composer Compatibility", erhalte ich die Fehlermeldung "This version of Virtual Center Server does not support View Composer."

Hat jemand von euch das Problem schon gehabt und evtl. gelöst?

MfG Patrick

Member
Beiträge: 319
Registriert: 26.04.2009, 15:59
Wohnort: Laatzen

Beitragvon PatrickW » 04.12.2009, 14:11

So ich konnte das Problem eingrenzen, es hat mit dem sdk auf dem vCenter zu tun.

Code: Alles auswählen

Connection to the Virtual Center Server https://172.25.1.16:443/sdk failed.


Hat jemand eine Idee wie ich das SDK aktiviere?

King of the Hill
Beiträge: 13486
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Beitragvon Dayworker » 04.12.2009, 15:48

Er probiert den installierten Webserver anzusprechen. Schau doch mal nach, was er hinter der Addy "https://172.25.1.16:443/sdk" normalerweise erwartet. Ich nehm mal an, daß dort eine XML-Datei oä liegt und dessen Inhalt abgefragt bzw verarbeitet wird.

Member
Beiträge: 319
Registriert: 26.04.2009, 15:59
Wohnort: Laatzen

Beitragvon PatrickW » 07.12.2009, 12:26

Wie würdest du den danach suchen?

Ich habe probiert den Ordner mit der Webseite auf dem VC zufinden, aber leider hat das nicht funkioniert.

Member
Beiträge: 319
Registriert: 26.04.2009, 15:59
Wohnort: Laatzen

Beitragvon PatrickW » 07.12.2009, 13:00

So ich habe gerade festgestellt, das anscheind der Composer Dienst ein Problem hat.

Diesen Eintrag findet man im Eventlog:

Code: Alles auswählen

Ereignistyp:   Fehler
Ereignisquelle:   VMware View Composer Service
Ereigniskategorie:   Keine
Ereigniskennung:   0
Datum:      07.12.2009
Zeit:      12:48:58
Benutzer:      Nicht zutreffend
Computer:   VCENTER
Beschreibung:
Failed to perform VMware View Composer module initialization.
VMware.Sim.CommonLib.Exception.InvalidParameterException: Key container with name SviKeyContainer does not exist.

Server stack trace:
   bei VMware.Sim.CommonLib.Crypto.RSACrypto.Init(String keyContainer)
   bei VMware.Sim.WebService.SimServer.Init()
   bei VMware.Sim.WebService.SimServer.<SimStart>b__0()
   bei System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
   bei System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
   bei System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:
   bei System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
   bei System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
   bei VMware.Sim.WebService.SimServer.WorkerFunction.EndInvoke(IAsyncResult result)
   bei VMware.Sim.WebService.SimServer.SimStart(String[] args)
   bei VMware.Sim.WebService.SimServer.OnStart(String[] args), Machine Name: VCENTER, Timestamp: 07.12.2009 11:48:58, App Domain Name: SviWebService.exe, Thread Identity: , Windows Identity: SYSINT\view, OS Version: Microsoft Windows NT 5.2.3790 Service Pack 2, reason: DoesNotExist, param: keyContainer


Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

Member
Beiträge: 319
Registriert: 26.04.2009, 15:59
Wohnort: Laatzen

Beitragvon PatrickW » 07.12.2009, 14:50

So Problem gelöst, der Composer Dienst benötigt anscheinend Domänenadminrechte um zulaufen, und wenn man nicht für alle Sachen wo man einen User angeben muss, den selben angibt, verursacht das auch Probleme.


Zurück zu „View / Horizon View“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast