Die Foren-SW läuft ohne erkennbare Probleme. Sollte doch etwas nicht funktionieren, bitte gerne hier jederzeit melden und wir kümmern uns zeitnah darum. Danke!

ISO nicht bootbar

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player und VMware Workstation Player.

Moderatoren: irix, continuum, Dayworker

Member
Beiträge: 6
Registriert: 05.06.2020, 17:57

ISO nicht bootbar

Beitragvon Sherlock » 05.06.2020, 18:16

Hallo,

in Version 15.5.5 build-16285975 lässt sich das ISO von Win 10 2004 nicht mehr booten.
Solange Win 10 noch nicht installiert ist, wird es ja automatisch gebootet, das klappt und man kann installieren.
Wenn ich nach erfolgter Installation allerdings beim Start mit "esc" das Menü aufrufe, CDROM markiere und Enter drücke, startet zwar die CD, aber die Meldung "Press any key" reagiert auf keinen Key, man landet also wieder im Menü.
Mit 15.5.2 und allen anderen Versionen hat es noch normal funktioniert. Ist das ein bekanntes Problem?

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: ISO nicht bootbar

Beitragvon Dayworker » 05.06.2020, 21:22

Win10-2004 ist gerade mal ein paar Tage alt und VMware braucht immer etwas Zeit, um die notwendigen Anpassungen vorzunehmen. Ich habe jetzt nicht geschaut, ob diese Win-Version überhaupt schon als Gast supportet ist. Ist sie es?


Mich würde nebenbei auch interessieren, weshalb man nach erfolgter Inst nochmal die CD einlegt?
Windows10 zieht die Sicherheit mit jeder neuen Win-Version an. Bei mit Win10 ausgelieferten Geräten kommt man ja nicht mal mehr einfach so ins BIOS/UEFI rein, selbst dafür sind Verrenkungen notwendig. Es würde mich also nicht sonderlich wundern, wenn das - so wie von dir beschrieben - überhaupt nicht mehr funktioniert.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: ISO nicht bootbar

Beitragvon ~thc » 05.06.2020, 21:34

Ich kann das von Sherlock beschriebene Phänomen bestätigen - der Fehler zieht aber weitere Kreise:

- Das aktuelle 2004 ist nicht relevant (Mit Windows 10 1909 geht es ebenso wenig)
- Wenn man der VM nach dem "Easy Install" und vor dem Booten die Floppy wieder wegnimmt
- Wenn man das OS später selbst installieren möchte

Im Moment scheint die UEFI-Firmware des Players 15.5.5 nur "Easy Install" zu können.

Einziger mir bekannter Workaround: In der VMX-Datei der VM die Zeile

Code: Alles auswählen

firmware = "efi"

löschen. Im alten BIOS-Modus funktioniert alles.

Member
Beiträge: 6
Registriert: 05.06.2020, 17:57

Re: ISO nicht bootbar

Beitragvon Sherlock » 05.06.2020, 22:58

Win10-2004 ist gerade mal ein paar Tage alt und VMware braucht immer etwas Zeit, um die notwendigen Anpassungen vorzunehmen. Ich habe jetzt nicht geschaut, ob diese Win-Version überhaupt schon als Gast supportet ist. Ist sie es?


Ja. 15.5.5 ist ja nun kompatibel mit Hyper-V und Win 10 2004 wird dafür benötigt und ist offiziell unterstützt.

Mich würde nebenbei auch interessieren, weshalb man nach erfolgter Inst nochmal die CD einlegt?


Es war Win 10 1909 installiert, also wollte ich das ISO von 2004 booten, um damit 1909 zu löschen und 2004 neu zu installieren. Ich hab's dann so gemacht: in 1909 nach Win RE gebootet und von dort direkt auf das ISO zugegriffen, ohne es booten zu müssen. Die auf der Disk von 1909 installierte 2004 war allerdings unbrauchbar, war mit dieser VM nicht kompatibel. Es ging nur in einer neuen, von 15.5.5 erstellten VM, in der übrigens nun der Disk-Typ NVMe Standard ist. Der lässt sich in der alten VM gar nicht auswählen. Allerdings gibt's da halt das Problem mit späteren Bootversuchen des ISOs.

Windows10 zieht die Sicherheit mit jeder neuen Win-Version an. Bei mit Win10 ausgelieferten Geräten kommt man ja nicht mal mehr einfach so ins BIOS/UEFI rein, selbst dafür sind Verrenkungen notwendig.


Ins BIOS muss man immer kommen, egal, ob ein OS installiert ist oder nicht. Falls nicht, hat man Schrott erworben. Da ich anscheinend nicht der einzige User mit diesem Problem bin, gehe ich mal davon aus, dass der ISO-Boot mit einem künftigen Update behoben wird. Wenn man Windows so einstellt, dass man beim Booten immer auch WIN PE angeboten bekommt, braucht man Win PE über ISO-Boot im Grunde auch nicht mehr.

@~thc
Ja, du hast Recht, im BIOS-Modus klappt das Booten des ISOs, dummerweise brauche ich beide Versionen, BIOS und UEFI. ;-)

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: ISO nicht bootbar

Beitragvon ~thc » 05.06.2020, 23:15

Nach ein paar mehr Tests:

- Betroffen sind alle Windows 10 Versionen ab 1703
- Nicht betroffen sind Windows 10 1607 und Windows Server 2016
- Nicht betroffen sind alle OS, bei denen der Player in den VMs EFI nicht aktiviert (Ubuntu, Win 8, Win7 etc.)

EDIT to ADD:

- Eine betroffene VM ist trotzdem mit anderen EFI-ISOs (Arch, Ubuntu etc.) bootbar.
- Man darf den "Easy Install"-Prozess nicht unterbrechen: Ein Entfernen des Floppy-Laufwerks oder ein späterer Start funktionieren nicht.
- Workaround (Non-Easy-Install): Easy Install durch Power-Off nach dem Erscheinen des Bootlogos abbrechen und das Floppy-Image löschen. Erst nach dem First-Stage-Setup die VM bearbeiten.

Member
Beiträge: 6
Registriert: 05.06.2020, 17:57

Re: ISO nicht bootbar

Beitragvon Sherlock » 06.06.2020, 13:27

Nach ein paar mehr Tests:


Mhm, ganz interessant. Ich habe den Windows-BCD jetzt so eingestellt, dass er beim Booten sowohl Win 10 als auch Win PE vorschlägt. Somit habe ich immer Zugriff auf Win PE von Win 10 oder auf das ISO, ohne es direkt booten zu müssen. Kann also offline Reparaturen machen oder auch neu installieren.

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: ISO nicht bootbar

Beitragvon Dayworker » 06.06.2020, 14:04

Sherlock hat geschrieben:Ins BIOS muss man immer kommen, egal, ob ein OS installiert ist oder nicht. Falls nicht, hat man Schrott erworben.
Falsch, ist "Quick Boot" oder "Fast Boot" aktiviert, kommst du aus Sicherheitsgründen halt nicht so einfach ins UEFI/BIOS rein. Sollte eigentlich auch logisch sein, weil man dann den lokalen Datenträger einfach per Live-CD auslesen könnte...



An diesem Punkt seid ihr jetzt eventuell auch angekommen. Jedenfalls sehen eure Probleme für mich so halbwegs danach aus. Eventuell hilft es ja einen zusätzlichen Boot-Eintrag für WinRE im UEFI anzulegen.

Member
Beiträge: 6
Registriert: 05.06.2020, 17:57

Re: ISO nicht bootbar

Beitragvon Sherlock » 06.06.2020, 15:23

Falsch, ist "Quick Boot" oder "Fast Boot" aktiviert, kommst du aus Sicherheitsgründen halt nicht so einfach ins UEFI/BIOS rein.


Ich schrieb "in BIOS muss man immer kommen", das ist nicht falsch. Den hirnrissigen Windows-Schnellstart sollte man auf jeden Fall sofort deaktivieren, denn er bringt etliche Probleme mit sich. Eine irre Schnapsidee von Microsoft. Falls nicht in Windows, sondern im BIOS sonstige Schnellstart-Optionen aktiviert sind, muss man trotzdem in BIOS kommen können. Wie einfach das geht, ist wurscht, irgendwie muss es gehen. ;-)

Sollte eigentlich auch logisch sein, weil man dann den lokalen Datenträger einfach per Live-CD auslesen könnte...


Wer physischen Zugriff auf das Gerät hat, kann das eh immer, sofern die Daten nicht verschlüsselt sind.

An diesem Punkt seid ihr jetzt eventuell auch angekommen. Jedenfalls sehen eure Probleme für mich so halbwegs danach aus. Eventuell hilft es ja einen zusätzlichen Boot-Eintrag für WinRE im UEFI anzulegen.


Wie schon gesagt, den Eintrag legt man im Windows-BCD an, er ist dann sowohl in UEFI- als auch in BIOS-Installationen gleichermaßen wirksam. Man kommt dann beim Booten der VM an das ISO ran, ohne es direkt booten zu müssen.

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: ISO nicht bootbar

Beitragvon JustMe » 06.06.2020, 20:33

Das Problem ist ja nicht, dass man nicht in's BIOS (oder in diesem Fall "EFI") kaeme. Das funktioniert sehr wohl.
Die VM bootet auch einwandfrei von der Windows-ISO (die Ausgabe "Press any key to boot from CD or DVD" mit den sechs Punkten kommt ja gerade von dort).

Das Problem ist, dass keinerlei Tastendruecke vom Windows-Bootprozess akteptiert werden, und deswegen eben nicht WEITER von der Installations-CD gebootet wird.

Deswegen funktioniert auch der Easy Install mit seiner Antwortdatei, wo eben keine Tastendruecke benoetigt werden, und offenbar spaeter ein verwendbarer Tastaturtreiber geladen wird.

Experte
Beiträge: 1664
Registriert: 04.10.2011, 14:06

Re: ISO nicht bootbar

Beitragvon JustMe » 06.06.2020, 21:17

Kleiner Nachtrag:

- Beim Start der VM in das EFI Boot Menu gehen per Taste Esc
- Im Boot Menu die EFI CD auswaehlen (egal, ob man SATA, SCSI oder IDE konfiguriert hat)
- Per Taste <Enter> die Auswahl starten
- Die Taste <Enter> NICHT loslassen
- Der erste Bootversuch schlaegt fehl (die sechs Punkte erscheinen)
- Der naechste Bootversuch startet das Windows Setup

Seen it, done it.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: ISO nicht bootbar

Beitragvon ~thc » 07.06.2020, 08:36

JustMe hat geschrieben:- Beim Start der VM in das EFI Boot Menu gehen per Taste Esc
- Im Boot Menu die EFI CD auswaehlen (egal, ob man SATA, SCSI oder IDE konfiguriert hat)
- Per Taste <Enter> die Auswahl starten
- Die Taste <Enter> NICHT loslassen
- Der erste Bootversuch schlaegt fehl (die sechs Punkte erscheinen)
- Der naechste Bootversuch startet das Windows Setup

Thx - funktioniert auch für VMs mit leerer Festplatte ("I will install the OS later").

Member
Beiträge: 6
Registriert: 05.06.2020, 17:57

Re: ISO nicht bootbar

Beitragvon Sherlock » 09.06.2020, 20:22

Das Problem ist ja nicht, dass man nicht in's BIOS (oder in diesem Fall "EFI") kaeme. Das funktioniert sehr wohl.
Die VM bootet auch einwandfrei von der Windows-ISO (die Ausgabe "Press any key to boot from CD or DVD" mit den sechs Punkten kommt ja gerade von dort).


Eben. Messerscharf erkannt.

[Enter-Trick]

In der Tat, wenn man die Enter-Taste einfach gedrückt hält, klappt es bei Folgeversuchen. Danke für den Tipp.

King of the Hill
Beiträge: 13000
Registriert: 01.10.2008, 12:54
Wohnort: laut USV-Log am Ende der Welt...

Re: ISO nicht bootbar

Beitragvon Dayworker » 10.06.2020, 18:34

Es gibt inzwischen die Version 15.5.6 und in dieser sollen Keyboard/Mouse/Sound-Probleme beseitigt worden sein. Vielleicht ist das eine einfachere Lösung für dieses Problem.

Guru
Beiträge: 2305
Registriert: 23.02.2012, 12:26

Re: ISO nicht bootbar

Beitragvon ~thc » 11.06.2020, 08:24

Das Update auf 15.5.6 behebt das Problem mit der "nicht erkannten" gedrückten Taste beim Booten von Windows 10-DVDs.

Nicht behoben wurde, dass eine (Nicht-Easy-Install) Win10-VM nicht automatisch von der DVD bootet.

Member
Beiträge: 6
Registriert: 05.06.2020, 17:57

Re: ISO nicht bootbar

Beitragvon Sherlock » 11.06.2020, 14:16

Dito, auch hier ist der ISO-Boot nun wieder OK.


Zurück zu „VMware Player und VMware Workstation Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast